1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Subdomains

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Webroy, Jul 15, 2009.

  1. Webroy

    Webroy Regular Pleskian

    26
    23%
    Joined:
    Oct 29, 2008
    Messages:
    156
    Likes Received:
    0
    I dont know if i am correct here but here is my problem

    I have got a domainname where i put in a catch all like this:

    Created a vhost.conf put in ServerAlias *.domainname.nl

    This works fine because alle pages are going to the mainpage....

    Except 1 page 1 want to work is also going to the mainpage: webmail....

    Is there something where i can exclude the webmail from the wildcard so i can still use that?
     
  2. GeoffreyK

    GeoffreyK Guest

    0
     
    Hello,

    I've a same problem.
    Thanks.
     
  3. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    Yeah, this is a very unpleasant change when upgrading to Plesk 9. Suddenly all domains that use webmail and have ServerAlias *.example.com setup cannot use webmail on their domain anymore. I guess the problem is that the Horde Apache configuration is loaded after the domain's Apache configuration (see the files in /etc/httpd/conf.d/).
     
  4. tusm

    tusm Guest

    0
     
    me too

    Hello,

    any update about this problem????

    1 year after last post and have same issue


    regards
     
  5. tusm

    tusm Guest

    0
     
    I have a solution but I don't know how many time will be working. Because I have changed /etc/httpd/conf.d/zzz_horde_vhost.conf and I don't know how plesk updates affect this file change.

    simply change:

    ServerName horde.webmail
    ServerAlias horde.webmail.*


    with:
    ServerName webmail
    ServerAlias webmail.*


    both <VirtualHost xxx.xxx.xxx.xxx:80> and <VirtualHost xxx.xxx.xxx.xxx:443>


    It works for me

    regards
     
Loading...