1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Subscription only work for 1st Customer Only

Discussion in 'Plesk Automation' started by DondyB, Jan 26, 2013.

  1. DondyB

    DondyB Basic Pleskian

    12
    35%
    Joined:
    Jan 21, 2013
    Messages:
    26
    Likes Received:
    0
    Hi,

    I've setup PPA with Backnet and FrontNet architecture using eth0 as FrontNet and Eth1 as Backnet. The public IP is on FrontNet and the communication IP is on Backnet (with Private IP).

    So, all the service node are setup correctly and ready to provide.

    Now here's the problem, for first customer, I can create subscriptions and the PPA will provision the service beautifully, however, when I create another customer (call it second or third customer), whenever I add the subscription for it, from the task manager PPA will failed to process that subscription.

    The error message is this "Method name
    createSubscriptionSkeleton on SCREF:pleskIntegration:0
    Last execution output
    Unable to create hosting. Ip address does not exist in client's pool"

    Any advise ?

    Regards,

    Dondy
     
  2. Andrey Dobrenko

    Andrey Dobrenko Regular Pleskian

    26
     
    Joined:
    Jun 26, 2007
    Messages:
    256
    Likes Received:
    0
    Hi DondyB,

    Probably, you try to create a subscription using dedicated IP addresses for it, but you cannot define IP pool. I'd recommend to read this doc at first to figure out how can configure IP pool.

    Best Regards,
    Andrey
     
  3. DondyB

    DondyB Basic Pleskian

    12
    35%
    Joined:
    Jan 21, 2013
    Messages:
    26
    Likes Received:
    0
    Hi Andrey,

    Actually I didn't create subscription with dedicated IP. It's just a simple DNS subscription.
    However, I go ahead by adding more IP to the pool but the result is still the same :(

    Regards,

    Dondy
     
  4. Andrey Dobrenko

    Andrey Dobrenko Regular Pleskian

    26
     
    Joined:
    Jun 26, 2007
    Messages:
    256
    Likes Received:
    0
    Ah. OK. The feature to have a subscription with DNS hosting only is not available yet in PPA. We have a task in our backlog and will do it later. Thanks!
     
  5. DondyB

    DondyB Basic Pleskian

    12
    35%
    Joined:
    Jan 21, 2013
    Messages:
    26
    Likes Received:
    0
    Hi Andrey,

    Even if I create subscription with other service than DNS (the Linux Hosting) it's still failing on the same place which is Create the blank subscription #xx in the Hosting Panel. The error is the same like what I reported

    Regards,

    Dondy
     
  6. Andrey Dobrenko

    Andrey Dobrenko Regular Pleskian

    26
     
    Joined:
    Jun 26, 2007
    Messages:
    256
    Likes Received:
    0
    HI DondyB,

    Let's work out your issues. At first, i need to know additional information. Not just the final error/

    1) The first question - who is actor? Reseller or Administrator. I guess, you try to create subscirption under reseller
    2) What service tempalate do you use? You create its service plan or use predefined from PPA?
    3) Please put here limits of resource types defined in service template. Just go to Products -> Service tempaltes -> <Tempalte> -> Resources and here you can see limits for each resource type.

    Guys, please provide more information when you report some problem in PPA in order I be able to help you. Thank you!

    Best Regards,
    Andrey
     
  7. DondyB

    DondyB Basic Pleskian

    12
    35%
    Joined:
    Jan 21, 2013
    Messages:
    26
    Likes Received:
    0
    Hi Andrey,

    Sorry for my late answer. Here's the answer for your question

    No, I created under Administrator. Haven't touch any on the reseller part

    I used the template that's predefined.

    Tried to add the quota of IP address, but the result is still the same.
    Here, I'm attaching the screenshot of the template resource and the error as well..

    Hope it helps

    Regards,

    Dondy
     

    Attached Files:

  8. XWSNZD

    XWSNZD New Pleskian

    10
    35%
    Joined:
    Jan 27, 2013
    Messages:
    7
    Likes Received:
    0
    This problem is very easy to replicate and could be viewed as a possible bug.

    If you have two interfaces for PPA management node, with IP's 10.1.1.1 and 111.222.333.444. Your server hostname is called "Master"

    You want 10.1.1.1 to be internal communication and 111.222.333.444 to be external traffic.

    During PPA installation you specify --ip 111.222.333.444 --communication_ip 10.1.1.1.

    You will receive an error message stating "The hostname 'Master' points to wrong IP '10.1.1.1'. It should point to IP address '111.222.333.444' that you specified during installation."

    You edit your /etc/hosts file and change "10.1.1.1 Master" to "111.222.333.444 Master". Start the ppa_installer again and it will install just fine.

    When you to make a new Shared subscription, with shared IP Address to Apache, Mail and SQL service nodes you receive the error "Unable to create hosting. Ip address does not exist in client's pool" with the IP address of 10.1.1.1, your internal interface.

    In our case we get the same error but only when using the migration tools in transfer mode. Transfer stops and just leaves a hell of a mess behind in PPA. A manual subscription works just fine for us but has failed in a similar manner to your issue many a PPA install ago.

    We have seen this alot in our testing and even have the steps documented. This is following Parallels documentation word for word. We have had this issue on a fresh install in the above scenario and IP Pools do very little to change it. At least 6-7 installs.

    You may also notice in your DNS that webmail.<domain> points to your internal address 10.1.1.1, not external.

    When you create a brand the brand hosting will point to 10.1.1.1, not external. Although you can change this.

    Its seems that PPA is reliant on hostname resolution during the install rather then IP addresses specified and there is a misconfiguration somewhere in that process that makes the system think that your internal IP can be used.
     
    Last edited: Feb 12, 2013
  9. DondyB

    DondyB Basic Pleskian

    12
    35%
    Joined:
    Jan 21, 2013
    Messages:
    26
    Likes Received:
    0
    Yes that's exactly what happens. Do you have any work around to solve the problem below ?

    Regards,

    Dondy
     
  10. XWSNZD

    XWSNZD New Pleskian

    10
    35%
    Joined:
    Jan 27, 2013
    Messages:
    7
    Likes Received:
    0
    Not official but try the following by marking that IP as being exclusive - make sure no sites or branding are assigned to that IP address before running the command:

    Assuming 10.1.1.1 was your IP.

    "/usr/local/psa/bin/ipmanage --update 10.1.1.1 -type exclusive"

    Been working great for us testing most of today. I did have a better look into the install process, script and logs after my last post and my comments on hostname resolution are not correct. But marking the IP as exclusive seems to have done the trick. Let me know if it works.
     
  11. DondyB

    DondyB Basic Pleskian

    12
    35%
    Joined:
    Jan 21, 2013
    Messages:
    26
    Likes Received:
    0
    Hi XWSNZD,

    Tried to execute that command and restart .. still got same error...

    I guess I will try to reinstall not using private IP :(

    Dondy
     
  12. PauloMolina

    PauloMolina New Pleskian

    13
    35%
    Joined:
    Jun 29, 2011
    Messages:
    18
    Likes Received:
    0
    I was having the same problem and discovered how to fix it.
    In my case, I had a Brand (Marketing -> Brands) owned by the administrator. When it was created, it was attached to the private IP, so it give that errors about the private IP.
    I fix it going to Marketing -> Brands -> Configure, and then on Power User, go to Websites & Domains menu.
    There you will see "Web Hosting Access". Click on it and change the IP to public one.
    Done!
     
  13. DondyB

    DondyB Basic Pleskian

    12
    35%
    Joined:
    Jan 21, 2013
    Messages:
    26
    Likes Received:
    0
    Hi PauloMolina

    YOU ROCK!!!

    It does solve my problem :D I'm still getting error though.. but not related to this one :)

    Thank you!

    Dondy
     
  14. reliablepenguin

    reliablepenguin New Pleskian

    22
    57%
    Joined:
    Nov 11, 2007
    Messages:
    10
    Likes Received:
    0
    Similar problem but error was:

    "Update mail settings of the subscription #44 Unable to create hosting. Ip address does not exist in client's pool"

    Notice that it's mail that creating the problem. Fixed it by going to:

    Marketing -> Brands -> Configure

    then:

    Server -> IP Addresses

    The IP address for our mail server node was set as dedicated when it needed to be shared. Changed and now new subscriptions are being created without error.

    Thanks,
    Lee
     
Loading...