1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

suexec not working...supposedly

Discussion in 'Plesk for Linux - 8.x and Older' started by webfinesse, Aug 30, 2006.

  1. webfinesse

    webfinesse Guest

    0
     
    Hello,

    I was wondering if there was anything special that needs to be done to have suexec work with plesk.

    I have looked through my http.include and plesk adds the the suexec group.

    My problem is I am having perl scripts / commands being executed with an apache/apache permissions. I was hoping suexec would help me track this down. However it appearently is not enabled.

    the mod_suexec is loaded in the apache runtime and supposedly it was compiled with the binary

    -D APACHE_MPM_DIR="server/mpm/prefork"
    -D APR_HAS_SENDFILE
    -D APR_HAS_MMAP
    -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
    -D APR_USE_SYSVSEM_SERIALIZE
    -D APR_USE_PTHREAD_SERIALIZE
    -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
    -D APR_HAS_OTHER_CHILD
    -D AP_HAVE_RELIABLE_PIPED_LOGS
    -D HTTPD_ROOT="/etc/httpd"
    -D SUEXEC_BIN="/usr/sbin/suexec"
    -D DEFAULT_PIDLOG="logs/httpd.pid"
    -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
    -D DEFAULT_LOCKFILE="logs/accept.lock"
    -D DEFAULT_ERRORLOG="logs/error_log"
    -D AP_TYPES_CONFIG_FILE="conf/mime.types"
    -D SERVER_CONFIG_FILE="conf/httpd.conf"

    what am i missing?
     
  2. Galactic Zero

    Galactic Zero Guest

    0
     
    Have you reciently upgraded anything? If so, you may need to copy psa's suexec over the existing one.
     
  3. webfinesse

    webfinesse Guest

    0
     
    No, I have not. I just did a fresh server install about a 3 weeks ago and I haven't had to upgrade anything.
     
Loading...