1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

System encoding problem

Discussion in 'Plesk for Linux - 8.x and Older' started by Rafels, Nov 16, 2007.

  1. Rafels

    Rafels Guest

    0
     
    Hi,
    after installing plesk on fresh Debian Etch( with utf-8 encoding ) I'm not able to write some characters( polish letters ) to file. On console I'm able to write this, but when I'm trying to write sth to file I've got this nasty stuff, like ĂÂÂÂÂĂŚ, but I should get żźćąśęół.

    Either messages for example from aptitude are also wrong served( like:

    Code:
    Wynik: -370
    
    ZaakceptowaÄ rozwiÄ
    zanie? [Y/n/q/?] ^[[?6c^[[?6c^[[?6c
    )

    my locale.gen file:

    Code:
    pl_PL.UTF-8 UTF-8
    
    pl_PL ISO-8859-2
    locale command:

    Code:
    LANG=pl_PL.UTF-8
    LC_CTYPE="pl_PL.UTF-8"
    LC_NUMERIC="pl_PL.UTF-8"
    LC_TIME="pl_PL.UTF-8"
    LC_COLLATE="pl_PL.UTF-8"
    LC_MONETARY="pl_PL.UTF-8"
    LC_MESSAGES="pl_PL.UTF-8"
    LC_PAPER="pl_PL.UTF-8"
    LC_NAME="pl_PL.UTF-8"
    LC_ADDRESS="pl_PL.UTF-8"
    LC_TELEPHONE="pl_PL.UTF-8"
    LC_MEASUREMENT="pl_PL.UTF-8"
    LC_IDENTIFICATION="pl_PL.UTF-8"
    LC_ALL=
    Code:
    echo $LANG
    pl_PL.UTF-8
    Code:
    locale -a
    C
    pl_PL
    pl_PL.iso88592
    pl_PL.utf8
    polish
    POSIX
    on dpkg-reconfigure locales I'm not able to finish creating locales, to do this I've to run locale-gen. My dpkg-reconfigure locales looks like this: http://chyl.pl/pub/images/dpkg-reconfigure_locales.jpg

    Is there anyone, who can help me to fix this encoding problem? Any ideas?

    PS. Sorry for my poor english...
     
  2. kazmen

    kazmen Guest

    0
     
    encoding and putty

    Hello,
    try to change settings in putty client of ssh daemon. Change Translation to UTF-8
    This will be working fine.


    Greetings.
     
Loading...