1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Unable to add Central SQL 2005 DB to Plesk server

Discussion in 'Plesk Expand 2.3 Distributed Services Topics (Mail, DNS, Databases)' started by wsani, Sep 1, 2008.

  1. wsani

    wsani Silver Pleskian

    28
    40%
    Joined:
    Mar 4, 2005
    Messages:
    509
    Likes Received:
    0
    From time to time I wonder if Plesk Expand will ever become stable without the ambigous errors and issues. Here is the latest one for me, when I try to add an existing SQL 2005 server to a Plesk server, I get the following error:

    Code:
    ACTION OUTPUT
    -------------
    <?xml version="1.0" encoding="UTF-8" standalone="no" ?>
    <packet action_id="1322841" version="2.3.1.8">
        <assign>
            <system>
                <status>error</status>
                <errcode>4003</errcode>
                <errtext>[Operator] PleskAgent error. Failed to add DB server to Plesk server #17: (1002) [PleskAgent - GENERAL] Unknown or general internal error. Login failed for user 'sa'.
    at (VADOConnection::open line 62)
    at Unable to ADO conect with connection string: Provider=SQLOLEDB.1;Initial Catalog=master;Data Source=sql.websitehosting4you.com(VADODatabaseProvider::connect line 181)
    at execute console command --check(vconsoleapp::start line 129)
    at execute &quot;C:\Program Files\Parallels\Plesk\/admin/bin/mssqlmng&quot; --check &quot;--server=sql.[domain].com&quot; &quot;--login=sa&quot; &quot;--password=*&quot;(vconsoleapp::run line 140).</errtext>
            </system>
        </assign>
    </packet>
    
    ACTION LOG:
    --------------
    Sep 01 2008 20:17:41 [:7491] DEBUG: pool: Sending message to parent: 2.
    Sep 01 2008 20:17:41 CDBOp[:7491] NOTICE: Command 'assign' requested
    Sep 01 2008 20:17:41 CDBOp[:7491] INFO: Assign DB server function called.
    Sep 01 2008 20:17:41 [:7491] DEBUG: Start transaction 'DEFAULT'.
    Sep 01 2008 20:17:41 CDBOp[:7491] DEBUG: Check for Server #17 exists - found.
    Sep 01 2008 20:17:41 [:7491] DEBUG: Transport for server #17 requested. Creating a new instance.
    Sep 01 2008 20:17:41 AConnection[:7491] INFO: >> https://10.20.43.167:8443/enterprise/control/agent.php : POST 243 bytes
    Sep 01 2008 20:17:41 AConnection[:7491] INFO: <?xml version="1.0" encoding="UTF-8" standalone="no" ?><packet version="1.4.2.0"><db_server><add><host>sql.websitehosting4you.com</host><port>0</port><type>mssql</type><admin>sa</admin><password>**********</password></add></db_server></packet>
    Sep 01 2008 20:17:45 AConnection[:7491] INFO: << https://10.20.43.167:8443/enterprise/control/agent.php : Response 1455 bytes
    Sep 01 2008 20:17:45 AConnection[:7491] INFO: <packet version="1.4.2.0"><db_server><add><result><status>error</status><errcode>1002</errcode><errtext>Login failed for user 'sa'.
    at (VADOConnection::open line 62)
    at Unable to ADO conect with connection string: Provider=SQLOLEDB.1;Initial Catalog=master;Data Source=sql.websitehosting4you.com(VADODatabaseProvider::connect line 181)
    at execute console command --check(vconsoleapp::start line 129)
    at execute &quot;C:\Program Files\Parallels\Plesk\/admin/bin/mssqlmng&quot; --check &quot;--server=sql.[domain].com&quot; &quot;--login=sa&quot; &quot;--password=*&quot;(vconsoleapp::run line 140)</errtext></result></add></db_server><output>C:\Program Files\Parallels\Plesk\admin\plib\DatabaseManagerMSSQL.php:219
    C:\Program Files\Parallels\Plesk\admin\plib\DatabaseManager.php:335
    C:\Program Files\Parallels\Plesk\admin\plib\DatabaseServerManager.php:172
    C:\Program Files\Parallels\Plesk\admin\plib\api-common\DatabaseManipulator.php:292
    C:\Program Files\Parallels\Plesk\admin\plib\api-rpc\AgentDatabaseServer.php:56
    C:\Program Files\Parallels\Plesk\admin\plib\api-rpc\PleskAPIOperator.php:106
    C:\Program Files\Parallels\Plesk\admin\plib\api-rpc\Agent.php:358
    C:\Program Files\Parallels\Plesk\admin\plib\api-rpc\PleskAPIOperator.php:106
    C:\Program Files\Parallels\Plesk\admin\plib\api-rpc\Agent.php:184
    C:\Program Files\Parallels\Plesk\admin\htdocs\enterprise\control\agent.php:22
    </output></packet>
    Sep 01 2008 20:17:45 [:7491] INFO: PleskAgent system reports no errors.
    Sep 01 2008 20:17:45 [:7491] DEBUG: Roll back transaction 'DEFAULT'.
    Sep 01 2008 20:17:45 CDBOp[:7491] ERR: Expand error: [Operator] PleskAgent error. Failed to add DB server to Plesk server #17: (1002) [PleskAgent - GENERAL] Unknown or general internal error. Login failed for user 'sa'.
    at (VADOConnection::open line 62)
    at Unable to ADO conect with connection string: Provider=SQLOLEDB.1;Initial Catalog=master;Data Source=sql.[domain].com(VADODatabaseProvider::connect line 181)
    at execute console command --check(vconsoleapp::start line 129)
    at execute "C:\Program Files\Parallels\Plesk\/admin/bin/mssqlmng" --check "--server=sql.[domain].com" "--login=sa" "--password=*"(vconsoleapp::run line 140).
    Sep 01 2008 20:17:45 [:7491] DEBUG: All transport instances destroyed.
    Sep 01 2008 20:17:45 [:7491] DEBUG: Transport instance for server #17 destroyed.
    Sep 01 2008 20:17:45 [:7491] DEBUG: All transport instances destroyed.
    Sep 01 2008 20:17:45 CDBOp[:7491] DEBUG: Boss operator finished with code 4003.
    
    Notes:

    1. I replaced the real domain with [domain], so please don't say it looks weird.
    2. Yes, the user 'sa' is able to connect remotely. There is absolutely nothing wrong with the server configuration or the username. In fact I was able to add the database server previously...
     
  2. wsani

    wsani Silver Pleskian

    28
    40%
    Joined:
    Mar 4, 2005
    Messages:
    509
    Likes Received:
    0
    Needless to say, I'm looking for suggestions. Thanks...
     
  3. gold

    gold Regular Pleskian

    25
    57%
    Joined:
    Jan 8, 2008
    Messages:
    307
    Likes Received:
    0
    What is the full version of Plesk server?
     
  4. wsani

    wsani Silver Pleskian

    28
    40%
    Joined:
    Mar 4, 2005
    Messages:
    509
    Likes Received:
    0
    Plesk 8.6.0

    Edit: 8.6.0.1 expand 2.3.1
     
  5. gold

    gold Regular Pleskian

    25
    57%
    Joined:
    Jan 8, 2008
    Messages:
    307
    Likes Received:
    0
    I can not reproduce this problem on Expand, Plesk for Windows 8.6.0.1 and MS SQL Server 2005. It is possible that you have problems with SQL server instances. The MS SQL Server 2005 can be registered in Plesk or Expand using hostname only "sql.server.host" or hostname and instance name "sql.server.host\instancename". You can test your SQL server configuration by registering it in the Plesk server directly.
     
  6. wsani

    wsani Silver Pleskian

    28
    40%
    Joined:
    Mar 4, 2005
    Messages:
    509
    Likes Received:
    0
    Thanks. But there is a reason why I didn't discuss the domain name in my forum post. I would appreciate it if you removed the domain name mentioned from your reply...
     
Loading...