1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

unable to change value of php safe_mode using Plesk

Discussion in 'Plesk for Linux - 8.x and Older' started by pacer, May 10, 2006.

  1. pacer

    pacer Guest

    0
     
    hi
    People says what it is very easy to change php safe_mode usin plesk's setup button for domain .
    But in my case for some reason i can't do it
    i thought there sould be a checkbox , or something else .
    i can see only this ...

    PHP support Yes (PHP 'safe_mode' on)

    and nothing else , no any kind of control .
    anybody please tell me how to disable safe_mode
    thanx
     
  2. hipernet

    hipernet Guest

    0
     
    If you try to change safe_mode to off in a subdomain using vhost.conf don't works, but in Plesk 7.5 the same config works fine.

    Plesk 8.0 sucks.
     
  3. pacer

    pacer Guest

    0
     
    Thank you for your comment , but that does not help me. i'm have been using plesk 8 with no problem so far.
     
  4. ALGORYTHM

    ALGORYTHM Guest

    0
     
    are you logged in as admin?
     
  5. pacer

    pacer Guest

    0
     
    No . i'm a customer, my admin tells me what i'm an idiot. :) and can't do trivial thing
     
  6. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    It could be that customers don't have enough rights to change the safe_mode setting. Ask the admin to change it for you.
     
  7. pacer

    pacer Guest

    0
     
    That it , I told him to turn off safe_mode cos i'm unable to do it myself . but he insist on doing that by hands of customers. I just got pissed on my admin. More then that he told me what safe_mode = off in php.ini and my site functionality what requires safe_mode to be turned off , should work correctly . But i still can't run my php script normally because i get a errors , that usually mean , what the safe_mode is ON. The only solution i see , is to get rid from that hosting provider. Looks like they are idiots. Because the problem solution has not been found during 2 weeks. :(
     
  8. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    What are the exact errors you're getting?
     
  9. NightStorm

    NightStorm Guest

    0
     
    Sounds like the admin is still familiarizing himself with 8.0. It would be a security issue to allow any customer to manage the safe_mode settings, so he would have to do it at his level.
    Also, Plesk appears to no longer read safe_mode settings from php.ini, so any settings he has in there would be rather useless.
    running a phpinfo file would show the safe_mode setting... directing your admin to the file would show him that any changes he is making to ini files are simply not working.
     
  10. ForzaHV

    ForzaHV Guest

    0
     
    I just upgraded to plesk8

    Maybe your admin has missed the fact that there is a improvement when it comes to this setting.
    Probarly he made the misstake (as i did myself at first), to change /etc/php,ini.
    He can set safe_mode=Off for each domain separatly. In the control panel for each domain. This is much better since it improves overall security on the server.

    Best regards.

    /Daniel Malmberg
     
  11. webignite

    webignite Guest

    0
     
    I'm hoping this is an oversight because if I have to log in to change the safe_mode setting for every client...

    There needs to be an option to allow a client to change this setting themselves.
     
Loading...