1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Unable to publish site

Discussion in 'Sitebuilder 4.0 for Linux' started by cherif, Jul 30, 2007.

  1. cherif

    cherif Guest

    0
     
    Hi,
    I installed Sitebuilder under Kubuntu 6.06 with all the available modules and templates, but when I want to publish a site localy via XCopy I get the following Error Message :

    The site cannot be published to the specified location.
    Cannot connect to the host via XCopy or do not have permissions for writing.

    I specified /WebDesign/ in the Working Directory field

    and

    I specified http://localhost/apache2-default/WebDesign/ in
    the Web site URL field

    Before that I added the following host :
    http://localhost/apache2-default/


    Also I checked write permissions on the /var/www/apache2-default directory, so what's wrong :confused:

    P.S I am running Sitebuilder with port number 8080 (http://localhost:8080/)
     
  2. caustic

    caustic Guest

    0
     
    Also I checked write permissions on the /var/www/apache2-default directory, so what's wrong
    This directory should be writable by the apache user (i.e. the one apache is running under).
     
  3. cherif

    cherif Guest

    0
     
    Thanks for the answer, but it's already the case :(
     
  4. caustic

    caustic Guest

    0
     
    I specified /WebDesign/ in the Working Directory field
    i.e. you have created /WebDesign directory on the server that is writable by apache user and http://localhost/apache2-default/WebDesign/ points there, correct?
     
  5. cherif

    cherif Guest

    0
     
  6. cherif

    cherif Guest

    0
     
    This time I created a folder named WebDesign under /opt/sitebuilder/ with the correct write permissions.
    But nothing is copied to the folder and this time I get the following Error Message :

    The site cannot be published to the specified location.
    Cannot connect to the specified site URL.

    I added the following host : http://localhsot:8080/

    I specified /opt/sitebuilder/WebDesign in the Working Directory field

    I specified http://localhost:8080/WebDesign/ in the Web site URL field

    Any idea :confused:
     
  7. caustic

    caustic Guest

    0
     
    I specified http://localhost:8080/WebDesign/ in the Web site URL field
    have you also setup apache to listen on 8080? You should use a config like this one:
    Code:
    Listen 8080
    
    <VirtualHost *:8080>
    DocumentRoot /opt/sitebuilder
    ServerName sitebuilder-publish
    AddHandler application/x-httpd-php5 .php
    ScriptAlias /bin /usr/bin
    Action application/x-httpd-php5 /bin/php5-cgi
    
    <Directory /opt/sitebuilder/WebDesign>
     Options +ExecCGI 
    </Directory>
    </VirtualHost>
    
     
  8. cherif

    cherif Guest

    0
     
    I added the following code to the Suitebuilder Apache config file :

    <Directory /opt/sitebuilder/WebDesign>
    Options +ExecCGI
    </Directory>
    </VirtualHost>


    But I get always the same Error Message :mad:
     
Loading...