1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Unable to setup physical hosting, no chroot problem

Discussion in 'Plesk for Linux - 8.x and Older' started by ginkelb, Jul 26, 2005.

  1. ginkelb

    ginkelb Guest

    0
     
    When i try to setup physical hosting for a new client i get the next errors.

    In a popup

    THe following error information is also available

    Can somebody please point my nose in the right direction?
     
  2. magisoft

    magisoft Guest

    0
     
    not to post a 'me too' - but, me too!

    Just started getting the same error tonight... did you find out anything?


    Unable to assign variables for PHostingForm: Unable to get hardquota state: usermng: Unable to getpwnam for user mr-jeff usermng: Error: invalid user
    0: /usr/local/psa/admin/htdocs/domains/hosting/phosting_setup.php:288 psaerror(string "Unable to assign variables for PHostingForm: Unable to get hardquota state: usermng: Unable to getpwnam for user mr-jeff usermng: Error: invalid user")
     
  3. hardweb

    hardweb Guest

    0
     
    The user (ftp login name) was removed from the system. You must re-add it in command line using useradd.
     
  4. vamosb

    vamosb Guest

    0
     
    I got the same error when I try to change FTP password. The user exists, I've checked...

    The onl ything what changed the Plesk version: 7.5.3 -> 7.5.4
     
  5. AndyD

    AndyD Guest

    0
     
    Same thing

    I'm getting the same error. I tried adding the user manually using 'useradd' but that just makes Plesk tell me that the user already exists.

    Surely someone must know what's causing this :(
     
  6. vamosb

    vamosb Guest

    0
     
    Hi AndyD,

    Check the FTP user name in Plesk, and the users of the OS. YOu should find the Plesk FTP user among the OS users.
    In my case the username was modified by sombody somehow. Never figured out how....
     
  7. AndyD

    AndyD Guest

    0
     
    When I view my /etc/passwd there's no username that conflicts with the one I'm trying to add with. I've also tried using 4 or 5 different usernames and I still get the same result.

    Here is the exact error:

     
  8. akucharski

    akucharski Guest

    0
     
    same problem

    I am having the same problem. I tried several times to go back and change the user name in case there was a duplicate but still getting the same:


    0: /usr/local/psa/admin/htdocs/domains/hosting/phosting_setup.php:288 psaerror(string "Unable to assign variables for PHostingForm: Unable to get hardquota state: usermng: Unable to getpwnam for user USERNAME usermng: Error: invalid user")
     
  9. AndyD

    AndyD Guest

    0
     
    I contacted support and got sent a patch.

    I tried to attach it but the forum doesn't allow attachments :(
     
  10. akucharski

    akucharski Guest

    0
     
    thanks for the heads up - really appreciate it, will give them a ring
     
  11. bandurao

    bandurao Guest

    0
     
  12. Joriz

    Joriz Guest

    0
     
    Can someone send me that patch. I have the same problem.
     
  13. ecence.com

    ecence.com Guest

    0
     
Loading...