1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

update 7.2>7.3 error :(

Discussion in 'Plesk for Linux - 8.x and Older' started by Waylander, May 10, 2005.

  1. Waylander

    Waylander Guest

    0
     
    hi,

    error... error... erorr... swsoft... and no support. maybe the comm can help me.

    ive read all the error after update posts, not found a solution for THIS error...

    ive try the update via the updater on a rh9 box.

    anyone have a idea whats wrong?

    thanks community!
    way

    and thanks sw-soft for your great "support" here...
    ---

    Preparing for packages installation...Error reading info for conflict check of installed package (null).
    Error reading info for conflict check of installed package (null).
    Error reading info for conflict check of installed package (null).
    Error reading info for conflict check of installed package (null).
    Error reading info for conflict check of installed package (null).
    Error reading info for conflict check of installed package (null).
    Error reading info for conflict check of installed package (null).
    Error reading info for conflict check of installed package (null).
    Error reading info for conflict check of installed package (null).

    ----- begin of output -----
    Installing kernel-2.4.20-31.9.i686.rpm
    warning: /root/psa/PSA_7.5.3/RH9_std.updates/kernel-2.4.20-31.9.i686.rpm: V3 DSA signature: NOKEY, key ID db42a60e
    grubby: unable to open /dev/hda: No such device or address
    grubby: unable to open /boot/boot.b: No such file or directory
    grubby fatal error: unable to find a suitable template
    grubby fatal error: unable to find a suitable template
    Installing /PSA_7.5.3/rpm_RedHat_9/base/psa-qmail-1.03-rh9.build75050506.13.i586.rpm
    Stopping : [ OK ]
    Trying to set up default qmail permissions... done

    ===> Installing Qmail server
    Trying to set maillog file to /usr/local/psa/var/log/maillog... done
    Configuring Qmail...
    Trying to generate SSL certificates for TLS sessions... done
    Trying to register service qmail... using /sbin/chkconfig
    done
    Trying to register qmail in alternatives... done
    Trying to start Qmail services... done
    Installing /PSA_7.5.3/rpm_RedHat_9/base/psa-proftpd-xinetd-1.2.10-rh9.build75050506.13.i586.rpm
    warning: /etc/proftpd.conf saved as /etc/proftpd.conf.rpmsave
    Installing /PSA_7.5.3/rpm_RedHat_9/base/psa-pre-keyupdate-7.5.3-rh9.build75050506.13.i586.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/base/psa-logrotate-3.7-rh9.build75050506.13.i586.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/base/libidn-0.4.2-rh9.build75050506.13.i586.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/opt/bu/perl-IO-Ftp-0.05-rh9.build75050506.13.noarch.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/opt/bu/perl-MIME-Lite-2.117-rh9.build75050506.13.noarch.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/base/Mambo-4.5.1-7506.noarch.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/base/psa-7.5.3-rh9.build75050506.13.i586.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/base/psa-hotfix-7.5.3-rh9.build75050509.16.i586.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/base/psa-courier-imap-add-7.5.3-rh9.build75050506.13.i586.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/base/courier-imap-3.0.8-rh9.build75050506.13.i586.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/base/psa-api-common-7.5.3-rh9.build75050506.13.noarch.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/base/psa-api-cli-7.5.3-rh9.build75050506.13.noarch.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/base/psa-key-7.5-rh9.build75050506.13.noarch.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/base/psa-locale-base-en-US-7.5.3-rh9.build75050506.13.noarch.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/opt/bu/psa-bu-7.5.3-rh9.build75050506.13.i586.rpm
    Installing /PSA_7.5.3/rpm_RedHat_9/opt/docs/psa-manual-custom-skin-guide-7.5.3-rh9.build75050506.13.i586.rpm
    error: Failed dependencies:
    psa-api-common = 7.5.2 is needed by (installed) psa-api-rpc-7.5.2-rh9.build75050128.10

    ----- end of output -----
    ===> Autoinstaller: stopped logging at Wed May 11 03:53:22 2005

    ***** end of log file *****
     
  2. Waylander

    Waylander Guest

    0
     
    part two...

    after check to install the api (why ive to do it manually :confused: )

    this error occurs...

    Trying to start MySQL server... done
    Trying to establish test connection... connected
    Trying to backup MySQL database... done
    MySQL databases are dumped to /var/lib/psa/dumps/mysql.preupgrade.dump.gz
    Database integrity check failed: duplicate values of (action_id, component) exist in table log_components

    ERROR while trying to
    Check the error reason(see log file: /tmp/psa_7.5.3_RedHat_9_build75050506.13_upgrade.log), fix and try again

    Aborting...

    error: %pre(psa-7.5.3-rh9.build75050506.13) scriptlet failed, exit status 1
    error: install: %pre scriptlet failed (2), skipping psa-7.5.3-rh9.build75050506.13

    ----- end of output -----
    ===> Autoinstaller: stopped logging at Wed May 11 04:24:26 2005

    ***** end of log file *****
    the log just give me a...

    Trying to establish test connection... connected
    `/var/lib/psa/dumps/mysql.preupgrade.dump.gz' -> `/var/lib/psa/dumps/mysql.preupgrade.dump.gz.4'
    Trying to backup MySQL database... done
    MySQL databases are dumped to /var/lib/psa/dumps/mysql.preupgrade.dump.gz
    Database integrity check failed: duplicate values of (action_id, component) exist in table log_components

    ERROR while trying to

    Aborting...

    this need some hours more i think...

    argh, what a *****
     
  3. DigitalCrowd

    DigitalCrowd Basic Pleskian

    24
    23%
    Joined:
    Jul 5, 2002
    Messages:
    58
    Likes Received:
    0
    Same issue here on FC2.
     
  4. DigitalCrowd

    DigitalCrowd Basic Pleskian

    24
    23%
    Joined:
    Jul 5, 2002
    Messages:
    58
    Likes Received:
    0
    Fixed it. Sorta.

    Did this in mysql... for psa databases

    delete from log_components;

    Install appears to be working now.
     
  5. Waylander

    Waylander Guest

    0
     
    thanks, but i cant longer log into plesk after the broken update... login>ok but just the header and a blank page show up :(

    plesk makes me :mad:
     
  6. DigitalCrowd

    DigitalCrowd Basic Pleskian

    24
    23%
    Joined:
    Jul 5, 2002
    Messages:
    58
    Likes Received:
    0
    After you deleted, did you

    rpm -Uvh *.rpm --force

    inside the base folder? I got the same error you did until the full install ran.
     
  7. Waylander

    Waylander Guest

    0
     
    phew... what a nightmare:)

    jep, after delete and a rpm -Uhv psa-7.5.3-rh9.build75050506.13.i586.rpm --force it works. now ive to test the box...

    thanks!

    way

    /edit1: lol... first test... webmail... just a 404... aaahhhh... i swear, i move all my boxes to another hoster without this damn plesk

    hrmpf :mad:

    /edit2: just for the other they run in troubles...
    after the commandline-update you have to do the update in plesk again. after this, the apache is broken, no connects possible. after a manually restart it works now, horde too. no more time to test now, 7am here, need some sleep.

    thanks sw-soft for this adventure-night...
     
  8. DigitalCrowd

    DigitalCrowd Basic Pleskian

    24
    23%
    Joined:
    Jul 5, 2002
    Messages:
    58
    Likes Received:
    0
    do that on ALL rpm's in the base dir... not just the single one.

    *.rpm
     
  9. Waylander

    Waylander Guest

    0
     
    jepp, think this was the (my) fault. but... why WE have to do this all? :p

    thanks again for the help! ;)

    way
     
  10. jdc32

    jdc32 Guest

    0
     
    i have the same problem (fc2).

    what do you mean with base dir? (/ root?)

    please help, which steps must i make!!!!!

    ps. nice business swsoft! expensive support for buggy software, thats makes sense :) im now 16std up for this ****!
     
  11. jdc32

    jdc32 Guest

    0
     
    okay i get the basedir

    delete the compo datas in the db and make a reupdate.

    i get this:
    Fehler: %pre(psa-7.5.3-fc2.build75050506.13) scriptlet failed, exit status 1
    Fehler: install: %pre scriptlet failed (2), skipping psa-7.5.3-fc2.build75050506.13
    11:psa-api-common ########################################### [ 61%]
    12:psa-api-cli ########################################### [ 67%]
    13:psa-horde ########################################### [ 72%]
    ERROR 1047 at line 43: Unknown command
    14:Mambo ########################################### [ 78%]
    15:eek:sCommerce ########################################### [ 83%]
    16:psa-hotfix ########################################### [ 89%]
    17:psa-imp ########################################### [ 94%]
    websrvmng: Service httpd failed to restart
    websrvmng: Service httpd failed to restart


    nothing works,.... im still offline
     
  12. blockcipher

    blockcipher Guest

    0
     
    This fixed me up. Thanks!!!!!
     
  13. DigitalCrowd

    DigitalCrowd Basic Pleskian

    24
    23%
    Joined:
    Jul 5, 2002
    Messages:
    58
    Likes Received:
    0
    Yea, I finally got all fixed last night. Had to do a *.rpm install AGAIN last night to get webmail working. But all is well. No complaints this morning. Now preparing for another round tonight.
     
Loading...