1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

update from 7.5.3 to 7.5.4 failed : dependancy error...

Discussion in 'Plesk for Linux - 8.x and Older' started by fgilain, Oct 5, 2005.

  1. fgilain

    fgilain Guest

    0
     
    Hi all,

    Plesk 7.5.3 running RHEL3.0.
    I try to use the GUI to update to 7.5.4 and i get the following error :

    ========================================
    Preparing for packages installation...
    ----- begin of output -----
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-hotfix-7.5.4-rhel3.build75050926.17.i586.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-7.5.4-rhel3.build75050824.12.i586.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-courier-imap-add-7.5.4-rhel3.build75050902.17.i586.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/courier-imap-3.0.8-rhel3.build75050824.12.i586.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-api-common-7.5.4-rhel3.build75050902.09.noarch.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-api-cli-7.5.4-rhel3.build75050902.09.noarch.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-key-7.5-rhel3.build75050824.12.noarch.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-locale-base-en-US-7.5.4-rhel3.build75050824.12.noarch.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/opt/modules/watchdog/psa-watchdog-1.0.0-rhel3.build75050926.17.i586.rpm
    error: Failed dependencies:
    psa = 7.5.3 is needed by (installed) psa-bu-7.5.3-rhel3.build75050506.13
    psa-api-common = 7.5.3 is needed by (installed) psa-api-rpc-7.5.3-rhel3.build75050602.16

    ----- end of output -----
    ===> Autoinstaller: stopped logging at Wed Oct 5 15:17:31 2005

    ***** end of log file *****

    ========================================

    Any idea ?

    Florent
     
  2. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Using SSH, try:

    #rpm -e psa-bu
    #rpm -e psa-api

    Then try it again from the GUI
     
  3. fgilain

    fgilain Guest

    0
     
    Hi,

    I just have run an up2date -u command in order to update my system before re-trying the Plesk update

    I'll run your command just after and tell you if it worked

    thanks

    Florent
     
  4. fgilain

    fgilain Guest

    0
     
    Ok,

    i ran your 2 command, second one told me :

    [root@mx2 root]# rpm -e psa-bu
    [root@mx2 root]# rpm -e psa-api
    erreur: le paquetage psa-api n'est pas installé (package not installed)

    now, using GUI, i still get 1 error :

    ====================================
    Preparing for packages installation...
    ----- begin of output -----
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-hotfix-7.5.4-rhel3.build75050926.17.i586.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-7.5.4-rhel3.build75050824.12.i586.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-courier-imap-add-7.5.4-rhel3.build75050902.17.i586.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/courier-imap-3.0.8-rhel3.build75050824.12.i586.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-api-common-7.5.4-rhel3.build75050902.09.noarch.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-api-cli-7.5.4-rhel3.build75050902.09.noarch.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-key-7.5-rhel3.build75050824.12.noarch.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/base/psa-locale-base-en-US-7.5.4-rhel3.build75050824.12.noarch.rpm
    Installing /PSA_7.5.4/rpm_RedHat_el3/opt/modules/watchdog/psa-watchdog-1.0.0-rhel3.build75050926.17.i586.rpm
    error: Failed dependencies:
    psa-api-common = 7.5.3 is needed by (installed) psa-api-rpc-7.5.3-rhel3.build75050602.16

    ====================================
     
  5. fgilain

    fgilain Guest

    0
     
    here are installed packages :

    [root@mx2 root]# rpm -qa | grep psa
    psacct-6.3.2-27
    psa-7.5.3-rhel3.build75050506.13
    psa-firewall-1.0.1-rhel3.build75050506.13
    perl-Font-AFM-1.18-60psa
    psa-spamassassin-7.5.3-rhel3.build75050506.13
    psa-kronolith-2.0.2-rhel3.build75050506.13
    psa-logrotate-3.7-rhel3.build75050824.12
    psa-key-7.5-rhel3.build75050506.13
    psa-imp-4.0.3-rhel3.build75050506.13
    perl-MLDBM-Sync-0.30-60psa
    psa-api-rpc-7.5.3-rhel3.build75050602.16
    psa-qmail-1.03-rhel3.build75050824.12
    psa-proftpd-1.2.10-rhel3.build75050506.13
    psa-manual-custom-skin-guide-7.5.3-rhel3.build75050506.13
    psa-api-cli-7.5.3-rhel3.build75050602.16
    psa-api-rpc-doc-7.5.3-rhel3.build75050602.16
    psa-proftpd-xinetd-1.2.10-rhel3.build75050824.12
    psa-boost-1.32.0-6
    mod_webapp-4.1.29-41psa.rhel3
    perl-HTML-Tree-3.16-60psa
    psa-passwd-3.0-rhel3.build75050506.13
    psa-courier-imap-add-7.5.3-rhel3.build75050506.13
    psa-migration-manager-7.5.3-rhel3.build75050506.18
    psa-tomcat-configurator-7.5.3-rhel3.build75050506.13
    perl-HTML-Format-1.23-50psa
    psa-api-common-7.5.3-rhel3.build75050602.16
    psa-api-rpc-protocol-7.5.3-rhel3.build75050602.16
    psa-pre-keyupdate-7.5.4-rhel3.build75050824.12
    psa-qmail-rblsmtpd-0.70-rhel3.build75050506.13
    psa-ingo-1.0.1-rhel3.build75050506.13
    psa-turba-2.0.2-rhel3.build75050506.13
    psacct-6.3.2-31.rhel3
    psa-locale-base-en-US-7.5.3-rhel3.build75050506.13
    psa-horde-3.0.4-rhel3.build75050506.13
    perl-MLDBM-2.01-60psa
    perl-FreezeThaw-0.43-60psa
    psa-mnemo-2.0.1-rhel3.build75050506.13
    psa-agent-1.3.4-75050602.16
    psa-hotfix-7.5.3-rhel3.build75050607.13


    Florent
     
  6. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Try

    #rpm -e psa-api-rpc*
     
  7. fgilain

    fgilain Guest

    0
     
    here is new output :

    [root@mx2 root]# rpm -e psa-api-rpc*
    erreur: le paquetage psa-api-rpc* n'est pas installé => (not installed package)
     
  8. fgilain

    fgilain Guest

    0
     
    without the ending "*", i get :
    [root@mx2 root]# rpm -e psa-api-rpc
    erreur: Dépendances requises:
    psa-api-rpc = 7.5.3-rhel3.build75050602.16 est nécessaire pour (déjà installé) psa-agent-1.3.4-75050602.16

    (English translation : package is needed fo already installed package)

    what should i do ?
     
  9. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
  10. fgilain

    fgilain Guest

    0
     
    Ok, Yum isn't installed on my syystem and i could'nt find anywhere something for my release :
    Red Hat 3.0ES....

    What should i do ?
     
  11. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Read that page well. It has a link to download yum and directions on using it with 3ES
     
  12. fgilain

    fgilain Guest

    0
     
    Oupss..sorry..i read too fast

    I finally YUM rpm it and installed it.
    But before getting out "standard Plesk upgrade", i finally choose to download the psa_install script from SwSoft and ran it to upgrade.

    all is now ok !!!! i'm so happy...

    I'll now have to check that all is ok, i'm sure that there are problems that other clients have found on 7.5.4 no ?

    Florent
     
  13. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Maybe not. I've had a few installs and upgrades that went very smooth. Hope yours did.
     
  14. fgilain

    fgilain Guest

    0
     
    no error message in install log, websites are up and running, mails too, ftp and ssh too...

    Hope it will continue ;-))

    Thanks for gaving me your help testing all of theses commands.

    Florent
     
Loading...