1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Update from 8.1.1 to 8.2.1 Failed

Discussion in 'Plesk for Linux - 8.x and Older' started by Mark Harris, Oct 26, 2007.

  1. Mark Harris

    Mark Harris Guest

    0
     
    Hi I tried to update from 8.1.1 to 8.2.1 on my Redhat server and the updater gave me this message

    Autoinstaller 3.2.1 (build at 2007-09-14 16:13 svn rev. 88422) started at (timezone EST) Sat Oct 20 19:32:18 2007 Command line args: /usr/local/psa/admin/bin/autoinstaller --enable-xml-output --source-type=plesk --target=/root/psa --select-release-id=PLESK_8_2_0 --notify-email=info@emailacme.com --install-component=base --install-component=java --install-component=spamassassin --install-component=docs --install-component=backup-ded --install-component=api --install-component=pmm --install-component=psa-firewall --install-component=cs-gs --install-component=psa-vpn --install-component=battlefield --install-component=psa-fileserver --install-component=watchdog

    Try to find rcfile...
    Autoinstaller rcfile not found.
    Check hostname is sucessfull.
    Opsys detected as: os_name=Linux os_vendor=RedHat version=el3 arch=i686 environment= Final opsys (with overriding) is: os_name=Linux os_vendor=RedHat version=el3 arch=i686 environment= Downloading the file products.inf3: 100% done.
    Downloading the file plesk.inf3: 100% done.
    Downloading the file sitebuilder.inf3: 30%..100% done.
    repository: Get brief packages info for all sources Checking for installed packages... readSystemPackagesBrief: execute rpm -qa --queryformat 'F:system_installed_brief_%{NAME}-%{VERSION}-%{RELEASE}.rpm\nN:%{NAME}\nE:%{EPOCH}\nV:%{VERSION}\nL:%{RELEASE}\nA:%{ARCH}\nf:%{INSTALLTIME}\nB:%{BUILDTIME}\nX:\n'
    done
    release PLESK_8_1_1 is actual
    release PLESK_8_2_0 is actual
    release PLESK_8_2_1 is actual
    release SB_3_0_2 is actual
    release SB_4_0_0 is actual
    Select best build of PLESK_8_2_0 for current OS First fit build is current best: PSA_8.2.0/plesk-8.2.0-rhel3-i386.inf3
    Select best build: finally choised PSA_8.2.0/plesk-8.2.0-rhel3-i386.inf3
    Downloading the file PSA_8.2.0/plesk-8.2.0-rhel3-i386.inf3: 96%..100% done.
    repository: Get brief packages info for all sources Detecting installed product components.
    Component base: mode upgrade, installed=1174563913, available=1183713973 No keyupdate need for component base Component psa-autoinstaller: mode up2date, installed=1189761457, available=1183642048 Component asp: mode upgrade, installed=1174564001, available=1183714063 Component mailman: mode upgrade, installed=1174564003, available=1183714065 Component postgresql: mode up2date, installed=1148334975, available=1148334975 Component java: mode upgrade, installed=1174563854, available=1183713896 Component spamassassin: mode upgrade, installed=1174563860, available=1183713902 Component rblsmtpd: mode upgrade, installed=1174563856, available=1183713898 Component mod_python: mode up2date, installed=1107266236, available=1107266236 Component ruby: mode upgrade, installed=1174564011, available=1183714073 Component fcgi: mode up2date, installed=1160390032, available=1160390032 Component vault: mode upgrade, installed=1174877970, available=1186465980 Component horde-comps: mode upgrade, installed=1174563970, available=1183714033 Component docs: mode upgrade, installed=1174563960, available=1183714021 Component backup-ded: mode upgrade, installed=1175673731, available=1183714060 Component drweb: mode upgrade, installed=1174563818, available=1183713861 Component kav: mode install, installed=0, available=1186550476 Component ppwse: mode upgrade, installed=1174563985, available=1186484762 Component api: mode upgrade, installed=1175673737, available=1183713884 Component sshterm: mode upgrade, installed=1174563784, available=1183713817 Component pmm: mode upgrade, installed=1175673726, available=1183713832 Component psa-firewall: mode upgrade, installed=1174563849, available=1183713892 Component cs-gs: mode upgrade, installed=1174563846, available=1183713888 Component psa-vpn: mode upgrade, installed=1174563954, available=1183714016 Component battlefield: mode upgrade, installed=1174563974, available=1183714037 Component bf2: mode upgrade, installed=1174564007, available=1183714069 Component psa-fileserver: mode upgrade, installed=1174563838, available=1183713880 Component watchdog: mode upgrade, installed=1174563992, available=1183714055 Component sitebuilder: mode upgrade, installed=1164255503, available=1182877783 Component sb-publish: mode up2date, installed=1160553046, available=1160553046 Component cf-support: mode upgrade, installed=1174564008, available=1183714070 Component atis: mode up2date, installed=1167889488, available=1167889488 Component miva: mode install, installed=0, available=1183714077 Component sso: mode install, installed=0, available=1183714091 Component de-DE-locale: mode upgrade, installed=1174825695, available=1186044524 Component ja-JP-locale: mode upgrade, installed=1174825720, available=1186044540 Component es-ES-locale: mode install, installed=0, available=1186044531 Component ru-RU-locale: mode install, installed=0, available=1186044554 Component fr-FR-locale: mode install, installed=0, available=1186044534 Component it-IT-locale: mode install, installed=0, available=1186044538 Component zh-CN-locale: mode install, installed=0, available=1186044560 Component zh-TW-locale: mode install, installed=0, available=1186044562 Check for components requires keyupdate No keyupdate need for component base Exchanging information with licensing server.
    KeyUpdateChecker::doCheck: no components for check key update

    Getting packages to installation list:
    Get packages to installation from selected component base Get packages to installation from selected component java Get packages to installation from selected component spamassassin Get packages to installation from selected component docs Get packages to installation from selected component backup-ded Get packages to installation from selected component api Get packages to installation from selected component pmm Get packages to installation from selected component psa-firewall Get packages to installation from selected component cs-gs Get packages to installation from selected component psa-vpn Get packages to installation from selected component battlefield Get packages to installation from selected component psa-fileserver Get packages to installation from selected component watchdog Check package set before installation https://rhn.ev1servers.net/XMLRPC There was an SSL error: [('SSL routines', 'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed')] A common cause of this error is the system time being incorrect. Verify that the time on this system is correct.
    ERROR: The up2date utility failed to install the required packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.


    ---
    Plesk autoinstaller.

    My system time is correct any ideas what I need to do to fix this?

    Mark
     
  2. Monica@

    Monica@ Guest

    0
     
    Hi.

    Try to skip the upgrade of the system components (add --disable-plesk-sys-updates in the command line arguments), or try to disable the running of up2date by creating /root/.autoinstallerrc file with the following:
    ALLOW_TO_USE_UP2DATE=no
    save the file and run the upgrade once again.
    To find out what's wrong with the up2date it's better to contact the OS vendor.
     
Loading...