1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Update templates after installing

Discussion in 'Sitebuilder 4.2 for Linux' started by pfellner, Mar 29, 2008.

  1. pfellner

    pfellner Guest

    0
     
    I used to use the command:
    sb_config --update_templates
    I've added a new custom template but that doesn't work anymore. How do I tell SB to update the templates DB?
     
  2. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Try to check custom template one more time if there are no problems with it's structure and information. Did you see it in Sitebuilder admin CP -> Server -> Templates list?
    Try to create a copy of one of the default templates and change it to new one, just to make sure if update procedure works. Change name for this template (directory should have new name and info.xml file information should be updated).
    Let me know about the results. As I know there were no issues with template updates in latest versions of Sitebuilder.
     
  3. pfellner

    pfellner Guest

    0
     
    I'm sorry but I meant to say that the command isn't even recognized.
    [root@jupiter ~]# cd /usr/local/sitebuilder/htdocs/templates/
    [root@jupiter templates]# sb_config --update_templates
    -bash: sb_config: command not found
    but to answer your question, no it doesn't appear in the CP.
     
  4. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Try to check if it exists on the server:

    # whereis sb_config
    sb_config: /usr/local/bin/sb_config
    # ls -la /usr/local/bin/sb_config
    -rwx------ 1 root root 69 Авг 7 2007 /usr/local/bin/sb_config

    # cat /usr/local/bin/sb_config
    #!/bin/sh
    cd /usr/local/sitebuilder/utils/ && exec perl configure $@

    Try to run it with full path, like this:

    # /usr/local/bin/sb_config --update_templates
     
  5. pfellner

    pfellner Guest

    0
     
    That did it. I had to use the full path. Thank you Dmitry!
     
Loading...