1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgrade from 7.x to 8.1.1 — ERRORS

Discussion in 'Plesk for Linux - 8.x and Older' started by clops, May 2, 2007.

  1. clops

    clops Basic Pleskian

    23
    57%
    Joined:
    Jun 9, 2006
    Messages:
    33
    Likes Received:
    0
    Hi,

    I get a lot of 404 errors when PLESK is fetching packages. Can someone give me a direction to dig in?

    ----

    Download file versions.inf3: 100% done
    Download file PSA_8.1.1/plesk-8.1.1-deb3.1-i386.inf3: 100% done
    Checking for system installed packages...done.
    Check for components installation status
    resolve packages with apt-get
    Get:1 http://packages.dotdeb.org stable/all Packages [15.4kB]
    Get:2 http://packages.dotdeb.org stable/all Release [88B]
    Get:3 http://packages.dotdeb.org stable/all Sources [2743B]
    Get:4 http://packages.dotdeb.org stable/all Release [69B]
    Get:5 http://debian.pkgs.cpan.org unstable/main Packages [57.6kB]
    Ign http://debian.pkgs.cpan.org unstable/main Release
    Err http://autoinstall.plesk.com PSA_8.1.1/ Packages
    404 Not Found
    Ign http://autoinstall.plesk.com PSA_8.1.1/ Release
    Hit http://ftp.edgewall.com sarge/trac Packages
    Ign http://ftp.edgewall.com sarge/trac Release
    Get:6 http://debian.intergenia.de sarge/main Packages [4523kB]
    Get:7 http://debian.intergenia.de sarge/main Release [98B]
    Hit http://debian.intergenia.de sarge/contrib Packages
    Get:8 http://debian.intergenia.de sarge/contrib Release [101B]
    Hit http://debian.intergenia.de sarge/non-free Packages
    Get:9 http://debian.intergenia.de sarge/non-free Release [102B]
    Get:10 http://debian.intergenia.de sarge/main Sources [1323kB]
    Get:11 http://debian.intergenia.de sarge/main Release [100B]
    Hit http://debian.intergenia.de sarge/contrib Sources
    Get:12 http://debian.intergenia.de sarge/contrib Release [103B]
    Hit http://debian.intergenia.de sarge/non-free Sources
    Get:13 http://debian.intergenia.de sarge/non-free Release [104B]
    Hit http://debian.intergenia.de sarge/non-US/main Packages
    Hit http://debian.intergenia.de sarge/non-US/main Release
    Hit http://debian.intergenia.de sarge/non-US/contrib Packages
    Hit http://debian.intergenia.de sarge/non-US/contrib Release
    Hit http://debian.intergenia.de sarge/non-US/non-free Packages
    Hit http://debian.intergenia.de sarge/non-US/non-free Release
    Hit http://debian.intergenia.de sarge/non-US/main Sources
    Hit http://debian.intergenia.de sarge/non-US/main Release
    Hit http://debian.intergenia.de sarge/non-US/contrib Sources
    Hit http://debian.intergenia.de sarge/non-US/contrib Release
    Hit http://debian.intergenia.de sarge/non-US/non-free Sources
    Hit http://debian.intergenia.de sarge/non-US/non-free Release
    Get:14 http://debian.intergenia.de sarge/updates/main Packages [431kB]
    Get:15 http://debian.intergenia.de sarge/updates/main Release [113B]
    Get:16 http://debian.intergenia.de sarge/updates/contrib Packages [621B]
    Get:17 http://debian.intergenia.de sarge/updates/contrib Release [116B]
    Get:18 http://debian.intergenia.de sarge/updates/non-free Packages [1431B]
    Get:19 http://debian.intergenia.de sarge/updates/non-free Release [117B]
    Get:20 http://debian.intergenia.de sarge/updates/main Sources [70.8kB]
    Get:21 http://debian.intergenia.de sarge/updates/main Release [115B]
    Get:22 http://debian.intergenia.de sarge/updates/contrib Sources [20B]
    Get:23 http://debian.intergenia.de sarge/updates/contrib Release [118B]
    Get:24 http://debian.intergenia.de sarge/updates/non-free Sources [414B]
    Get:25 http://debian.intergenia.de sarge/updates/non-free Release [119B]
    Failed to fetch http://autoinstall.plesk.com/debian/PSA_8.1.1/Packages.gz 404 Not Found
    Fetched 6427kB in 5s (1255kB/s)
    Reading Package Lists...
    E: Some index files failed to download, they have been ignored, or old ones used instead.
    Warning: there is errors in 'apt-get update'
    Start Deb-based installation with apt
    Hit http://debian.intergenia.de sarge/main Packages
    Hit http://debian.intergenia.de sarge/main Release
    Hit http://debian.intergenia.de sarge/contrib Packages
    Hit http://debian.intergenia.de sarge/contrib Release
    Hit http://debian.intergenia.de sarge/non-free Packages
    Hit http://debian.intergenia.de sarge/non-free Release
    Hit http://debian.intergenia.de sarge/main Sources
    Hit http://debian.intergenia.de sarge/main Release
    Hit http://debian.intergenia.de sarge/contrib Sources
    Hit http://debian.intergenia.de sarge/contrib Release
    Hit http://debian.intergenia.de sarge/non-free Sources
    Hit http://debian.intergenia.de sarge/non-free Release
    Hit http://debian.intergenia.de sarge/non-US/main Packages
    Hit http://debian.pkgs.cpan.org unstable/main Packages
    Ign http://debian.pkgs.cpan.org unstable/main Release
    Hit http://debian.intergenia.de sarge/non-US/main Release
    Hit http://debian.intergenia.de sarge/non-US/contrib Packages
    Hit http://debian.intergenia.de sarge/non-US/contrib Release
    Hit http://debian.intergenia.de sarge/non-US/non-free Packages
    Hit http://debian.intergenia.de sarge/non-US/non-free Release
    Hit http://debian.intergenia.de sarge/non-US/main Sources
    Hit http://debian.intergenia.de sarge/non-US/main Release
    Hit http://debian.intergenia.de sarge/non-US/contrib Sources
    Hit http://debian.intergenia.de sarge/non-US/contrib Release
    Hit http://debian.intergenia.de sarge/non-US/non-free Sources
    Hit http://debian.intergenia.de sarge/non-US/non-free Release
    Hit http://debian.intergenia.de sarge/updates/main Packages
    Hit http://debian.intergenia.de sarge/updates/main Release
    Hit http://debian.intergenia.de sarge/updates/contrib Packages
    Hit http://debian.intergenia.de sarge/updates/contrib Release
    Hit http://debian.intergenia.de sarge/updates/non-free Packages
    Hit http://debian.intergenia.de sarge/updates/non-free Release
    Hit http://debian.intergenia.de sarge/updates/main Sources
    Hit http://debian.intergenia.de sarge/updates/main Release
    Hit http://debian.intergenia.de sarge/updates/contrib Sources
    Hit http://debian.intergenia.de sarge/updates/contrib Release
    Hit http://debian.intergenia.de sarge/updates/non-free Sources
    Hit http://debian.intergenia.de sarge/updates/non-free Release
    Hit http://packages.dotdeb.org stable/all Packages
    Hit http://packages.dotdeb.org stable/all Release
    Hit http://packages.dotdeb.org stable/all Sources
    Hit http://packages.dotdeb.org stable/all Release
    Hit http://ftp.edgewall.com sarge/trac Packages
    Ign http://ftp.edgewall.com sarge/trac Release
    Err http://autoinstall.plesk.com PSA_8.1.1/ Packages
    404 Not Found
    Ign http://autoinstall.plesk.com PSA_8.1.1/ Release
    Failed to fetch http://autoinstall.plesk.com/debian/PSA_8.1.1/Packages.gz 404 Not Found
    Reading Package Lists...
    W: Couldn't stat source package list http://autoinstall.plesk.com PSA_8.1.1/ Packages (/var/lib/apt/lists/autoinstall.plesk.com_debian_PSA%5f8.1.1_Packages) - stat (2 No such file or directory)
    W: You may want to run apt-get update to correct these problems
    E: Some index files failed to download, they have been ignored, or old ones used instead.
    Warning: there is errors in 'apt-get update'
    Reading Package Lists...
    Building Dependency Tree...
    W: Couldn't stat source package list http://autoinstall.plesk.com PSA_8.1.1/ Packages (/var/lib/apt/lists/autoinstall.plesk.com_debian_PSA%5f8.1.1_Packages) - stat (2 No such file or directory)
    W: You may want to run apt-get update to correct these problems
    E: Version '3.1.2-build31070419.14' for 'psa-autoinstaller' was not found
    ERROR: Install command execution failed

    ---
     
  2. clops

    clops Basic Pleskian

    23
    57%
    Joined:
    Jun 9, 2006
    Messages:
    33
    Likes Received:
    0
    Hi, is there any help on this topic?
     
  3. clops

    clops Basic Pleskian

    23
    57%
    Joined:
    Jun 9, 2006
    Messages:
    33
    Likes Received:
    0
    Wonderful Tech-Support. What are we paying the money for then?
     
  4. poke

    poke Guest

    0
     
    This forum is not moderated/responded to by SWsoft. It is supported by your fellow plesk users so please don't talk sh!t to us as we don't own the damn company bud.

    I'm sure everyone saw your posts and opted not to even respond and try to help you due to your attitude.

    Let's make things better and try to fix your problem :)

    Firstly are you sure that your firewall is completely off before you attempt the install? Is this a dedi or VPS?

    Also, just some words of wisdom, Plesk runs best on Fedora/Redhat systems. I've run into many issues using Suse and Debian. 100% percent of the time, its easier to update a plesk FC/RH release vs a Deb, Suse, BSD, etc..

    good luck to you and I hope you find a solution.

    Cheers
     
  5. poke

    poke Guest

    0
     
    Sorry, but I forgot to mention that you should not go from 7.x to 8.1.1. You will have better luck upgrading incrementally.
     
  6. clops

    clops Basic Pleskian

    23
    57%
    Joined:
    Jun 9, 2006
    Messages:
    33
    Likes Received:
    0
    But there are no such options in the Upgrade panel. All I see is 8.1.1 :(
     
  7. poke

    poke Guest

    0
     
    Hey clops,

    Are you still running plesk 7.x?

    If so, if you have a direct license from SWsoft, you should have access to the packages to manually update.

    I would advise not using the Updater in plesk especially on a non RH variant. But, when you click on the updater, you only have the 8.1.1 option, not 7.5.x or 8.1.0?
     
  8. clops

    clops Basic Pleskian

    23
    57%
    Joined:
    Jun 9, 2006
    Messages:
    33
    Likes Received:
    0
    Yeah, I have a valid license and am running 7.5.1 I think a while. The only option I see in the updater is 8.1.1 and it doesn't work :) MySQL 5.0 compatibility would be nice, that is the only reason for upgrading of course.

    So, where do I start the manual procedure?

    thnx!
     
  9. poke

    poke Guest

    0
     
    Well first off, updating plesk to 8.1.1 is not going to update your MySQL version, however it will support MySQL 5.. Off hand I'm not sure where to obtain the plesk friendly deb packages precompiled for plesk.

    I would advise you get a server management company to run the update for you.

    If not, grab the packages from swsoft.com and update your system incrementally. PLEASE BACKUP before you attempt this :)

    I am not proficient enough to run you step by step through a debian plesk update, but I'm sure there are many ppl on this forum that have experience.
     
  10. poke

    poke Guest

    0
     
    If this is not a production server, i would advise a fresh plesk 8.1.1 install if possible..
     
  11. clops

    clops Basic Pleskian

    23
    57%
    Joined:
    Jun 9, 2006
    Messages:
    33
    Likes Received:
    0
    I have upgraded MySQL the first day I got the server running, yet Plesk 7.5.x doesn't like it in some places (some queries use reserved words). As I got from the site, Plesk 8.1.1 is MySQL 5.x compatible, and this is the only portion I am interested in :)

    I hope someone can pinpoint me in the right direction :)

    thank anyhows!
     
  12. poke

    poke Guest

    0
     
    You stated that MySQL was the only reason to update.

    Since you updated during 7.x this might be the reason for the update issues.

    Is your server production?
     
  13. clops

    clops Basic Pleskian

    23
    57%
    Joined:
    Jun 9, 2006
    Messages:
    33
    Likes Received:
    0
    Unfortunately this is a production server :(
     
  14. poke

    poke Guest

    0
     
    Hmm.. I would advise you migrate the domains off the current server to another. The Plesk Migration Manager should do the job, however there are other options.

    Is your server using the old /home/httpd/vhosts schema or /var/www/vhosts?

    You may consider migrating the domains off and then back on to the newly updated server.

    I'm sorry I don't have a more definitive answer for you.
     
  15. clops

    clops Basic Pleskian

    23
    57%
    Joined:
    Jun 9, 2006
    Messages:
    33
    Likes Received:
    0
    the only reason to update are the minor compatibility issues with Pleask 7.5.x and MySQL 5.x -- i would have fixed them myself, yet the code is encrypted :(
     
Loading...