1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

upgrade of PHP5

Discussion in 'Plesk for Linux - 8.x and Older' started by NightMan, Apr 14, 2007.

  1. NightMan

    NightMan Guest

    0
     
    I am trying to upgrade the php to PHP5 using yum with ART's rpm base.
    but it gives me a dependencies error. but the package is seems to be already there. how can I solve this?

    [root@server root]# yum upgrade php
    Gathering header information file(s) from server(s)
    Server: Atomic Rocket Turtle - 2 - Atomic PSA-Compatible RPMS
    Finding updated packages
    Downloading needed headers
    Finding obsoleted packages
    Resolving dependencies
    .....Unable to satisfy dependencies
    Package php-domxml needs php = 4.3.10-2.4, this is not available.

    [root@server root]# rpm -q php-domxml
    php-domxml-4.3.10-2.4
    [root@server root]#
     
  2. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
  3. NightMan

    NightMan Guest

    0
     
    I solved the issue.

    by the way, do you have the PHP5.2.x to get installed on a FC2 with PSA 8.1.1 ? if yes, is it stable?

    I tried the following channel, but not getting any updates listed

    [atomic-bleeding]
    name=Atomic Rocket Turtle - $releasever - Atomic PSA-Compatible RPMS
    baseurl=http://www.atomicorp.com/channels/atomic/fedora/$releasever/$basearch
     
  4. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    No not for FC2, Ive discontinued support for FC1, FC2, FC3, RH9 since they are no longer supported. FC4 might go that way soon as well since its also not supported. RHEL3/CentOS3 arent in the archive at the moment, but I might consider adding them again in the future.
     
  5. NightMan

    NightMan Guest

    0
     
    sad :( , so if I install the php5.2 by my own, everything will break in the PLESK?
     
  6. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    I use PHP 5.2.1 on CentOS4 with PSA 8.1 now. So no, PSA wont break, provided you're running on that platform. I expect to have similar success with FC5, FC6, and CentOS5/RHEL5.
     
  7. NightMan

    NightMan Guest

    0
     
    Atomic,
    My problem is i am still at FC2:(
     
  8. MajorWinters

    MajorWinters Guest

    0
     
    Upgrade to FC6?
     
  9. NightMan

    NightMan Guest

    0
     
    or centerOS.5.
    yes I am planning an upgrade.
     
  10. MajorWinters

    MajorWinters Guest

    0
     
    Same here ;)
     
  11. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    Assuming you're talking about CentOS 5: that's not supported yet by Plesk.
     
  12. NightMan

    NightMan Guest

    0
     
    Hi Yes, I meant the CentOS 5.

    I found out that was not supported yet. will wait until the PSA is ready for this version.
     
Loading...