1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgrade - The MD5 checksum failed

Discussion in 'SiteBuilder' started by ccto, Jan 28, 2009.

  1. ccto

    ccto Basic Pleskian

    26
    90%
    Joined:
    Mar 21, 2005
    Messages:
    86
    Likes Received:
    3
    We tried to upgrade it again, but failed as below -

    Please help, and please verify the files before release.

    ---

    Or can we simply copy the files /root/parallels/* recusively from development server to production server same directory for upgrade setup files?

    Thank you for your kind attention.
    Regards,
    George.
     
  2. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Try to remove /root/parallels/ directory from the server where you are running upgrade and run autoinstaller one more time. It could probably related to latest templates updates and differences in info files.
     
  3. mustangp51

    mustangp51 Guest

    0
     
    I am having same exact problem on FC8 system. Did Dmitry's recommendation to delete files from install directory work for you?
     
  4. mustangp51

    mustangp51 Guest

    0
     
    did that & got this result: Starting installation of packages
    Installing the package psa-updates-9.0.1-fc8.build90090127.18.noarch (b 0xb24d3f0 source=0x9854c90 P:1 R:1)
    /etc/selinux/targeted/contexts/files/file_contexts: Multiple different specifications for /usr/local/sitebuilder/tmp(/.*)? (system_u:eek:bject_r:httpd_sys_content_t:s0 and system_u:eek:bject_r:tmp_t:s0).
    package psa-updates-9.0.1-fc8.build90090127.18.noarch is already installed
    ERROR: Unable to install the requested packages because either there is
    not enough free disk space left, or there are package dependency problems.
    Warning! Not all packages were installed.
    Please check if your system services are operable.
    Please, contact product technical support.
     
  5. mustangp51

    mustangp51 Guest

    0
     
    confirmed setenforce 0, deleted 1 sitebuilder refer in selinux context file. ran from command line again. same result.
    also checked disk partitions using df -h command. none at limits. re set all & ran from within control. same as yesterday and failure info different from command line..
    ****
    Warning: unresolved requires 'psa = 9.0.0' from psa-api-rpc-9.0.0-fc8.build90081208.07.noarch (s 0xa47b978 source=0xa444b10 P:83 R:6)
    Warning: unresolved requires 'psa-api = 9.0.0-fc8.build90081208.07' from psa-api-rpc-9.0.0-fc8.build90081208.07.noarch (s 0xa47b978 source=0xa444b10 P:83 R:6)
    Warning: unresolved requires 'psa = 9.0.0' from psa-updates-9.0.0-fc8.build90081222.11.noarch (s 0xa47ba90 source=0xa444b10 P:1 R:3)
    Warning: unresolved requires 'kpartx' from dmraid-1.0.0.rc14-4.fc8.i386 (s 0xa846640 source=0xa444b10 P:18 R:17)
    Warning: unresolved requires 'psa = 9.0.0' from psa-backup-manager-9.0.0-fc8.build90081208.07.i586 (s 0xad181c8 source=0xa444b10 P:392 R:6)
    Warning: unresolved requires 'radeontool' from pm-utils-0.99.4-6.fc8.i386 (s 0xa4ae418 source=0xa444b10 P:51 R:14)
    Warning: unresolved requires 'vbetool' from pm-utils-0.99.4-6.fc8.i386 (s 0xa4ae418 source=0xa444b10 P:51 R:14)
    Warning: unresolved requires '/usr/bin/lp' from redhat-lsb-3.1-19.fc8.i386 (s 0xa4ae788 source=0xa444b10 P:29 R:152)
    Warning: unresolved requires '/usr/bin/lpr' from redhat-lsb-3.1-19.fc8.i386 (s 0xa4ae788 source=0xa444b10 P:29 R:152)
    Warning: unresolved requires '/usr/sbin/sendmail' from redhat-lsb-3.1-19.fc8.i386 (s 0xa4ae788 source=0xa444b10 P:29 R:152)
    Warning: unresolved requires 'psa-api = 9.0.0-fc8.build90081208.07' from psa-migration-manager-9.0.0-fc8.build90081208.07.i586 (s 0xa4b63a0 source=0xa444b10 P:278 R:49)
    Warning: unresolved requires 'psa = 9.0.0' from psa-migration-manager-9.0.0-fc8.build90081208.07.i586 (s 0xa4b63a0 source=0xa444b10 P:278 R:49)
    Installing the package psa-updates-9.0.1-fc8.build90090127.18.noarch (b 0xb3e4e48 source=0xa625708 P:1 R:1)
    package psa-updates-9.0.1-fc8.build90090127.18.noarch is already installed
    ERROR: Unable to install the requested packages because either there is
    not enough free disk space left, or there are package dependency problems.
    Warning! Not all packages were installed.
    Please check if your system services are operable.
    Please, contact product technical support.
    *****
    any ideas here appreciated.
     
  6. mustangp51

    mustangp51 Guest

    0
     
    Another update: I should note: the check sum issue did go away on deletion of the contents of the install directory.

    In looking at all the files getting warnings I have noted there are 2 of all the psa rpm's. example using rpm -q psa-api-rpc:
    psa-api-rpc-9.0.0-fc8.build90081208.07
    psa-api-rpc-9.0.1-fc8.build90090127.18

    should I remove the 9.0.0 versions?

    as for the redhat rpm's mentioned...rpm finds these:
    dmraid-1.0.0.rc14-4.fc8
    redhat-lsb-3.1-19.fc8

    Thanks for any help
     
  7. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    First of all I can suggest you to check disk space one more time as the error message informs you about this:
    "Unable to install the requested packages because either there is not enough free disk space left..."

    As for packets: psa-api-rpc-9.0.0-fc8.build90081208.07 and psa-api-rpc-9.0.1-fc8.build90090127.18, you need to make sure that psa-9.0.1 is installed on the server and remove old psa-api-rpc-9.0.0-fc8.build90081208.07.

    Actually, this is mostly related to Plesk but not Sitebuilder. Try to update all existing components for Plesk first and after that install/upgrade Sitebuilder. If there are still any issues provide /tmp/autoinstaller3.log here. It could help me to understand what can be the reason for this.
     
  8. mustangp51

    mustangp51 Guest

    0
     
    I agree it became a plesk problem. just to be sure on file space I deleted the cache file from the tmp dir. I remove all the 9.0.0 rpm's that reported "unresolved" which was psa-api-rpc, psa-updates, psa-backup-manager, and psa-migration-manager. The re-install appeared to go ok BUT on psa start, I got error 1033 (HY000) "incorrect information in file" xxxx.frm in 3 of the table .frm's misc, sesssions, & DomainServices.frm. & PLESK would not run. I spent all day researching ways to fix - your recommendation from a 2007 post on 8.1, "incorrect information in 'misc' table and several other discussion. A whole set of thread on innodb lines & file size mismatch in my.cnf as the cause seemed a goose chase. according to mysql "show engine" Innodb is disabled. finally... I restored everything from the daily dump of yesterday. NOW I have a very weird situation... all the modules are 9.0.1 but certain (1 for sure) functions don't exist...as was the case in 9.0.0. such as I can't choose Webmail in mail setup - no webmail client are seen neither horde or atmail are options but both show installed and of JAN 27 2009 version. I have figured other things out. making progress 7 some potato vodka help calm me. Webmail choice is still open. As for the whole Sitebuilder thing- except for the license recognition, it seems to be working now. Thank you.
     
    Last edited by a moderator: Feb 19, 2009
  9. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Mustangp51,

    Sorry for the delay. Did you sort our Webmail missing option issue? By the way, it is better to separate threads related to Parallels Plesk and Parallels Plesk Sitebuilder. It should help other users find necessary information more effectively.
     
  10. mustangp51

    mustangp51 Guest

    0
     
    Dmitry, Thank you for checking. Actually it seems resolved as of yesterday. after exploring & chasing some other things, I simply removed psa-horde & atmail with yum, then reinstalled via command line autoinstaller. Now the control panel sees both as options. I also did this remove/install approach on spamassassin & fixed some problem with it. and Horde works but atmail fails. I will not chase atmail problem now. Now I am working on billing & again Sitebuilder (it would not publish) both of which I removed. I am also checking each service & module more carefully, even though plesk sees them installed, 3 so far had some issue that yum remove / reinstall corrected. Thank you again.
     
Loading...