1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Urgent!!! Please Help!!!

Discussion in 'Plesk for Linux - 8.x and Older' started by Limedrink, Oct 7, 2006.

  1. Limedrink

    Limedrink Guest

    0
     
    I just upgraded my 7.5.4 installation to 8.0.0 (supposedly).

    The upgrade failed.

    At the bottom of the log, I get:

    Error while execute command rpm -U /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/java/mod_jk-ap20-1.2.15-42psa.fc1.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/base/psa-8.0.0-fc1.build80060425.18.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/base/psa-locale-base-en-US-8.0.0-fc1.build80060331.13.noarch.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/base/psa-api-8.0.0-fc1.build80060413.08.noarch.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/updater/psa-autoinstaller-3.0.1-build060406.10.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/base/psa-libpam-plesk-8.0.0-fc1.build80060331.13.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/modules/bf1942/psa-bf1942-1.0.0-fc1.build80060331.13.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/docs/psa-manual-custom-skin-guide-8.0.0-fc1.build80060331.13.noarch.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/modules/firewall/psa-firewall-1.0.1-fc1.build80060331.13.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/modules/vpn/psa-vpn-2.0.1-fc1.build80060331.13.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/modules/fileserver/psa-fileserver-1.0.0-fc1.build80060331.13.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/migration/psa-migration-manager-8.0.0-fc1.build80060413.08.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/modules/watchdog/psa-watchdog-2.0.0-fc1.build80060331.13.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/modules/csgs/cs-gs-2.0.0-fc1.build80060331.13.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/backup/psa-backup-manager-8.0.0-fc1.build80060413.08.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/mail/psa-spamassassin-8.0.0-fc1.build80060331.13.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/api/psa-api-rpc-8.0.0-fc1.build80060413.08.noarch.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/java/psa-tomcat-configurator-8.0.0-fc1.build80060331.13.noarch.rpm /root/psa/PSA_8.0.0/update-rpm-FedoraCore-1-i386/spamassassin-3.1.0-1.i386.rpm /root/psa/PSA_8.0.0/update-rpm-FedoraCore-1-i386/perl-Mail-SpamAssassin-3.1.0-1.i386.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/opt/api/psa-agent-1.4.0-80060331.13.noarch.rpm
    ERROR: error while executing RPM


    And nothing works... I need to either get 8.0.0 working or go back to 7.5.4.

    I am running FC1.

    Any ideas what to do?


    Regards,

    Limedrink.
     
  2. 0031

    0031 Guest

    0
     
    Did you try to run this command manually?
     
  3. Limedrink

    Limedrink Guest

    0
     
    Yes, I did.

    I ended up actually being able to revert the PSA database back to before the upgrade, then force-installing the 7.5.4 RPMs, and then restoring some configuration files until I got the critical services back online.

    I resolved the issue with SWsoft support and it was actually a combination of messed up privilege tables, but mostly duplicate entries in the PSA database:

    http://forum.swsoft.com/showthread.php?s=&postid=144668#post144668


    Regards

    Limedrink.
     
Loading...