1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

User does not exist

Discussion in 'Plesk for Linux - 8.x and Older' started by celticsoul, Apr 14, 2005.

  1. celticsoul

    celticsoul Guest

    0
     
    HI, I've done some edit to /etc/httpd/conf/httpd.include and /etc/httpd/conf/httpd.conf then I restarted httpd but SOME of my domains got the default apache's page intead of their home page. found out that's it's because of the corruption if the httpd.include file, I've tried to use:
    /usr/local/psa/admin/sbin/websrvmng -a -v
    to rebuild the file but I got:
    websrvmng: User trananhtu does not exist, virtual host trananhtu.info skipped
    websrvmng: User trananhtu does not exist, virtual host trananhtu.info skipped
    websrvmng: User traitim does not exist, virtual host haitraitimhong.com skippedwebsrvmng: User traitim does not exist, virtual host haitraitimhong.com skippedwebsrvmng: User chuyenle does not exist, virtual host lehongphong-nd.org skippedwebsrvmng: User chuyenle does not e...
    ,,,,

    I'm not able to disable or delete the domains in plesk control panel neither.
    Please help.
    Thank you.
     
  2. hardweb

    hardweb Guest

    0
     
    Most likely you deleted the FTP users from the system. The solution is to add them manually using useradd.
     
  3. celticsoul

    celticsoul Guest

    0
     
    I have tried to add them using useradd but websrvmng did not rebuild the httpd file for that domain correctly ( or it did not rebuild at all, I doon't know).

    How to make websrvmng rebuild the file automaticlly?

    Thanks.
     
  4. celticsoul

    celticsoul Guest

    0
     
    For some reasons, users have been disappeared,

    ---------------------------------------------------------
    [root@cyberlot root]# ls -la
    /home/httpd/vhosts/freehosting4vn.net/
    total 76
    drwxr-xr-x 19 root root 4096 Apr 10 03:23 .
    drwxr-xr-x 61 root root 4096 Apr 14 12:54 ..
    drwxr-x--- 5 10055 psaserv 4096 Apr 10 03:23
    anon_ftp
    drwxr-xr-x 2 root root 4096 Apr 10 03:23 bin
    drwxr-x--- 2 10055 psaserv 4096 Apr 10 03:23
    cgi-bin
    drwxr-x--- 2 root psaserv 4096 Apr 14 13:45
    conf
    drwxr-xr-x 2 root psaserv 4096 Apr 10 03:23
    error_docs
    drwxr-xr-x 2 root root 4096 Apr 10 03:23 etc
    drwxr-x--- 3 10055 psaserv 4096 Apr 10 03:23
    httpdocs
    drwxr-x--- 3 10055 psaserv 4096 Apr 10 03:23
    httpsdocs
    drwxr-xr-x 2 root root 4096 Apr 10 03:23 lib
    drwxr-x--- 2 root psaserv 4096 Apr 10 03:23 pd
    drwx------ 2 10055 root 4096 Apr 10 03:23
    private
    .....
    [root@cyberlot root]# grep 10055 /etc/passwd
    [root@cyberlot root]#
    ---------------------------------------------------------


    Please help.

    Thanks.
     
  5. hardweb

    hardweb Guest

    0
     
    You must add the users manually, this is the only solution. You can also edit the /etc/passwd file, with the right UID you can see on the Plesk directories.
     
Loading...