1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

using smartermail and smarterstats with plesk

Discussion in 'Plesk for Windows - 8.x and Older' started by manos2000, Jul 26, 2007.

  1. manos2000

    manos2000 Guest

    0
     
    As i know from previous experience, on both these tools it is better to stop their servers and attach the processes to IIS (it is more secure and uses much less cpu).
    If this is done then plesk recognises these as components or not?

    thanks

    manos
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    You can use SmarterMail and SmarterTools with IIS.
    Plesk recognises SmaterMail or SmarterTools as Windows services.
    In order to Plesk can connect to it you should specify on page Plesk > Server > Components Management appropriate parameteres login, password and port.
     
  3. manos2000

    manos2000 Guest

    0
     
    smartetools at 8.2

    tried it, attached the process to IIS, it is working fine from web interface but plesk does not recognises it

    env: plesk 8.2 / SmarterMail Server 4.3.2760

    manos
     
  4. manos2000

    manos2000 Guest

    0
     
    smartertools

    Found this at swsoft kb:
    Since version 7.6 Plesk allows selecting web server provider for SM web service: IIS or SM native Web Server

    but where can i choose the web server provider? There is no option after installing plesk?

    thanks

    manos
     
  5. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Plesk tries to connect to SmarterMail or SmarterStats on localhost and specifed port.
     
  6. manos2000

    manos2000 Guest

    0
     
    smartertools

    yep but using localhost smartermail and smarterstats servers must have unassigned (all) ips.
    i prefered to use unique ips for the servers in order users to not have put 9998 or 9999 ports as many firewalls block these ports

    manos
     
  7. LeaUK

    LeaUK Guest

    0
     
    In plesk 8.1 I had to ensure SM was running on both 80 (for normal access using IIS) and 9998 so Plesk could talk to SM.

    I didn't find an option to change the port number as advised above :( but maybe 8.2 has this new facility?

    Lea
     
  8. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Please click on Plesk > Server > Components Management > Mail Server > SmarterMail
     
  9. LeaUK

    LeaUK Guest

    0
     
    Thanks sergius

    You are quite right, there is a port option in 8.1.

    But now I remember why I kept 9998 open, it's because I get this error if I choose port 80

    "Error: Some fields are empty or contain an improper value."

    ????


    Smarter mail is working fine on port 80, but Plesk cannot talk to it?
     
  10. manos2000

    manos2000 Guest

    0
     
    smartertools

    If u use port 80 then u have to use unique ips for smartermail and smarterstats or if u use shared ips with other sites u have to use different host headers.
    In case u use unique ips at port 80 (best option in my opinion) plesk has not a field to declare this ip so can not communicate.It communicates only if u use all (unassigned) ips.
    As sergius said they will fix it in next version.


    manos
     
  11. LeaUK

    LeaUK Guest

    0
     
    I run both SM and SS in IIS, both on the same IP and both on port 80, they have different host headers webmail.mydomain.com and stats.mydomain.com

    But, Ples fails to talk to SM on port 80 even if configured to do so, the error message above is given by Plesk. However I leave SM running on 9998 and configure Plesk for this port.

    The rest of the world can use port 80 to talk to SM :)

    Works for me

    Lea
     
  12. manos2000

    manos2000 Guest

    0
     
    smartertools

    i run also attached on IIS SM and SS, use ports 9998 and 9999 so plesk can communicate with these.
    The problem is that user has to type www.mydomain.com:port in order ot use webiinterface.
    The best would be to use a unique ip at port 80 for each service and add a default A record at server>DNS webmail.domain.com = ip

    manos
     
  13. LeaUK

    LeaUK Guest

    0
     
    Ah, I had to use some tricks to fool Plesk into adding host headers in the SM IIS site....here's how:

     
Loading...