1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Vhost Include Doesn't work for SSL

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by bsterzenbach, Feb 23, 2009.

  1. bsterzenbach

    bsterzenbach Guest

    0
     
    It appears that the vhost.conf include found in httpd.include does not apply to SSL protected requests.

    For example, in my vhost.conf file I place open_basedir directives to allow for additional directories. When browsing via SSL the includes no longer work.

    Since the include that calls vhost.conf is placed outside of the SSL virtual server directive, the modifications in vhost.conf are not applied to SSL requests. Is there a way around this?

    Thanks

    Bill
     
  2. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    965
    Likes Received:
    32
    Location:
    Romania
    vhost_ssl.conf and in httpd.include in the 443 part to place the include of this file.
     
  3. TroyP

    TroyP Guest

    0
     
    I'm having the exact same issue. Placing the directives in vhost_ssl.conf and /usr/local/psa/admin/sbin/websrvmng --reconfigure-vhost-ssl --vhost-name=domain.com and apachctl restart does nothing to correct it. Any advice on this?
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
Loading...