1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

vhost without hostheaders

Discussion in 'Plesk for Windows - 8.x and Older' started by mrvandalen, Feb 8, 2006.

  1. mrvandalen

    mrvandalen Guest

    0
     
    Hello,

    I've recently started using my dedicated server and I'm experiencing some trouble with setting up a vhost without hostheaders (my hosting company told me to set this up).

    Right now when a visitor types in a subdomain that doesn't exist they get forwareded to a default domain (my website). I don't want this to happen, I want to forward them to a standard oops page or something. I host several websites and people have asked me why I send visitors to my own site when their visitors type in nonexistingsubdomein.domain.com.

    Can someone explain me how to make this work?

    Thanks

    PS. Should I do something specific with my DNS settings?
     
  2. mrvandalen

    mrvandalen Guest

    0
     
    I'm new to this forum so I'm not sure if I placed the topic in the correct section?
     
  3. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    you probably have dns pointing to your server, and without hostheader you will see the default web site. Make sure you have not chosen a default site for the ip.
     
  4. mrvandalen

    mrvandalen Guest

    0
     
    I've looked up how to change a default domain, but I cannot alter this setting. I get my default domain set in plain text and not in an input field.

    When logged in as administrator I go to:
    1. Server
    2. IP addresses
    3. IP address (on the overview I select my only ip address)
    4. I can see my default domain in plain text (not in an inputfield)

    Hope you can help me out.

    Thanks!
     
  5. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    you set default by clicking on the number of hosted domains in the ip list, not on the ip itself ;) try see if you can choose none there
     
  6. mrvandalen

    mrvandalen Guest

    0
     
    Wow, I did not know that - thanks....

    The only thing now is that I need to set one of the domains as default. I thought of setting up a new hosting account using www.one-of-the-domains.com/default/index.html as domain, but this trick didn't work.

    Any suggestions?
     
  7. mrvandalen

    mrvandalen Guest

    0
     
    Could it have something to do with my DNS settings? When I try to reach my site with "mydomain.com" (without the www) I get a "The page cannot be displayed" page.

    Could anyone shed some light on this. I need to get the default domain and mydomain.com thing working asap....

    Thanks a million
     
  8. oatmeal@

    oatmeal@ Guest

    0
     
    mydomain.com does not work because you do not have a host header telling IIS where to look for the site.
    You cannot vhost in IIS without host headers.
     
  9. mrvandalen

    mrvandalen Guest

    0
     
    mydomain.com does not work because you do not have a host header telling IIS where to look for the site.
    How can I get this to work then? Should I use PLesk or do I have to something manually on my server?

    You cannot vhost in IIS without host headers.
    So I'll never be able to avoid people typing in a wrong address to see my own site?
     
Loading...