1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

VPN Services Do No Start After Reboot

Discussion in 'Plesk for Linux - 8.x and Older' started by vision, May 3, 2006.

  1. vision

    vision Guest

    0
     
    I've started using the VPN services (on a Fedora box), however the service is not starting automatically after I reboot.

    When I look at the module, I have the switch to disable the module. After I reboot, it shows the service is enabled (button shows disable) but it does not work.

    I have to disable, then enable and the VPN will start working.

    Anyone know where to look to fix this problem?
     
  2. nars

    nars Guest

    0
     
    I had same problem and after digging about it I have found the problem is that the psa-vpn init script doesn't create the file /var/lock/subsys/psa-vpn, this causes it to never run the script with stop param at runlevel 6 (reboot) as it should do, and therefore the pid file is never removed, which causes it to refuse to start at next reboot... to fix the problem, edit the file /etc/init.d/psa-vpn

    search for:
    Code:
        if $PRODUCT_ROOT_D/admin/sbin/modules/$MODULE/openvpn --config "$conf"; then
          echo "$SERVICE_NAME: OpenVPN has been started"
    after this add:
    Code:
          touch /var/lock/subsys/psa-vpn
    search for:
    Code:
        if [ -f "$pid" ]; then
          kill `cat "$pid"`
          rm -f "$pid"
    after this add:
    Code:
          rm -f /var/lock/subsys/psa-vpn
    Then start/stop the service and it will now work correcty after reboot.
     
Loading...