1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Watchdog buggy or just setting adjustment

Discussion in 'Plesk for Linux - 8.x and Older' started by rvdmeer, Oct 20, 2005.

  1. rvdmeer

    rvdmeer Guest

    0
     
    Hi,

    If i'm reading the forum threads nobody is positive about watchdog because it should include bugs. For so far the only error i experienced was that qmail didnt restart because the statement for the qmail restart in watchdog is:

    /usr/local/psa/admin/bin/mailmng --start-smtpd

    This will only restart the mailmng. If you change this for example into "/etc/init.d/qmail restart" it would be fine right?

    I'm asking this because i dont see any other bugs.

    Regards,
    Ronald
     
  2. Hal9000

    Hal9000 Guest

    0
     
    it would interest me too, i have the same excat problem.
    and i am actually wondering what is taking sw-soft so long to fix this problem.
    my users are getting kind of sick to have their mails not appear for hours (until i start qmail from the plesk panel again).
     
  3. ShadowMan@

    ShadowMan@ Guest

    0
     
    The last update included a watchdog fix where it affected Spamassassin, they are still working on fixing other bug(s). Most people just uninstall Watchdog to avoid problems.

    Isn't it enough that it interfere's with Qmail? I would think that would be more than enough of a problem to warrant not using it until it's fixed properly.... (IMO)
     
  4. Hal9000

    Hal9000 Guest

    0
     
    yes indeed, i removed the watchdog module... wtf, it does just the contrary of what's supposed to do: keep the system up and running!
    hal
     
  5. rvdmeer

    rvdmeer Guest

    0
     
    without the swearing, thanks for the information.
     
  6. Hal9000

    Hal9000 Guest

    0
     
    sorry, i was kind of upset...
    i edited my post.
    hal
     
  7. Hal9000

    Hal9000 Guest

    0
     
    As in my case qmail was stopping even without the watchdog, i reinstalled it and firstly changed the parameter as you said. Qmail got restarted and worked, but the watchdog still thought it was down.
    I now changed the "start" command to this, i hope it works better next time:
    /opt/psa/admin/bin/mailmng --start-smtpd && /etc/init.d/qmail restart
    e.g. it should execute both commands, the one that makes qmail start and the one that makes the watchdog happy :p
     
  8. Inner Child 77

    Inner Child 77 Guest

    0
     
    Personally I had it installed and things seemed to be fine but my outgoing mail grinded and them about a week ago qmail stopped and I had to go in and restart it. I think uninstalled Watchdog and qmail works good and my outgoing email is fast again.

    IC
     
  9. kozchris

    kozchris New Pleskian

    22
    23%
    Joined:
    Sep 4, 2005
    Messages:
    8
    Likes Received:
    0
    So this is why I keep having to restart qmail. WTF? I turned off watchdog but only after I had customers complaining.
     
  10. Hal9000

    Hal9000 Guest

    0
     
    i uninstalled the watchdog, but qmail keeped stopping...
    then i re-enabled the watchdog with another parameter (/etc/init.d/qmail restart for starting it up) and it worked... till tonight.

    ANOTHER 15 HOURS DOWNTIME OF QMAIL!
    SW-SOFT!!! YOU WON YOUR AWARD! [link]
    NOW SHOW YOU DESERVE IT AND DO SOMETHING ABOUT QMAIL !!!!!!!!!!!
     
  11. poke

    poke Guest

    0
     
    Server Assistant Version 2 just came out today by 4PSA... It is very nice looking and WORKS! It costs a few bucks, but it does its job.

    Take a look here:
    http://www.4psa.com/company/newsid.php?id=54

    and as always, jbwebhosting.com offers 10 % off all 4PSA products and bundles :)
     
Loading...