1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Web Mail

Discussion in 'Plesk for Linux - 8.x and Older' started by Spyder, Jan 4, 2005.

  1. Spyder

    Spyder Regular Pleskian

    25
    40%
    Joined:
    Jan 13, 2003
    Messages:
    155
    Likes Received:
    0
  2. bartje3

    bartje3 Guest

    0
     
    Webmail https

    Hi,

    Found this here in the forum, easiest solution:

    -----------------------------------------------------
    Ouote:

    Open your webmail/horde/index.php file with your favorite editor. At the top of the page (after <?php) enter:

    $page = "https://".$HTTP_SERVER_VARS['HTTP_HOST'];
    if ($HTTP_SERVER_VARS['SERVER_PORT'] == "80") {
    header("Location: ".$page);
    }

    save your file. test by pointing your browser to webmail: http://webmail.[domain.com]

    Works for me. Should work for you.
    ------------------------------------------------------

    Regards,
    Bart
     
  3. Spyder

    Spyder Regular Pleskian

    25
    40%
    Joined:
    Jan 13, 2003
    Messages:
    155
    Likes Received:
    0
    Thank's..... but the problem is no run under plain http.... the main question is how to move the horde to answer in other location not on the default webmail sub domain....

    let me try post anoter example...

    default >

    http(s)://webmail.domain.com


    new location >

    http(s)://www.domain.com/webmail.

    (the biggest problem is my very poor english :( )
     
  4. Spyder

    Spyder Regular Pleskian

    25
    40%
    Joined:
    Jan 13, 2003
    Messages:
    155
    Likes Received:
    0
    Hi, no one can find answer ??

    Tia.
     
  5. bartje3

    bartje3 Guest

    0
     
    Maybe ?

    Hi,

    Maybe you could use this ? But I think you have to modify it.

    --------------------------------------------------------------------------------------
    --------------------------------------------------------------------------------------

    edit your /etc/httpd/conf/httpd.conf file and insert something like following right _before_ "Include /etc/httpd/conf/httpd.include" line:



    code:--------------------------------------------------------------------------------
    <VirtualHost NNN.NNN.NNN.NNN:80>
    ServerName webmail.*
    ServerAlias webmail.*
    RewriteEngine on
    RewriteRule ^/ https://%{SERVER_NAME}/ [R]
    </VirtualHost>
    --------------------------------------------------------------------------------


    Where NNN.NNN.NNN.NNN needs to be replaced with the real server IP address where webmail.domain.com resolves to.
    don't forget to restart Apache to reread configuration changes.
    --------------------------------------------------------------------------------------
    --------------------------------------------------------------------------------------

    Maybe you could use: RewriteRule ^/ http://%{SERVER_NAME}/ webmail/[R]
    ...or something like that, figure it out ;o)

    Regards,
    Bart
     
  6. Who-m3

    Who-m3 Guest

    0
     
    An easier fix would be to look into the .htaccess directives for Apache. If I'm not mistaken, webmail will open under https and http (secure and standard) protocols. Perhaps an .htaccess directive to load the webmail page when the /webmail direcotry is called would be a fix for what you need. If not, the users should still be able to login to webmail via the standard protocol.

    Another fix would be to install a separate e-mail checking applications, such as SquirrelMail, UebiMiau, etc, in the domain itself. This would give the client more customization, allowing them to modify the files for their webmail. Horde, too, would be an option.

    One such application exists in the Application Vault, if you have a license to use it. UebiMiau (page 2, app vault).
     
  7. Spyder

    Spyder Regular Pleskian

    25
    40%
    Joined:
    Jan 13, 2003
    Messages:
    155
    Likes Received:
    0
    Thank´s for all... replies... I will try.

    and forgive me for the rude "no one can find answer ??" I must write ..

    Hi,

    "some one find ?? "

    TIA
     
  8. pdxmike

    pdxmike Guest

    0
     
    i've tried both suggestions (modifying index.php and httpd.conf) and i get a timeout when trying to access webmail via https (this happens on both firefox and internet explorer). I enabled ssl when I configured my domain - is there anything else i need to do?
    also, I assume EITHER of those methods should work - no need to do both (?)
     
  9. sydan

    sydan Guest

    0
     
    Easiest way to force SSL may be use .htaccess file:

    Code:
    RewriteEngine On
    RewriteCond %{SERVER_PORT} !^443$
    RewriteRule ^(.*)?$ https://%{SERVER_NAME}%{REQUEST_URI} [L,R]
    
    
    For Horde Imp with Plesk 7.1.5 the place for .htaccess is /home/httpd/vhosts/webmail
     
Loading...