1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

webmail stopped working after 7.5.3

Discussion in 'Plesk for Linux - 8.x and Older' started by atomicmak, May 17, 2005.

  1. atomicmak

    atomicmak Guest

    0
     
    i have 7.5.2 working with squirrelmail perfectly and when i updated 7.5.3 and didnt check for horde addon it still updated horde and now my squirrelmail dosent being redirect only opens horde.

    i think there is something changed in horde.

    i have

    /etc/httpd/conf.d/squirrelmail.conf

    #
    # SquirrelMail is a webmail package written in PHP.
    #

    #Alias /webmail /usr/share/squirrelmail

    #
    # SquirrelMail is a webmail package written in PHP.
    # This is a config file for apache 2.0.
    # $Id: squirrelmail.conf,v 1.2 2003/03/27 03:08:16 graf25 Exp $
    #

    Alias /horde /usr/share/squirrelmail
    Alias /imp /usr/share/squirrelmail

    <Directory /usr/share/squirrelmail>
    php_admin_flag engine on
    php_admin_flag magic_quotes_gpc off
    php_admin_value safe_mode off
    # php_admin_value open_basedir "/"
    </Directory>

    =================================
    can anybody help me running the same way a squirrelmail ?

    ths is little urgent if someone can point me as my all clients lost their squirrelmail need.
     
  2. JohnB@

    JohnB@ Guest

    0
     
    Exact same problem here.
    Did you find a solution?

    John
     
  3. trauma

    trauma Guest

    0
     
    I'm suffering with exactly the same issue. Unfortunately, customers noticed it before I did.
     
  4. JohnB@

    JohnB@ Guest

    0
     
    Out datacenter support person just pointed out that /etc/httpd/conf/httpd.include can be edited. It works. BUT whenever apache is restarted the files gets rewritten and this change gets overwritten.
    Ideas??
     
  5. atomicmak

    atomicmak Guest

    0
     
    thats true

    there is no way to workout the thing as httpd.include gets re generated whenever we edit something in cp or restart the apache.

    apache 2 says squirrelmail.conf in
    /etc/httpd/conf.d/
    could be workout but it is not working that way also.

    can someone look at the matter??

    i am anther week running off my own custom webmail & customer get noice on me daily.
     
  6. proserve

    proserve Guest

    0
     
    You'll have to run /usr/local/psa/admin/bin/websrvmng -a

    After that a restart of plesk is needed

    This because the location of horde has been changed, and the configfiles need to be rewriten.
     
  7. atomicmak

    atomicmak Guest

    0
     
    well thats okay but here we dont require to run horde or not wanted as we have our own squirrelmail rediret like

    http://webmail.domain.tld/horde/src/login.php

    so in 7.5.2 it was working perfect but its not working in 7.5.3
     
  8. JohnB@

    JohnB@ Guest

    0
     
    I have received a SOLUTION to this from Plesk technicians (see below). However, we decided not to use this and to go with the standard NEW login at http://YourWebsite.com/webmail/ instead ....

    ------ Q U O T E ---------

    You can try redefine required VirtualHost following way:

    Copy complete VirtualHost from httpd.include, add it into httpd.conf
    BEFORE httpd.include, for example

    ==========
    <VirtualHost 1.2.3.4:80>
    DocumentRoot /usr/local/psa/psa-horde/
    Alias /horde/ /usr/local/psa/psa-horde/
    Alias /imp/ /usr/local/psa/psa-horde/imp/
    ServerName webmail
    ....

    </VirtualHost>

    Include /usr/local/psa/apache/conf/httpd.include
    ==========

    Then make all the required changes directly in httpd.conf and restart
    apache. Apache will take first VirtualHost definition from httpd.conf
    and ignore the second one form httpd.include.

    Note that it may affect further Plesk updates or this virtualhost may
    have changes in future Plesk versions, so that it is better to remove
    this custom definition from httpd.conf before Plesk update and
    copy/create it anew after Plesk update accurding to new httpd.include..
    ------------------------
     
  9. linuxFreek

    linuxFreek Guest

    0
     
    SOLUTION!!!!!!!!

    Hey guys/girls,

    Here is the solution that worked for me:
    this is my squirrelmail.conf file:

    <Directory /home/httpd/vhosts/ebizdna.net/httpdocs/server/squirrelmail>
    php_admin_flag engine on
    php_admin_flag magic_quotes_gpc off
    php_admin_value safe_mode off
    php_admin_value open_basedir "/usr/share/pear:/home/httpd/vhosts/ebizdna.net/httpdocs/server/squirrelmail"
    </Directory>

    ** notice the last line that you have to add the dir that squirrelmail is in for it to work. let me know if this helps you. :)
     
  10. atomicmak

    atomicmak Guest

    0
     
    thanks

    I have just did some terick given base on "JohnB" I think its working that way

    open httpd.conf and at the end of file just put your settings e.g.

    ####################################
    <VirtualHost \
    xx.xx.xx.xx:80 \
    >
    DocumentRoot /usr/share/squirrelmail/
    Alias /horde/ /usr/share/squirrelmail/
    ServerName webmail
    ServerAlias webmail.*
    UseCanonicalName Off
    <Directory /usr/share/squirrelmail>
    <IfModule sapi_apache2.c>
    php_admin_flag engine on
    php_admin_flag magic_quotes_gpc off
    php_admin_flag safe_mode off
    php_admin_value open_basedir "/usr/share/pear:/usr/share/squirrelmail"
    </IfModule>
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>
    ####################################
    just add your ip to top and restart apache and you're done.

    if i get any more problem on this i will post ASAP
     
  11. atomicmak

    atomicmak Guest

    0
     
    there is one problem i've found is when i add fresh new domain to controlpanel and try to access

    http://www.newdomain.tld

    it shows squirrelmail webmail due to addition of virtualhost in the httpd.conf

    please can someone tell me how to have both default underconstruction page as it is and this webmail.domain.tld goes to squirrelmail ?
     
  12. JohnB@

    JohnB@ Guest

    0
     
    Can you repharse this:

    -----
    it shows squirrelmail webmail due to addition of virtualhost in the httpd.conf
    -----

    Don't understand what is happening??

    John
     
  13. atomicmak

    atomicmak Guest

    0
     
    I have added below code to httpd.conf not in httpd.include and webmail started working but lets say now someone tries to access www.newdomain.tld just added fresh that shows webmail login page not the default under construction page.

    here is the code i aded to my httpd.conf

    ####################################
    <VirtualHost \
    xx.xx.xx.xx:80 \
    >
    DocumentRoot /usr/share/squirrelmail/
    Alias /horde/ /usr/share/squirrelmail/
    ServerName webmail
    ServerAlias webmail.*
    UseCanonicalName Off
    <Directory /usr/share/squirrelmail>
    <IfModule sapi_apache2.c>
    php_admin_flag engine on
    php_admin_flag magic_quotes_gpc off
    php_admin_flag safe_mode off
    php_admin_value open_basedir "/usr/share/pear:/usr/share/squirrelmail"
    </IfModule>
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>
    ####################################

    my webmai started working but now someone tries to access www.newdomain.tld which is just added newely also shows webmail login page rather to show a default welcome page of hosting provider.
     
  14. JohnB@

    JohnB@ Guest

    0
     
    Hi again:

    Anyone has found a satisfactory solution for this yet?

    John
     
  15. trauma

    trauma Guest

    0
     
    This worked for me... (obviously changing the xx's to your appropriate IP addresses).

    I replaced the squirrelmail.conf file with the stuff below, and just make sure that it's included before httpd.include in your httpd.conf file. Seems to be working fine so far.

    ###
    <VirtualHost \
    xx.xx.xx.xx:80 \
    xx.xx.xx.xx:80 \
    xx.xx.xx.xx:80 \
    xx.xx.xx.xx:80 \
    >
    DocumentRoot /usr/share/squirrelmail/
    Alias /horde/ /usr/share/squirrelmail/
    ServerName webmail
    ServerAlias webmail.*
    UseCanonicalName Off
    <Directory /usr/share/squirrelmail>
    <IfModule mod_php4.c>
    php_admin_flag engine on
    php_admin_flag magic_quotes_gpc off
    php_admin_flag safe_mode off
    php_admin_value open_basedir "/usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/tmp"
    </IfModule>
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>
    ###
     
  16. vbslim

    vbslim Guest

    0
     
    Seems to work fine...

    Thanks for this
     
Loading...