1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Why Can't i forward to gmail and yahoo-mail after upgrade to 8.4

Discussion in 'Plesk for Linux - 8.x and Older' started by ToolBox, May 12, 2008.

  1. ToolBox

    ToolBox Basic Pleskian

    23
    57%
    Joined:
    Jul 10, 2005
    Messages:
    36
    Likes Received:
    0
    Why Can't i forward to gmail and yahoo-mail after upgrade to 8.4?

    mailer daemon reply this messages.
    --------------------------------------------------
    Hi. This is the qmail-send program at xxxxxxxxxx.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.

    <XXXXXXXX.YYYYYYYY@gmail.com>:
    handlers permanentfail
    --------------------------------------------------

    Why?
     
  2. joeybutterface

    joeybutterface Guest

    0
     
    Yes it's broken. Several of us have reported it already. I have no idea whether Parallels will bother fixing it.
     
  3. exi1ed0ne

    exi1ed0ne Guest

    0
     
    It looks related to the domainkeys implementation. From my maillog:
    qmail-remote-handlers[17994]: call_handlers: stop call handlers because handler 'dd51-domainkeys' not PASS (31)
     
  4. exi1ed0ne

    exi1ed0ne Guest

    0
     
    Well, it is working this morning after not changing anything, and I have a theory. It may have been the internal DNS was not updated to reflect the domain keys entry, so it was failing locally. I can't verify that a bind restart would fix it though, as I'm out of boxes. :)

    Might be something to look at if someone else has an issue.
     
  5. exi1ed0ne

    exi1ed0ne Guest

    0
     
    Alright, it looks like it has NOT gone away. However it seems specific to when I send from a gmail address to a valid forwarding email address in Plesk which forwards it to a yahoo email address. Even thought I have the server set to NOT verify domainkeys, it still appears to be doing so.

    This is just unacceptable. Where is the fix? Is it being worked on? The knowledgebase is useless.
     
  6. joeybutterface

    joeybutterface Guest

    0
     
  7. pfellner

    pfellner Guest

    0
     
    I've got the same issue. We just upgraded to 8.4. We didn't have this problem on 8.3. Domainkeys are turned on.
     
  8. PixyPumpkin

    PixyPumpkin Guest

    0
     
    Did somebody hear something from Parallels about this BUG?
     
  9. pfellner

    pfellner Guest

    0
     
    Sending from gmail is correct but it's not limited to yahoo email forwards. I have a client on cox.net getting the same errors.
     
  10. joeybutterface

    joeybutterface Guest

    0
     
    Read my reply above. They need help tracking down the cause.

    Compile the evidence and send it to Sergius (who works for Parallels) so they can fix this bug more quickly.
     
  11. ToolBox

    ToolBox Basic Pleskian

    23
    57%
    Joined:
    Jul 10, 2005
    Messages:
    36
    Likes Received:
    0
    I have two gmail address.

    a@gmail.com
    b@gmail.com

    and my email settings are

    Address : myemail@pleskcontroledserver.com
    Redirect : On ( to a@gmail.com )

    in the gmail UI.
    i sent to a@gmail.com from account b@gmail.com.

    plesk server report this.....

    --------------------------------------------------
    Hi. This is the qmail-send program at pleskcontroledserver.com.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.

    <a@gmail.com>:
    handlers permanentfail
    --------------------------------------------------

    Ofcource pleskcontroledserver.com is not ..... I'm using my real domain.....

    If i remove two checkmark from
    Controlpanel > Server > mail > DomainKeys spam protection
    Allow signing outgoing mail
    Verify incoming mail
    no error reporting.

    Server Info:
    CentOS 5.
    Plesk version 8.4 upgrade from 8.3.
     
  12. pfellner

    pfellner Guest

    0
     
    It appears as though the problem lies with the signing of the outgoing email with Domainkeys.

    Controlpanel > Server > mail > DomainKeys spam protection
    I unchecked "Allow signing outgoing mail" but left "Verify incoming mail" checked and no errors. This is just a workaround but it's better than we're getting from Parallels.
     
  13. PixyPumpkin

    PixyPumpkin Guest

    0
     
    Thank you :)
     
  14. pfellner

    pfellner Guest

    0
     
  15. ToolBox

    ToolBox Basic Pleskian

    23
    57%
    Joined:
    Jul 10, 2005
    Messages:
    36
    Likes Received:
    0
    update-patch on 23th May 2008 (jst) but not fix it...

    Hi. This is the qmail-send program at server.mydomain.jp.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.

    <toolbox@gmail.com>:
    handlers permanentfail

    --- Below this line is a copy of the message.

    Return-Path: <anotherid@gmail.com>
    Received: (qmail 3777 invoked by uid 110); 23 May 2008 11:07:00 +0900
    Delivered-To: 1-mainid@server.mydomain.jp
    DomainKey-Status: good
    X-Spam-Checker-Version: SpamAssassin 3.2.4 (2008-01-01) on server.mydomain.jp
    X-Spam-Level: **
    X-Spam-Status: No, score=2.2 required=7.0 tests=AWL,BAYES_50,TVD_SPACE_RATIO
    autolearn=no version=3.2.4
    DomainKey-Status: good
    Received: (qmail 3763 invoked from network); 23 May 2008 11:06:58 +0900
    Received: from wf-out-1314.google.com (209.85.200.170)
    by mydomain.jp with SMTP; 23 May 2008 11:06:58 +0900
    Received-SPF: pass (mydomain.jp: SPF record at _spf.google.com designates 209.85.200.170 as permitted sender)
    Received: by wf-out-1314.google.com with SMTP id 28so296159wfc.20
    for <mainid@server.mydomain.jp>; Thu, 22 May 2008 19:07:05 -0700 (PDT)
    DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
    d=gmail.com; s=gamma;
    h=domainkey-signature:received:received:message-id:date:from:reply-to:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition;
    bh=q5cyARPl5zX/knmvCnEy11G7/r6gcljJ44qrvv5DErY=;
    b=kIrxHr8rbU29RSVQAUwS7/D8ddWf6Ynb19EZ/sydJ9jicQQdijmFTGy/n9PXnf9TdP7twO9tAWgO2Cpsj+vVZe6mt7ZWAm/rEpenMMFOB7gcss8R+Dyxd6HjUA5J9n0juEahlJGdV9R9p8ORTqc9LY8mBWpXDcAEaxk+RjJJK2A=
    DomainKey-Signature: a=rsa-sha1; c=nofws;
    d=gmail.com; s=gamma;
    h=message-id:date:from:reply-to:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition;
    b=hx1DvxLO+k8BWjbfQQ6481jox1S+g2M9qSBaM1B4kIlxcnlVjYsdeN2FEQxfHTgDtT2q7a1nm9aB5Wcdwt+n7RWrT41qFQC62+EkPmYx7aMEemREc0Ghwyet3qGSDMgbvV1LpMxvFYKyEQffykYGxqK0hJ4JvgorJhEFOsFvQOQ=
    Received: by 10.143.19.16 with SMTP id w16mr342941wfi.223.1211508425544;
    Thu, 22 May 2008 19:07:05 -0700 (PDT)
    Received: by 10.142.127.6 with HTTP; Thu, 22 May 2008 19:07:05 -0700 (PDT)
    Message-ID: <6b8e815e0805221907t1e1cc795vf6a09241672005c6@mail.gmail.com>
    Date: Fri, 23 May 2008 11:07:05 +0900
    From: "=?ISO-2022-JP?B?GyRCJUklIiVdJTElQyVIOWJMWhsoQg==?=" <anotherid@gmail.com>
    Reply-To: anotherid@gmail.com
    To: mainid@server.mydomain.jp
    Subject: TEST
    MIME-Version: 1.0
    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: 7bit
    Content-Disposition: inline

    TEST
     
  16. chapuisat

    chapuisat Guest

    0
     
    Hi,

    same Problem here. Mail coming from gmail.com to which is forwarded to xxx@profimailer.de. Plesk 8.4.0 with DomainKey activated.

    ==============
    Hi. This is the qmail-send program at xxx.xxx.net.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.

    <xxx@profimailer.de>:
    handlers permanentfail

    Return-Path: <xxx@gmail.com>
    Received: (qmail 21872 invoked by uid 110); 24 May 2008 19:11:42 +0200
    Delivered-To: 7-xxx@xxx.de
    DomainKey-Status: good
    X-Spam-Checker-Version: SpamAssassin 3.1.0 (2005-09-13) on xxx.xxx.net
    X-Spam-Level:
    X-Spam-Status: No, score=-97.9 required=5.0 tests=AWL,BAYES_50,HTML_30_40,
    HTML_MESSAGE,USER_IN_WHITELIST autolearn=ham version=3.1.0
    DomainKey-Status: good
    Received: (qmail 19834 invoked from network); 24 May 2008 19:11:38 +0200
    Received: from rv-out-0708.google.com (209.85.198.242)
    by xxx.xxx.net with SMTP; 24 May 2008 19:11:38 +0200
    Received: by rv-out-0708.google.com with SMTP id f25so1116152rvb.32
    for <xxx@xxx.de>; Sat, 24 May 2008 10:11:36 -0700 (PDT)
    DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
    d=gmail.com; s=gamma;
    h=domainkey-signature:received:received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references;
    bh=W9cix9WejMYwpUDYrLw1v8MjEnCsZ1dmkCJb3uhzeXY=;
    b=KQUu/ET/njTli0e5++zPmc24KvR8DmJbHHjSwDNF12VN0CQyNKmVKc9UucGY5tggf9lC/6JFG+65JojO5h43Rj6DUEIeRre+CL44131pVNA3Pgdg2PjCaF6YLzbPBSF75Np/5eSK54APsJcJwhqfSdha/IOV9G5tQgB+uay5dos=
    DomainKey-Signature: a=rsa-sha1; c=nofws;
    d=gmail.com; s=gamma;
    h=message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references;
    b=v70OqlebcqLYZN7f4I53MWxSd9D/udNY744rTCfWOpDjZrMWYbNbMTfDRCqq/FCizpvWpgN3Q4QfjOLYTMUHQwoxrqaqU5p8FWGZsLs4xN3IROV2lnjGzeeQX2CEvFwviIVqKaCHsZ98nb9L3AKbVsTBubU5Dn6eYLRvq0QSPFw=
    Received: by 10.141.198.9 with SMTP id a9mr1273035rvq.280.1211649096071;
    Sat, 24 May 2008 10:11:36 -0700 (PDT)
    Received: by 10.141.145.20 with HTTP; Sat, 24 May 2008 10:11:36 -0700 (PDT)
    Message-ID: <199d96b80805241011k2a3336d5u194cd0e71b195404@mail.gmail.com>
    Date: Sat, 24 May 2008 19:11:36 +0200

    ==============
     
  17. exi1ed0ne

    exi1ed0ne Guest

    0
     
    Looks like people have been letting Sergius know:

    The limits on PMs is ridiculously small for normal users too. Makes no sense given the cost of disk space these days.
     
  18. gerryb

    gerryb Guest

    0
     
    Spam Protection Error 8.4.0

    I had to TURN OFF spam protection based on DNS blackhole lists as after 8.4.0 install. DNS spam protection stopped me sending emails (by rejecting them) from my home IP address. Spamhaus correctly sees my IP as a non-fixed IP of virgin media, and should block direct to mx. But is NOT the correct behaviour for relayed SMTP authenticated connections. It would mean neither I or my users would not be able to use my email servers from home/office. Spamhaus/DNS blackhole lists should NOT block authenticated SMTP connections.

    Further more my server now ignores the IP whitelist IP completely. Putting in my home IP in that list makes no difference when DNS protection is turned on.

    Spamhaus report is as below:

    "Ref: PBL041637

    82.21.0.0/16 is listed on the Policy Block List (PBL)

    --------------------------------------------------------------------------------
    Outbound Email Policy of The Spamhaus Project for this IP range:

    This IP range has been identified by Spamhaus as not meeting our policy for IPs which should deliver 'direct-to-mx' mail to PBL users.
    Important: If you are using any normal email software such as Outlook, Entourage, Thunderbird, Apple Mail, and you are being blocked by this Spamhaus PBL listing when you try to send email, the reason is simply that you need to turn on "SMTP Authentication" in your email software settings (Tools : Accounts : Properties : Outgoing Mail Server : check "My server requires authentication").
    If you do not know how to do this, ask your Internet Service Provider for help with "SMTP Authentication".

    See also: http://www.spamhaus.org/faq/answers.lasso?section=Spamhaus PBL
     
  19. ToolBox

    ToolBox Basic Pleskian

    23
    57%
    Joined:
    Jul 10, 2005
    Messages:
    36
    Likes Received:
    0
    Why does not parallels solve this problem?

    Why?

    Isn't this problem a bug?

    Isn't it wrong as the principle of operation?

    Why do not they do anything?
     
  20. PixyPumpkin

    PixyPumpkin Guest

    0
     
    Or at least let us know that they are working on a fix or something, why did they not test it :( this bug should be fixed weeks ago IMO...
     
Loading...