1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

.wml files / .htaccess

Discussion in 'Plesk for Linux - 8.x and Older' started by RootChaos, Dec 23, 2005.

  1. RootChaos

    RootChaos Guest

    0
     
    Hi Guys

    I've been reading some posts on getting .htaccess files working as well as getting .wml files working.

    As far as I can see, I have AllowOverride All set on the directory /home/httpd/vhosts in the config file /etc/httpd/conf/httpd.include

    <Directory "/home/httpd/vhosts">
    AllowOverride All
    Options SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    php_admin_flag engine off
    </Directory>


    Which means that .htaccess should be working in any virtual host directory and sub-directories.

    I also have a .htaccess file with the following :-

    # Enable WML (Wireless Markup Language)
    AddType text/vnd.wap.wml .wml
    AddType image/vnd.wap.wbmp .wbmp
    AddType application/vnd.wap.wmlc .wmlc
    AddType text/vnd.wap.wmlscript .wmls
    AddType application/vnd.wap.wmlscriptc .wmlsc
    DirectoryIndex index.wml


    Which should allow index.wml to be the default index file and also enable WAP content.

    I don't think this config is working as I cannot browse to the index.wml file. It finds the file, but then prompts to save the file in stead of opening the file in the browser.


    Can anyone suggest some steps where I'm going wrong ?


    Thanx

    RC
     
  2. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Have you added .wml directly to the DirectoryIndex line of httpd.conf?
     
  3. RootChaos

    RootChaos Guest

    0
     
    Hi...

    I did not have index.wml in DirectoryIndex on httpd.conf - Added it just now but still no working result. Still wants to save the file...


    RC
     
  4. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Once you added it, did you restart httpd?

    #service httpd restart
     
  5. RootChaos

    RootChaos Guest

    0
     
    Indeed I did.
     
Loading...