1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Wow Cgi/perl Problem Finally Fixed?

Discussion in 'Plesk for Linux - 8.x and Older' started by tecdady, May 30, 2005.

  1. tecdady

    tecdady Guest

    0
     
    this is unreal. i looked into the httpd.include file in the conf directory of one of my virtual domains. this is what was included for the execution of perl files in the httpd.include:

    <Directory /home/httpd/vhosts/final9sports.com/httpdocs>
    <IfModule mod_perl.c>
    <Files ~ (\.pl$)>
    SetHandler perl-script
    PerlHandler ModPerl::Registry
    Options ExecCGI
    allow from all
    PerlSendHeader On
    </Files>


    Anyone see a massive problem here?
    <Directory /home/httpd/vhosts/final9sports.com/httpdocs>

    eh... hmm. httpdocs? i changed the to cgi-bin. all scripts ran IMMEDIATELY. you have got to be kidding me. could this REALLY be the problem? this is on a psa 7.5.3 box. now im scared after reading that plesk overwrites these files, this will get changed back and everything will break again. can someone shed some light on this and let me know what ive found. and that if it is THE problem, where to fix a "master" conf file so that this wont get overwritten with the incorrect file location.
     
  2. jshanley

    jshanley Guest

    0
     
    I'm not aware of a way to change the default without receiving a fix from SW-Soft themselves. Email their support department and ask for a fix.

    And you're right - they screwed up. All those people on the forums that say "SW Soft -does- do testing, if it's broken it's probably something you did wrong" make me laugh. I think SW-Soft testing mostly consists of "did we get a compile error for this build? No? Cool! Release it!" hehe. They're badly in need of an engineer that actually understands the concept of regression testing. They very badly need a "real" test suite for their products.
     
  3. tecdady

    tecdady Guest

    0
     
    hey J, thanks for the reply, i did notice that after i made this change the perl all worked, but all the php died... very strange stuff. there is something REALLY wrong with this. IT SHOULD NOT BE THIS HARD TO MAKE PERL SCRIPTS RUN PERIOD. its borderline rediculous, and for those of you who have yet to switch to php, or like me that still have perl code for some of your clients, its just madness. can anyone evaluate the solution ive posted and let me know what the ramifications would be fully? im a good sysadmin, but no where near what it takes to know the full quarks of psa and what this would do to apache etc.
    chris
     
  4. tecdady

    tecdady Guest

    0
     
    the complete irony of it all..... cgi and perl scripts run 100% a-ok in the httpdocs directory. HAHAHAHAHA. so here is my suggestion. forget the cgi-bin. its broken. dont spend 97623972937429374 hours like i have trying to make your perl script run there. its a waste of time. just put them into the httpdocs dir. swsoft knows about this problem. trust me. they knew about it before they even released this software. they just dont know how to fix it. you dont create something like this, and not know its shortcomings. its just a shame, they dont have the talent to fix the monster they have created. welcome to the world of software folks.
     
  5. Maxim Kutov

    Maxim Kutov Guest

    0
     
    Hello,

    Actually we cannot confirm that this line is wrong.

    <Directory /home/httpd/vhosts/final9sports.com/httpdocs>

    And moreover if you replace /home/httpd/vhosts/final9sports.com/httpdocs for /home/httpd/vhosts/final9sports.com/cgi-bin, then it could cause more problems.

    This kind of code is needed for Mod_perl only.

    <Directory /home/httpd/vhosts/final9sports.com/httpdocs>
    <IfModule mod_perl.c>
    <Files ~ (\.pl$)>
    SetHandler perl-script
    PerlHandler ModPerl::Registry
    Options ExecCGI
    allow from all
    PerlSendHeader On
    </Files>


    If you would like to use perl scripts with .pl ext. inside httpdocs folder, then you have to use vhost.conf file with following content:

    <Directory /home/httpd/vhosts/final9sports.com/httpdocs>
    <Files ~ (\.pl$)>
    AddHandler cgi-script .cgi .pl
    Options +ExecCGI
    </Files>
    </Directory>

    Everything was checked out with psa-7.5.3-build75050506.13
     
  6. tecdady

    tecdady Guest

    0
     
    actually, i can run perl scripts inside the httpdocs folder without any kind of modification whatsoever to the vhost.conf folder. but still, why wont scripts run in the cgi-bin? i realize my solution maybe wrong as i eluded to that. instead of telling me its wrong, why cant someone from swsoft tell us how to make it work correctly? i mean, bigfoot exists right? can a working cgi-bin be that elusive? this makes no sense....
     
  7. panaman

    panaman Guest

    0
     
    yeah, i have a client with his stuff broke also...
    Its wierd... some of the clients work ok and some don't

    But if i copy his .pl scripts to httpdocs.. they work correctly???????

    on another client they work correctly in the cgi-bin folder....

    i am running 7.5.2

    I am not going to tell my client to put all his stuff httpdocs... then when someday they actually do fix it... they won't work in httpdocs
     
  8. panaman

    panaman Guest

    0
     
    this is the error i get in my suexec_log

    [2005-06-02 15:05:33]: target uid/gid (10075/10001 or $ld) mismatch with directory (2524/10075) or program (2524/10075)
     
  9. panaman

    panaman Guest

    0
     
    I changed the group on the file "test.pl" from psaserv to psacln and it ran the test.pl out of the cgi-bin directory.. on a couple hosts..

    On this one hosts i am just getting"
    Forbidden
    You do not have permission to access this document.
     
  10. tecdady

    tecdady Guest

    0
     
    again, the ability to tell us our solution is wrong, seems to be the order of the day for swsoft. the want to tell us the solution to THEIR problem seems to be completely elusive. ill never understand it.
     
Loading...