1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

WYSIWYG Broke After Upgrade

Discussion in 'Plesk for Linux - 8.x and Older' started by gdeakyne, Dec 28, 2007.

  1. gdeakyne

    gdeakyne Guest

    0
     
    I updated from 8.2 to 8.3 and now the WYSIWYG throws IE errors and is unusable. I've tried multiple files to edit, multiple domains, multiple Plesk servers. All of my plesk servers are CentOS 4 x86_64 that are VPSs on Virtuozzo. Anyone else try the WYSIWYG editor in IE7 and see any issues. I see this across 8 Plesk Servers.
     
  2. biznesshosting

    biznesshosting Guest

    0
     
    have you contacted plesk directly??

    this seems a bit odd to happen to 8 machines at the same time.....
     
  3. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    I have IE7 and plesk 8.3 and have no problems on the WYSIWYG - perhaps you can give us reproduction steps? Admitedly I didnt try too much in the editor, just opened it, made a couple of edits and saved, had no problems to report with that.
     
  4. gdeakyne

    gdeakyne Guest

    0
     
    I have a support ticket opened and they just informed me that it's a bug and that when the developers return on the 7th, it will be a high priority. They said that it was reproducible on both virtuozzo servers (which I use) and stand-alone servers.
    I tried both centos 4 (i386 & x86_64) and fedora 6 (i386 & x86_64). I tried using the templated install of plesk that you install via virtuozzo and the auto_installer. All combinations had the same error. You go to edit a file in the WYSIWYG and it throws a javascript error in IE7 and just shows a blank page and you can't click any of the buttons on the toolbar.
    I finally just setup new servers with 8.2.1 and migrated the domains over. I think I will wait a few weeks to see if there's another patch since there seems to be a large number of issues that others are having.
    One interesting thing about the WYSIWYG is that it's developed by solmetra and the version within Plesk is v1.0. If you go to solmetra's site, there's already a 2.0, check it out

    I wonder why they don't use a newer version within plesk, maybe one that works in other browsers besides IE. We use the Professional Website Editor by Plesk, but you have to login with the ftp credentials to access the WYSIWYG and that's annoying that you have to login twice to get into the editor.
     
  5. dash

    dash Regular Pleskian Staff Member

    28
    40%
    Joined:
    Sep 26, 2007
    Messages:
    204
    Likes Received:
    47
    Gentlemen,
    As a workaround you can just remove first line ( <? ?>) from /usr/local/psa/admin/htdocs/spaw/class/script.js.php file.
    The fix will be released with nearest Plesk update.
     
  6. burnley

    burnley Regular Pleskian

    28
    57%
    Joined:
    Feb 6, 2008
    Messages:
    222
    Likes Received:
    2
    Location:
    Melbourne, Vic
    I can confirm the work around posted by 'dash' does work. Thanks dash!

    I had customers having issues with IE6 as well as 7. It loads in IE6 but you could not type anything, some other customers could type but the tool bar at the top went AWOL.

    SPAW 2 would be nice if anyone at swsoft is listening.

    p.s ... is it just me or does SPAW 2 sound like some cheap B grade hollywood movie?
     
  7. gdeakyne

    gdeakyne Guest

    0
     
    I agree that a spaw upgrade would be a nice inclusion on the next release. I haev a customer that has an embedded flash video on their home page and whenever they update that page, it messes up the html code. Here's a post on spaw's forum referencing a spaw update that fixes this issue, http://forums.solmetra.com/viewtopic.php?t=1524

    Has anyone tried to manually upgrade spaw?
     
  8. dash

    dash Regular Pleskian Staff Member

    28
    40%
    Joined:
    Sep 26, 2007
    Messages:
    204
    Likes Received:
    47
    I agree - 1.04 which is distributed with Plesk is too old
    The lates stable version is 2.0.6 and Plesk 8.4 will include it.
     
  9. gdeakyne

    gdeakyne Guest

    0
     
    Is there a date for 8.4 yet?
     
Loading...