1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

yum, up2date, el3, and atomicturtle

Discussion in 'Plesk for Linux - 8.x and Older' started by DaemonJ, Jan 4, 2005.

  1. DaemonJ

    DaemonJ Guest

    0
     
    I am trying to update my version of php to 4.3.10 and was recommended to use AtomicTurtle.com's RPMs through yum.

    According to the documentation at AtomicTurtle, I just had to add the channels to the /etc/sysconfig/rhn/sources file, which I have done.

    Now I am unsure of how to proceed.

    Can anyone offer advice / guidance?
     
  2. Who-m3

    Who-m3 Guest

    0
     
    yum help will return quiet a bit of useful information for you.

    In this case, "yum update <package>" is what you're looking for. Since you want to update php, "yum update php" should do the job for you. It'll connect to ART, download quiet a few headers, then ask if you're sure you want it to install a list of packages. With ART's yum archive, it should outline all the dependancies and have them listed before it tries to update. I'm sure other archives do this as well, but I can speak of it on ART's because I've used it for other items.
     
  3. serve-you.net

    serve-you.net Guest

    0
     
    If you are using the rhn method, then you just need to do "up2date -u" after you add the sources to your sources.
     
  4. DaemonJ

    DaemonJ Guest

    0
     
    The problem was that I do not have yum installed and AtomicTurtle says to use up2date instead of yum on my OS.

    I will give "up2date -u" a try as serve-you.net suggests. What is the rhn method and how do I know if that is what I am using or not?
     
  5. serve-you.net

    serve-you.net Guest

    0
     
    From ART:

    For up2date configurations (FC1, 3ES) modify your /etc/sysconfig/rhn/sources file, replacing CHANGEME with 3ES for 3ES systems, and 1 for FC1 systems:


    # THIS CONTAINS MY PSA COMPATIBLE RPMS
    yum atomic-psa http://www.atomicrocketturtle.com/atomic/psa/CHANGEME/


    # THIS CONTAINS ONLY SW-SOFT's PSA 7.0.x RPMS.
    # USE THIS CHANNEL IF YOU USE PSA 7.0.x
    yum atomic-psa7 http://www.atomicrocketturtle.com/atomic/psa7/CHANGEME/


    # THIS CONTAINS ONLY SW-SOFT's PSA 7.1.x RPMS
    # USE THIS CHANNEL IF YOU USE PSA 7.1.x
    yum atomic-psa71 http://www.atomicrocketturtle.com/atomic/psa71/CHANGEME/
     
  6. DaemonJ

    DaemonJ Guest

    0
     
    Yep, I followed those instructions but could not find any documentation or instructions for what I should *do* with up2date in regards to how to run it and with what options.

    I am not familiar with any of this and did not know the proper way to proceed with running up2date.

    I did run the "up2date -u" command as you suggested and it said that php v4.3.10 was not installed, which was the one thing that I was after.

    This is the response that I received:
    PHP:
    Testing package set solving RPM inter-dependencies...
    There was a package dependency problemThe message was:

        
    To solve all dependencies for the RPMs you have selectedThe following
        packages you have marked to exclude would have to be added to the set
    :

        
    Package Name                        Reason For Skipping
        
    ======================================================================
        
    php-4.3.10-1.rhel3.art              Config modified

    Unresolvable chain of dependencies
    :
    aspell-0.33.7.1-25.3                     requires aspell-config 2:0.33.7.1
    ethereal  0.10.5
    -0.30E.2                 requires libnetsnmp.so.5
    net
    -snmp  5.0.9-2.30E.12                 requires libnetsnmp.so.5
    net
    -snmp  5.0.9-2.30E.12                 requires libnetsnmpagent.so.5
    net
    -snmp  5.0.9-2.30E.12                 requires libnetsnmphelpers.so.5
    net
    -snmp  5.0.9-2.30E.12                 requires libnetsnmpmibs.so.5
    php
    -imap-4.3.10-1.rhel3.art              requires php 4.3.10-1.rhel3.art
    php
    -mysql-4.3.10-1.rhel3.art             requires php 4.3.10-1.rhel3.art
    php
    -pgsql-4.3.10-1.rhel3.art             requires php 4.3.10-1.rhel3.art

    Any idea what I need to change and where in order to get php updated?
     
  7. DaemonJ

    DaemonJ Guest

    0
     
    I also just noticed that there is no 7.5.1 channel listed.

    Will that have a detrimental effect by having listings for the previous 2 versions and not the version that I am using (i.e. 7.5.1)?
     
  8. DaemonJ

    DaemonJ Guest

    0
     
    Perhaps I am asking the wrong question(s).

    How is everyone else upgrading their php version to 4.3.10 due to the latest security problems with earlier versions?
     
Loading...