• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

[nginx as apache proxy] Unable to generate web server configuratión

estratagemas

New Pleskian
Plesk: 12.5.30
OS: Centos 7.1.1503

I've server with nginx as apache reverse proxy (nginx on :80 and apache on :7080).
Web page works fine but i get this error on plesk:

Unable to generate the web server configuration file on the host because of the following errors:

Template_Exception: Can not restart web server: httpd stop failed
0 /usr/sbin/httpd processes are killed
httpd stop failed
0 /usr/sbin/httpd processes are killed

file: /usr/local/psa/admin/plib/Service/Driver/Web/Server/Apache.php
line: 110
code: 0

Please resolve the errors in web server configuration templates and generate the file again.
I try to restart apache or reconfigure the domain(httpdmng) but i get the same error.

Any ideas?

Thanks
 
Hi estratagemas,

to start, you could use

If you experience issues, you might notice, that Plesk stores repair - procedures in logs at "/var/log/plesk". Please investigate possible issues/errors/problems/failures from these logs.


You could as well always use the command

/usr/local/psa/admin/bin/autoinstaller --select-product-id plesk --select-release-current --reinstall-patch --install-component base

... to be sure, that all latest patches are installed for your current Plesk installation.
 
Back
Top