• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

PHP through Apache does not work after upgrade

R

Rexxars

Guest
Hi!

Encountered a bug in PHP on the server, so I decided to try and upgrade Plesk hoping it would upgrade PHP. Well, something went wrong.

Firstly Apache wouldn't start but I fixed that by remove 'php_admin_value' as mentioned in the log from a config file. But now, Apache won't read interpret PHP files- it just outputs them to the web browser!

Here's the parts from the log that I could tell went wrong:

Purging configuration files for apache2-common ...
dpkg - warning: while removing apache2-common, directory `/etc/apache2/conf.d' not empty so not removed.
dpkg - warning: while removing apache2-common, directory `/var/www' not empty so not removed.
(Reading database ... 45856 files and directories currently installed.)
Preparing to replace apache2-mpm-prefork 2.0.54-5sarge1 (using .../apache2-mpm-prefork_2.2.3-4+etch1_i386.deb) ...
invoke-rc.d: unknown initscript, /etc/init.d/apache2 not found.
dpkg: warning - old pre-removal script returned error exit status 100
dpkg - trying script from the new package instead ...
dpkg: ... it looks like that went OK.

Starting web server (apache2)...Syntax error on line 15 of /var/www/vhosts/<maskedsite>/conf/httpd.include:
Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the server configuration
[31mfailed! [39;49m
invoke-rc.d: initscript apache2, action "start" failed.

Trying to establish test connection... connected
done
Syntax error on line 2 of /var/www/vhosts/<maskedsite>/conf/vhost.conf:
Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration
websrvmng: Service /etc/init.d/apache2 failed to reload
websrvmng: Service /etc/init.d/apache2 failed to reload

Also, when I try to upgrade Plesk through the control panel, it now says
Error: Not found source for system packages (release 3.1, codename sarge) in /etc/apt/sources.list

But source.list looks like this:

deb https://autoinstall.plesk.com/debian/PSA_8.1.1 sarge all
#deb http://packages.dotdeb.org stable all
#deb-src http://packages.dotdeb.org stable all

deb http://ftp.de.debian.org/debian/ stable main
deb-src http://ftp.de.debian.org/debian/ stable main

deb http://security.debian.org/ stable/updates main
deb http://www.backports.org/debian/ sarge-backports main contrib non-free
deb-src http://www.backports.org/debian/ sarge-backports main contrib non-free

Any ideas? I'm totally lost and don't know where to turn.
 
Back
Top