1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

10.4.4 Upgrade with mysql conflicts

Discussion in 'Plesk 10.x for Linux Suggestions and Feedback' started by Ernie@, Dec 26, 2011.

  1. Ernie@

    Ernie@ Basic Pleskian

    23
    57%
    Joined:
    Aug 27, 2005
    Messages:
    36
    Likes Received:
    0
    Hi IgorG,

    Thanks for your prompt reply. I've resolved some of the problems.

    However, when I executed
    /usr/local/psa/admin/sbin/autoinstaller --select-release-latest --upgrade-installed-components

    it comes to another problem about the MySQL conflicts as below. I'm currently installed MySQL 5.5.19 and php 5.3.

    Can I remove the libmysqlclient?

    Thanks.

    ===============================
    autoinstaller3.log extract
    -------------------------


    #selectBestResolvers(): Can't find solution for 'libmysqlclient.so.15()(64bit)' of plesk-core-10.13.4-cos5.build1013111102.18.x86_64.
    Add plesk-core-10.13.4-cos5.build1013111102.18.x86_64 to black list
    Migrating plesk-core-10.13.4-cos5.build1013111102.18.x86_64 to blacklist
    The requested package "plesk-core" could not be installed: dependency 'libmysqlclient.so.15()(64bit)' is unresolved
    ---- start dependency problems explanation -----
    Searching problems for the "plesk-core" package.
    plesk-core-10.13.4-cos5.build1013111102.18.x86_64: No suitable solutions were found
    for the "libmysqlclient.so.15()(64bit)" dependency.
    The "MySQL-shared-compat-5.5.19-1.rhel5.x86_64" package resolves "libmysqlclient.so.15()(64bit)".
    There is no explanation for the "MySQL-shared-compat" package.
    The "libmysqlclient15-5.0.77-4.el5_5.4.11062011.x86_64" package resolves "libmysqlclient.so.15()(64bit)".
    There is no explanation for the "libmysqlclient15" package.
    The "mysql-5.0.77-4.el5_6.6.x86_64" package resolves "libmysqlclient.so.15()(64bit)".
    Searching problems for the "mysql" package.
    Unable to downgrade 'mysql' package to version 5.0.77-4.el5_6.6:
    version 5.5.14-11071510 is currently installed.
    The "libmysqlclient15-5.0.77-4.el5_5.4.11062011.x86_64" package resolves "libmysqlclient.so.15()(64bit)".
    There is no explanation for the "libmysqlclient15" package.
    ---- end dependency problems explanation -----
    Solution for dependency 'libmysqlclient.so.15()(64bit)' is not available.

    The following could cause the installation failure:
    1)plesk-core-10.13.4-cos5.build1013111102.18.x86_64: No suitable solutions were found
    for the "libmysqlclient.so.15()(64bit)" dependency.

    2)Unable to downgrade 'mysql' package to version 5.0.77-4.el5_6.6:
    version 5.5.14-11071510 is currently installed.



    The following could cause the installation failure:
    1)plesk-core-10.13.4-cos5.build1013111102.18.x86_64: No suitable solutions were found
    for the "libmysqlclient.so.15()(64bit)" dependency.

    2)Unable to downgrade 'mysql' package to version 5.0.77-4.el5_6.6:
    version 5.5.14-11071510 is currently installed.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Not sure but you can try to remove conflicted packages only from rpm database with corresponding option --justdb for rpm command.
     
Loading...