1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

3 Reasons why .NET will not work in PLESK

Discussion in 'Plesk for Windows - 8.x and Older' started by knocx, Mar 22, 2005.

  1. knocx

    knocx Guest

    0
     
    1 - Plesk does not have an option to setup the application folder as a NET application
    2 - PLESK does not has capabilities to give r/w/x permissions for Machine ASPNET user to application directory
    3 - PLESK Does not have capabilities to assign the created applications application pool to the user application pool


    You have to configure all these manually to get clients .NET applications work!

    I hope they will issue a fix for that


    regards
    knocx
     
  2. ColorPrint

    ColorPrint Guest

    0
     
    Hm... about second point - you can setup permissions via Plesk File Manager (in domain options).

    I have ASP .NET applications running on my Plesk host without any problems
     
  3. knocx

    knocx Guest

    0
     
    Hi ;

    i do also I have ASP .NET applications running on my Plesk host without any problems.

    But the point is admin have to do manual configuraion , client can not configure such things from PLESK, can he?
     
  4. ColorPrint

    ColorPrint Guest

    0
     
    Hmm... I and my customers uses Plesk panel only to configure it
     
  5. knocx

    knocx Guest

    0
     
    Namely where can you initiate this action;

    How can you setup the application folder as a NET application ?

    can you tell me, i can not find it
     
  6. ColorPrint

    ColorPrint Guest

    0
     
    Setup "Virtual directories" in Plesk panel for your domain and check permissions and "Create application" option
     
  7. knocx

    knocx Guest

    0
     
    well i am so blind...

    thanks i haven't recognized it before
     
  8. kalexan

    kalexan Guest

    0
     
    Well when I setup a virtual dir I only wave these options:

    Name:
    Path:
    Read:
    Write :
    Script source access :
    Directory browsing :
    Execute permissions :

    where is the "Create application" option???
     
  9. ColorPrint

    ColorPrint Guest

    0
     
    Are you have "ASP.NET" option enabled for this domain?
     
  10. kalexan

    kalexan Guest

    0
     
    if you mean at :
    (hosting) setup > services > Microsoft ASP.NET support
    yes...
     
  11. jbrinkman

    jbrinkman Guest

    0
     
    This still ignores the fact that this "solution" only creates virtual directories. It does not allow me to run ASP.Net applications in the root directory. I want my site users to be able to go to http://mywebdomain.com/default.aspx and have that work. Right now I do not see a way to make it happen.
     
  12. ColorPrint

    ColorPrint Guest

    0
     
    hmm... I'm placed my test application in the root of domain and it works fine:
    http://test.vstu.org/index.aspx
     
  13. wharfratjoe

    wharfratjoe Guest

    0
     
    i installed the generic e-commerce site on a test site i have and asp.net was working for me.
     
  14. cybernova

    cybernova Guest

    0
     
    you can contact your support department to help you with this...there is an option in the iis to convert an existing folder in to an application.....in the web site properties and make sure that the web.config file is in the httpdocs directory itselsf as it might give an server application error ..if it is in the application directpry itself
     
  15. AutoWizard

    AutoWizard Guest

    0
     
    Please help

    Has anyone found a solution to this problem? Plesk is not allowing me to install an asp.net app at the root directory.
     
Loading...