• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

502 bad gateway after Nginx install

Julian Taylor

New Pleskian
First post so hi all, nice to meet you!

I've just upgraded my VPS from Plesk 11 to the latest version then upgraded the Ubuntu from 12.4 to 14.4 subsequent to doing this I installed NginX via the GUI and that has broken it!

After upgrading Plesk as per instructions we tried to run the final post script as per this instruction Run the post-upgrade script. The post-upgrade script is named distupgrade.helper.<OS.old-OS.new>_post.sh and is located in the /usr/lib/plesk-9.0/ directory but it came back and said this file is not there. My friend searched for it but couldn't find it at all.

When I go to the actual site www.***.*** then it says Err connection refused (before it went to a parallels holding screen) and when I try to log into Plesk it throws the 502 error.


This is the error I get in SSH and I wondered if anyone knew how to fix this?
/usr/bin/sw-engine: error while loading shared libraries: libboost_filesystem-plesk.so.1.55.0: cannot open shared object file: No such file or directory

I am not versed in SSH but my friend has been helping me and he does this stuff as a job. He will be coming online in 12 hours as he's in Australia.

Any help or suggestions welcome.

Cheers

Jools
 
After upgrading Plesk as per instructions we tried to run the final post script as per this instruction Run the post-upgrade script. The post-upgrade script is named distupgrade.helper.<OS.old-OS.new>_post.sh and is located in the /usr/lib/plesk-9.0/ directory but it came back and said this file is not there. My friend searched for it but couldn't find it at all.
According to official Plesk documentation this script is located in /usr/local/psa/bin directory - https://docs.plesk.com/en-US/12.5/a...ver-administration/distupgrade-support.74627/
Please use correct instruction.
 
Back
Top