• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Resolved 502 Bad Gateway on Plesk 12.5.30 #39 and Ubuntu server 14.04

Boris Panno

New Pleskian
Hi all,
the problem in the title is randomly. Above all at login to some sites made with Prestashop in the Front-end.
I could not figure out the source of the problem from the log files.
Can anyone give me any suggestions where can I look for the problem to solve it?
Thank you all in advance.
nginx_error_502_bad_gateway.png
Boris
 
Hi Boris Panno,

"502 Bad Gateway" - "nginx" - issues are mostly caused by missing or incorrect nginx directives, or as well by inactive services. Pls. be aware that there might be quite a lot of reasons, which you should investigate with the help of your domain - specific log - files:



You will find an awfull lot of "502" - issues/problems, when you use the Forum search. :) Pls. have a look at: https://talk.plesk.com/search/search?&keywords=502+bad+gateway
 
Back
Top