1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Activating the domain after tranfer

Discussion in 'Plesk for Windows - 8.x and Older' started by systemfx, Oct 6, 2005.

  1. systemfx

    systemfx Guest

    0
     
    Hi all,

    I am new to plesk. We just migrated our company site to dedicated server running plesk 7.5. on windows.

    all the dns entries appear to be correct and our cohost has moved all our DNS to the nameserver. Our name server on plesk is configured properly as far as I can tell.

    So I have up moved all our web files now to the httpdocs section.

    What I want to know is why every time I try and access our domain, I get a network login instead of our webpages?

    Is there something I have not configured properly? Please help!

    PLESK NOOBY
     
  2. eara01

    eara01 Guest

    0
     
  3. systemfx

    systemfx Guest

    0
     
    thanx for replying mate...

    Yes this is similar, although my problem is not FTP, its allowing our website to accessible for all the net.

    So I checked our list of IUSR and there's a "GUEST" account. Should that be selected?

    If not, what should be entered to make the site totally public?


    Cheers mate!

    I will be standing by waiting for your reply.
     
  4. eara01

    eara01 Guest

    0
     
    That link does not describe an FTP problem...it describes a "I'm a web surfer trying to browse your web site, but when I try to enter you want me to give you an FTP id and password" problem.

    When you enter the url www.whatever.whatever in your browser an ID and password prompt (network login?) appears. If you enter the FTP id and password it then lets you enter/browse the web site.

    So, not really an FTP problem, but FTP intrudinging on browsing.

    Regarding the guest account...sorry - I don't know about that one. I think the ID used to access the files is IUSR_<domainname>.
     
  5. systemfx

    systemfx Guest

    0
     
    Ok that makes sense, mate.

    I will give that a shot and see what happens.

    thanx for the prompt reply ;)
     
  6. systemfx

    systemfx Guest

    0
     
    Ok I just tried to do what you mention.

    My problem seems to be that there are no GROUPs or users currently defined that have permissions to view my domain/website.

    Now, the group "everyone" is there, and I tried setting some permissions for them, but it still does not remove the authentication notice when I try and view my site.

    How would I go about defining the IUSR_mydomain group when it does not exist?

    How would I begin to enter that? What os apps do that?
    Internet Information Services? IIS?

    a little befuddled...
     
  7. eara01

    eara01 Guest

    0
     
    Plesk should create the applicable IDs - you should be able to see them in the Windows Server Computer Management "Local Users and Groups." They should have been created when you created the domain in Plesk.

    ftp<domainname> (for browsing I think)
    IUSR_ftp<domainname> (anonymous ID)

    If they're not there, these commands might fix it up for you - at a DOS prompt on the server:

    cd %plesk_bin% (ie cd c:\Program Files\SWsoft\Plesk\admin\bin\)
    websrvmng --remove-vhost --vhost-name=<domainname>
    websrvmng --reconfigure-vhost --vhost-name=<domainname>

    websrvmng.exe is the executable, the rest are paramaters

    Or, you can try this (to hit all domains)
    websrvmng --reconfigure-all (you might want to try this one first)

    There doesn't seem to be a great deal of documentation on the command -line utilities...some say the --remove-vhost command deletes the files in the domain, some say it doesn't delete the files. I don't know myself (only did this on empty domains so I couldn't tell you for sure - let me know:p )
     
  8. systemfx

    systemfx Guest

    0
     
    By doing this, I can say that your going to DELETE all your domains, leaving nothing but a empty directory.

    No thanks, you try it.
     
  9. Antony

    Antony Guest

    0
     
    2systemfx: Eara01 gave you quite correct sequence of commands. 'Websrvmng --remove... ' utility removes the domain from IIS, not from Plesk and not from vhosts folder. Also 'websrvmng --reconfigure...' re-creates them in IIS with proper permissions and directory security.
    The other way to fix the issue is to istall all the hotfixes, provided on Plesk Patches page on this site, restart Plesk and run

    cd %plesk_bin%
    websrvmng --update-anon-passwords-all

    It fixes the issue with login/password too.
     
  10. systemfx

    systemfx Guest

    0
     
    Thanx for that Info, Antony - I'm glad someone at SW-SOFT stepped in.

    I owe Ear an apology :)

    I'll try it now.
     
  11. systemfx

    systemfx Guest

    0
     
    Hi Antony and Ear,

    So, I after all this I did find the proper method of setting up a Anonymous internet Account and give it permissions to our webserver.

    it was done by finding IUSR_<machinename>, in default users.
    and gave them every permission except FULL CONTROL.

    And that also did not work in allowing surfer to our site.

    then....

    I just tried both the commands that you both suggested.

    The one that Antony suggests I thought looked hopefull.

    But it did not work.

    It Kept saying that a command parameter was not available. I even double check my administrator permissions to be sure i could do it.



    So I tried:

    websrvmng --reconfigure-vhost --vhost-name=<domainname>

    and

    websrvmng --reconfigure - all

    which ran with out an error, but did not spit anything out. I then checked the sites to see if the authentication was gone...it wasnt).

    I posted this question in the "how to" area of the forums, but it's relevant here, how do you find the hotfix intallation history, or find out many hotfixes you have installed? I am not completely sure that I have all the hotfixes listed on this site download section.

    I am at a complete loss!

    When MS says they got Win2003 webserver in LOCKDOWN mode by default, they weren't kidding ! It's almost INERT!
    :D
     
  12. Antony

    Antony Guest

    0
     
    Please check if 'enable anonymous access' is checked out in Directory security tab under the domain properties in IIS.
    Also sometimes there is a protection of \ dir is set in Plesk CP - protected dirs.
    So, if websrvmng --reconfigure-vhost etc did not helped you, then check this two settings.
     
  13. systemfx

    systemfx Guest

    0
     
    Hi Antony,


    As I figured, when our server was built it did not have any hotfixes intalled

    I think that will help. I will post back when I install the hotfixes.

    Should most likely fix the problem as I understand it.

    Cheers!
     
Loading...