1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Adsense doesnt like Tomcat generated URL :9080/<application>

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by flupke, May 5, 2009.

  1. flupke

    flupke Guest

    0
     
    See Adense mail thread below, it doesnt like www.mydomain.com:9080/app

    How can I have the Tomcar application running under www.mydomain.com. I tried the following in vhost:

    ProxyPass / http://www.mydomain.com:9080/java_project_name
    ProxyPassReverse / http://www.mydomain.com:9080/java_project_name

    The web server then enters in a loop (Detected by the browser which stops the request)

    I tried to replaced www.mydomain.com with 127.0.0.1: no luck, even with ajp instead of http.

    It is really imposible, you can I get a Tomcat application running in a 'transparent' mode under the top-level domain?


    Adsense mail thread:

    Unacceptable site content: In order to participate in Google AdSense,
    publishers' websites and application information must satisfy the
    following guidelines:

    *Your website must be your own top-level domain (www.example.com and not
    www.example.com/mysite).
    *Your domain must have been registered and active for at least 6 months
    before you apply for AdSense.
    *You must provide accurate personal information with your application that
    matches the information on your domain registration.
    *Your website must contain substantial, original content.
    *Your site must comply with Google AdSense program policies:
    https://www.google.com/adsense/support/bin/answer.py?hl=en&answer=48182
    which include Google's webmaster quality guidelines:
    http://www.google.com/support/webmasters/bin/answer.py?answer=35769#quality.


    If your site satisfies the above criteria in the future, please resubmit
    your application and we'll review it as soon as possible.
     
  2. flupke

    flupke Guest

    0
     
    I solved it by splitting www. from the main site, www is now a sub-domain, I use mod_rewrite with [P] option (procy) to have clean url www.domain.com
     
Loading...