1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

All Websites disappeared and httpd.include files empty

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by LehmannBrothers, May 21, 2011.

  1. LehmannBrothers

    LehmannBrothers Guest

    0
     
    Hi,

    I have a strange problem. One of my websites expired, and defaulted to the plesk page. I logged into the plesk panel, and extended the date by one year. I re activated the subscription. The site is still dead.

    I noticed in my /conf folder for the site there are files :

    12998313060.68478700_httpd.include (Size 3210)
    and
    13059871000.93721100_httpd.include (Size 317)

    I manually copied the older file with the 3210 size to the new one, and restarted httpd. Site was back up. After the nightly routine tasks this morning I noted there was a new file, size 317 again, with no config directives in it.

    So I searched the forums and it was suggested I run : /usr/local/psa/admin/bin/httpdmng --reconfigure-all

    I Did and no all my websites in plesk has a confige file size of 317, and all sites are dead. It is as if does not take the config from plesk and write the correct config files from it.

    Running plesk 10.2.0 on CentOS 5.5 (Upgraded to 5.6 using yum, before I went from 10.0.1 to 10.2.0

    PLEASE HELP as all my clients are down currently. (They also started reporing mail keeping asking for password.

    Wilhelm
     
  2. LehmannBrothers

    LehmannBrothers Guest

    0
     
    Correction ... There are only 8 out of 74 sites that get the *.*.httpd.include file generated properly.
     
  3. Blake@Parallels

    Blake@Parallels Regular Pleskian

    24
    73%
    Joined:
    Jul 28, 2008
    Messages:
    168
    Likes Received:
    0
    Location:
    Seattle, WA
    Are you using some sort of billing software with your Plesk? Many pieces of billing software have functionality to delete sites (including all content, services, etc.) when a subscription is expired/past-due/etc.
     
  4. LehmannBrothers

    LehmannBrothers Guest

    0
     
    No Billing Software is being used. Not even the Plesk one.
    The sites are thre, so is the old config files. but everytime I manually copy an old file to the new one it only works a short while till plesk creates a new blank one.
     
  5. N3cTr0

    N3cTr0 Guest

    0
     
    I have the same problem just in a different way.
    I decided to update plesk and install horde, I mainly use atmail, but everytime plesk updates I see a mysql error about a horde table, so decided to just install horde so that mysql error message could go away << (That alone is a bug with plesk, if you do a clean install and dont install horde, everytime something updates in plesk you get a mysql horde table missing message"

    So anyway did the update and after that I get this message when trying to start httpd:

    [root@guess bin]# /etc/init.d/httpd start
    Starting httpd: httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error on line 5 of /etc/httpd/conf.d/zz010_psa_httpd.conf: Syntax error on line 447 of /usr/local/psa/admin/conf/generated/13059122020.48673400_server.include: Syntax error on line 5 of /usr/local/psa/admin/conf/vhosts_bootstrap.conf: Could not open configuration file /var/www/vhosts/mydomain.com/conf/13059122030.35434000_httpd.include: Permission denied

    Any suggestions?
     
  6. LehmannBrothers

    LehmannBrothers Guest

    0
     
    Blake @ Parallels ?

    No reply anymore ? Anyone else ? My clients are screaming ....
     
  7. LehmannBrothers

    LehmannBrothers Guest

    0
     
    No thanks to Parallels support. I figured it out on my own.

    My server never had IPV6 support, and after some update it gained it. (as I now have an IPV6 option in hosting settings that I never had) This caused my subscriptions to "lose" their IPV4 ip addresses, and I suspect due to an Plesk update, as it was the only thing I done, between it working and not working.

    I noticed in my subscriptions on a server that I have not updated, Under "Hosting" when you view a subscription, I had IP, System Username and Domains, while this one with the problem (and the latet Plesk updates) there was no IP.

    To fix it I had to click on each subscription, then on click on "Change Hosting Options" select my server's IPV4 Address (it went to none after the update)

    Some domains, however (those that was not linked to a service plan) retained their IP's.

    After this I ran "/usr/local/psa/admin/bin/httpdmng --reconfigure-all" again and all went back to normal.

    Wilhelm Lehmann
     
Loading...