1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Anonymous FTP is not active

Discussion in 'Plesk for Linux - 8.x and Older' started by editor, May 4, 2005.

  1. editor

    editor Guest

    0
     
    Anonymous FTP was (is) not active

    Hi,


    our new PLESK-server 7.5.2 running onto Linux with 1
    IP-number is used for HTTP, MAIL and FTP.

    Logged in to https://domainname.tld:8443 and to
    go direct to our domainname, the icon "Anonymous FTP" is not
    active.

    If I move the mouse over this deactive icon "Anonymous FTP",
    it says here following:

    "Unable to set up Anonymous FTP: shared IP address type."

    If I login by FTP to this one domainname, it shows very
    clear a own folder "anon_ftp", so I think, this is not the
    problem.

    How is it possible to activated this? We have only 1
    IP-number and the PLESK-reseller does not allow us to add
    more IP-numbers.

    Do you think, that there is a way to do anything in the
    SQL-database under the table "psa", so this icon will be
    active then?

    Thank you for any ideas and suggestions. :)
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Go to the Servers, IP addresses area, click on the IP address, change it to Exclusive, then go back to Domains, and the icon should now be active.

    The 'anon_ftp' directory is created by default on all domains. Just because it is there does not mean anonymous ftp is active. The directory will be present in all domains created.
     
  3. editor

    editor Guest

    0
     
    Thank you. Does this mean, that the other 6 domainnames
    will not work anymore?

    Example:

    PLESK 7.5.2 with 1 IP-number has 6 domainnames:

    mydomainname.tld (HTTP, FTP, MAIL and Anonymous-FTP)
    anotherdomainname01.tld (only HTTP, FTP, MAIL)
    anotherdomainname02.tld (only HTTP, FTP, MAIL)
    anotherdomainname03.tld (only HTTP, FTP, MAIL)
    anotherdomainname04.tld (only HTTP, FTP, MAIL)
    anotherdomainname05.tld (only HTTP, FTP, MAIL)

    If I switch the "shared IP-adress to exclusive IP" for
    "mydomainname.tld", then the other domainnames
    would then have a problem, hmm?

    Thank you very much.
     
  4. jshanley

    jshanley Guest

    0
     
    An exclusive IP is one that is "exclusively" for a client. If all those domains belong to one client, then it's not a problem. Shared IPs are IPs that can be assigned to anyone.
     
  5. editor

    editor Guest

    0
     
    Hi Jshanley,

    Ah, thank you very much. I understand. So, if I add a new client with his own domainname, then my anonymous-FTP will not work anymore, correct?

    If this is really so, how can I teach PLESK that this should be ignored? Hmm. I am just looking in the SQL-database under the table "psa".

    Thank you.
     
  6. editor

    editor Guest

    0
     
    So, I was trying it to realize your idea.
    Server --> IP-adresses ---> IP-number ---> change it to exclusive
    [OK]

    Error message, cite:

    "You cannot change IP type, IP address belongs to the pools of
    serveral clients at the same time."

    It is correct, because my brother and my sister have also
    access with their own "client"-account and there are listed
    their domainnames.

    How can I teach this PLESK to ignore this error-message?
    All the domainnames use this one 1 IP-number so or so,
    because the PLESK-reseller does not allow us to add more
    IP-numbers to this PLESK-server.

    How do you think about my trick: I will move all the
    domainnames by the psa-entry in the SQL-database.
    All domainnames will run under my account then. After it,
    I will delete the other "client"-accounts. It seems then so,
    that I am the only one client on this PLESK-server. Then
    I will try to change it again to "exclusive ip-number". And if
    this is ok, then I have an "Anonymous FTP". Correct?

    thank you.
     
  7. jamesyeeoc

    jamesyeeoc Guest

    0
     
    editor,

    As jshanley has already posted:

    Since you have now told us that you do have more than one 'client', then this will not be possible via the Plesk interface.

    If you were to move all the domains to a single client account, and only have one client account, then you could do what I posted.

    Keep in mind that if you do this, anonymous ftp will be turned on for *all* domains, not just one. That is also not a Plesk created problem, just the nature of the beast.

    You need to keep in mind that Virtual domain hosting is not the same as dedicated (or exclusive) IP based hosting. They are quite different. In the old days, it used to be IP based only. Once they created ways to do Virtual hosting, it also created additional flexibility, but also limitations.
     
  8. editor

    editor Guest

    0
     
    Hi jamesyeeoc ,

    Yes, I m just trying to do this.

    Oh, geeez. Hmm, you re right. If you want a clear configuration,
    everything should get an own ip-number.



    Well, some years ago, I had 256 IP-numbers running onto
    PLESK (hmm, version 5 or so, a older Plesk-version). These
    256 IP-numbers were from RIPE.NET, because we were located
    in Europe. With the moving from Europe back to USA, we could
    not move the european RIPE-IPs to USA, because North- and
    South-America has ARIN as the right one station for american
    IP-numbers. So, this is why we had to give back our 256
    IP-numbers to RIPE and we have therefore to "restart" with
    new american IP-numbers from ARIN. To oder new IP-numbers
    from ARIN is not possible, because the PLESK-reseller allows
    us only to have 1 IP-number. I am online since 1989, this
    means for over 16 years. Just for your info about the little
    background here with me.

    BTW: In the meanwhile, I think, I should change the PLESK-reseller.
    Do you have a tip for me? PLESK 7.5.2 Reloaded for max. 100
    domainnames and only 3 IP-numbers would be very fine for me.
    I have heard, that there should something good anywhere in
    Colorado. Hmm?

    Thank you.
     
  9. editor

    editor Guest

    0
     
    Hi,

    so, I moved now all the domainnames to my cl_id.
    The other cl_id do not have a domainname anymore.
    If one of the other cl_id will login, then there will not
    appear any domainname anymore, because all
    domainnames are run now only under my cl_id.

    And it does not work. Cite:

    "You cannot change IP type, IP address belongs to the pools
    of serveral clients at the same time."

    I think, I will delete the other cl_id, so I am really the
    only one cl_id with all the domainnames. I hope, that
    this will work now.
     
  10. editor

    editor Guest

    0
     
    > "You cannot change IP type, IP address belongs to the pools
    > of serveral clients at the same time."
    >
    > I think, I will delete the other cl_id, so I am really the
    > only one cl_id with all the domainnames. I hope, that
    > this will work now.

    I really deleted all the other clients with their own cl_id.
    Then I tried it again with

    Server --> IP-adresses ---> IP-number ---> change it to exclusive
    [OK]

    The 1 IP-number is now "exclusive type IP adress". I test
    now if I can call the URL of each domainname. For the
    visitor, nothing happened. They will get the same website
    like it was before.

    Now I have a look again to mydomainname.tld to see,
    if the icon "Anonymous FTP" is still deactived by Plesk.
    And it is not deacitive anymore. It is active now! Fine.

    I can setup now "Anonymous FTP" for mydomainname.tld.
    And I do this now, of course. I am logged in as
    "myclientid-account" instead of the Plesk-Admin. And what do
    I see?

    me > mydomainname.tld >
    Anonymous FTP account for the domain mydomainname.tld

    All is deactive, oh no. The icon "Anonymous FTP" was active,
    but to be able to surf to there does not help me as the
    "myclientid-account". I log out now.

    I relogin to Plesk, but not with "myclientid-account", I use
    now my Plesk-root-Account to login onto https://www.mydomainname.tld:8443
    and I go again to mydomainname.tld to the icon "Anonymous FTP".

    Now it seems so, that I can really setup anything there for
    having an "Anonymous FTP"-server. And I do this, of course.

    Domains > mydomainname.tld >
    Anonymous FTP account for the domain mydomainname.tld

    [enable]-button has the status, that it is disabled.

    I fill out and mark all the things there.

    [X] Display welcome message (a must says RFC)
    Welcome to the public FTP of mydomainname.tld

    [_] incoming, etc.. no, thank you

    Limit of sim. connections: [100]
    Limit of download bandwith: empty / unlimited

    I think, I am finished. I click on [OK]
    (I know, it is still enabled, which I will do in the next step)

    Back to "Anonymous FTP", I click on "enable" this service.
    Sucessfully done. It is active. Let me look know what will
    happen if I call ftp://ftp.mydomainname.tld and if it will
    really work. Wonderful! It works.

    Current directory is /
    Welcome to the public FTP of mydomainname!

    conf/ Thu May 05 19:29:00 2005 Directory
    incoming/ Wed Apr 13 16:01:00 2005 Directory
    pub/ Wed May 04 20:25:00 2005 Directory

    Looks good, doesn't it? ;-)

    /conf/ and /incoming/ does not allow a user to upload anything.
    Thats exact this what I setuped before. Now let me look to the
    /pub/. Ok, I can download my test.zip and it works fine.

    So, thank you all here for your suggestion, impulse. :)

    :D
     
  11. editor

    editor Guest

    0
     
    Ooops, there is something wrong with the Anonymous FTP.

    ftp://ftp.mydomainname.tld/pub
    shows there my test.zip-File.

    ftp://ftp.theotherdomainname.tld/pub/
    shows there also my test.zip-File.

    I open my ftp-client, use the login-datas not of
    "mydomainname.tld", I use the login-datas for FTP
    of the "theotherdomainname.tld". And I go by FTP
    to the folder

    /anon-ftp/

    This folder is total empty. I cannot see the "test.zip"-file.
    I upload a "testpic.jpg" to /anon-ftp" and then I call
    ftp://ftp.theotherdomainname.tld/ and I cannot see it.

    I don't think, that this Plesk-configuration is conform with RFC
    ftp://ftp.ripe.net/rfc/ because it seems so, that all the domainnames
    will automatically get the files of "Anonymous FTP".

    Any comments? Hmm...
     
Loading...