1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Apache died out of the blue

Discussion in 'Plesk for Linux - 8.x and Older' started by acidbox, Sep 6, 2005.

  1. acidbox

    acidbox Guest

    0
     
    Out of the blue I got this error today. Server has been up and running for a week with no issues until now.

    /etc/resolv.conf shows the following (hosting at EV1Servers):

    I was able to bring Apache back by adding nameserver xx.xx.xx.xx (my IP) to the resolv.conf file, but when I do that my FTP server dies. I have no clue what's going on.

    Not sure what's going on here, but it was working fine yeserday. Where can I check for issues?
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Question 1: You are not using a Windows editor to edit the files are you?
    - Windows based editors will put CR LF at the end of lines, Linux only wants LF.
    - If you have edited files using a Win Editor, you can use the 'dos2unix' utility to strip the CR's from the file.
    - Linux editors: nano, pico, vi, emacs

    Question 2: Have you check to see if you've been hacked or rooted?
    - install and run RKHunter and Chrootkit
    - check the contents of /tmp for any strange files (if you need to, email me a listing of the files to jamesyeeoc at y a h o o dot c o m)

    Question 3: Did you add your 'nameserver xx.xx.xx.xx (your IP) after your ISP's, not before them, right? I also put 'nameserver 127.0.0.1' at the bottom line of resolv.conf.

    Question 4: Have you changed your root password and Plesk admin password lately, if not, you may want to do that.

    Question 5: "with no issues until now", so that does not include the SMTP/Port block or SMTP delay issues? LOL

    Are you sure that in trying to resolve the SMTP issue(s), that you did not inadvertently edit resolv.conf? Just asking...
     
  3. acidbox

    acidbox Guest

    0
     
    1.) I'm editing the file directly in Pico via SSH

    2.) I'm trying to run RKHunter now, but I can't even get the files to the server and I can't even connect to the server via FTP. It connects and then after it issues the LIST response to get a dirlist, I get an error that says "Error Reading Response From Server". Then the connection dies.

    I tried to do a wget to get rkhunter and I get this message:

    I tried two other downloads sites, same thing. Then I tried adding the domain name in the hosts file to force it to look in the right spot and it just sits there saying connecting forever until I break out. Like this:

    So now, I'm not sure how to get files transfered to my box anymore. Something is seriously wrong.

    3/) I added it below the first two dns entries. I just now added 127.0.0.1 as well. No change.

    4.) I just changed it again a couple minutes ago to be safe.

    5.)LOL. I know, right. I got all sorts of issues.

    Also, Here are the logs when I try to connect via FTP, I am not sure if the server is trying to resolve my host or something and just cannot find it, but I cannot connect:

    It just keeps doing this over and over again until my FTP client gives up.

    Just a side note, from reading other posts, I should have not used the Plesk firewall module either. I used to run APF on ensim with no issues, I think I might switch back to that if I can get these issues sorted out. That Plesk Firewall, while it looks nice, may not work correctly.

    Need to get this fixed up asap though, so any help is appreciated.
     
  4. acidbox

    acidbox Guest

    0
     
    Somewhat embarrassing, but I fixed it. Apparantly when I was editing the firewall to allow for a secondary SMTP server through, I must have DISABLED all other outgoing connections, which in effect shut down my server. lol.

    Thanks for the help James, you were a big one!
     
Loading...