1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

awstats not working after plesk restore

Discussion in 'Plesk for Windows - 8.x and Older' started by bob2, Feb 27, 2006.

  1. bob2

    bob2 Guest

    0
     
    I had a hardware failure on one of our plesk servers. I was able to use a backup that was created before the problems started. But now when the plesk statistics run it gives the following error message.

    Error 2 at Open file 'C:\Program Files\SWsoft\Plesk\Additional\AWStats\wwwroot\cgi-bin\awstats.model.conf': The system cannot find the file specified.


    I had tried to disable stats for all the sites that were using webstats and then re-enabling stats for those sites but the same error message comes up. Any ideas anyone.
     
  2. bob2

    bob2 Guest

    0
     
    Ok I have made a little progress with my problem. I have another plesk windows server running the exact setup. I have copied the following folders and files from the c:\program files\swsoft\plesk\additional\awstats\wwwroot\cgi-bin\ directory

    Folders
    >>lang
    >>lib
    >>plugins

    Files
    >>awredir.pl
    >>awstats.conf
    >>awstats.model.conf
    >>awstats.pl

    The issue now is that when the files are copied over and I run the statistices.exe the statistics are compiled correctly. But if I run the statistics.exe within a few minutes again it returns the following error message about the webstat folder for a random domain name

    Run-Time error: Error 183 at Create the directory 'C:\inetpub\vhosts\domain name\statistics\webstat\AWStats': Cannot create a file when that file already exists.

    any ideas anyone??
    any help would be greatly appreciated.
     
  3. bob2

    bob2 Guest

    0
     
    OK I have gotten the problem fixed if anyone has this problem. My server was running version 7.5.3. The config files for awstats would disappear when the statistics.exe was run and if I tried to run it a second time it would complain that the file was not there. I remembered that the statistics.exe was updated for a problem with webstats that many people were having that were running version 7.5.3. I re-installed the updated statistics.exe and corresponding config files and this fixed the problem.
     
Loading...