1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

BSD 6.1 : Apache crashes on adding SSL cert

Discussion in 'Plesk for Linux - 8.x and Older' started by syntax, Jan 2, 2007.

  1. syntax

    syntax Guest

    0
     
    I've FreeBSD 6.1 with PSA 8.0.1

    Everything was working smoothly until I tried to add an SSL cert . As soon as I add a custom cert through control panel, the apache server stops working.

    Error log says :

    Code:
    [Tue Jan 02 19:57:57 2007] [warn] RSA server 
    certificate CommonName (CN) `plesk' does NOT match server 
    name!? [Tue Jan 02 19:57:57 2007] [warn] RSA server 
    certificate CommonName (CN) `plesk' does NOT match server 
    name!? [Tue Jan 02 19:57:57 2007] [warn] RSA server 
    certificate CommonName (CN) `plesk' does NOT match server 
    name!? [Tue Jan 02 19:57:57 2007] [warn] RSA server 
    certificate CommonName (CN) `plesk' does NOT match server 
    name!?
    and nothing more

    strace of httpd start ends as

    Code:
    42380 getpid()                          = 42380 (ppid 42377) 
    42380 gettimeofday({3811757175, 3500885170}, NULL) = 0 42380 write(14, "\211\r\227\35s\322x\247\331@=0\335\334\374L\364W\251s\364"..., 78) = 78 
    42380 getpid()                          = 42380 (ppid 42377) 
    42380 gettimeofday({1165251822, 1790872133}, NULL) = 0 42380 write(14, "\307\376a\357\1776\202\277\276t\216\200\2\251\322\270T"..., 148) = 148 
    42380 getpid()                          = 42380 (ppid 42377) 
    42380 exit(1)                           = ? 
    42377 <... wait4 resumed> [WIFSIGNALED(s) && WTERMSIG(s) == SIGBUS], WUNTRACED, NULL) = 42380 
    42377 exit(1)                           = ?
    soon after it reads all the certs into memory.

    To enable apache again, I'm forced to delete the SSL cert that I just added . HTTPS works with the default plesk certificate . Even a self signed cert will crash it again.

    Any help or clue would be appreciated.
     
Loading...