1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Bug in subdomain.sh

Discussion in 'Plesk for Linux - 8.x and Older' started by ashopandreas, Nov 8, 2007.

  1. ashopandreas

    ashopandreas Guest

    0
     
    The --hard-quota parameter for the subdomain.sh Plesk API script doesn't work in 8.2.1. No matter what you set it to you always sets the quota to unlimited.
     
  2. anb_t

    anb_t Guest

    0
     
    Plesk CLI subdomain sets user quota according to system block size. If one specifies kilobytes value of hard_quota less then 1024, Plesk CLI sets hard quota to 0 (unlimited).
    Also pay attention to hard quota type specification:

    ~# /usr/local/psa/bin/subdomain --help | grep -A 3 -- -hard_quota
    -hard_quota <number>[K|M|G] hard disk quota (use 0 for
    "unlimited", which is set by default.
    You can specify this option when using
    a separate FTP account)
    ~#

    If you fail attend specification of the hard quota type, subdomain considers it to be in 'K', i.e. kilobytes.

    ./anb
     
  3. ashopandreas

    ashopandreas Guest

    0
     
    Thank you for your help! I had missed the new K|M|G part of the parameter. It works just fine with those.
     
Loading...