1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can connect via FTP but not send anything

Discussion in 'Plesk for Windows - 8.x and Older' started by patrick24601, Dec 14, 2004.

  1. patrick24601

    patrick24601 Guest

    0
     
    I'd like some suggestions or some other reference on what my problem may be.

    I have a new Plesk 7 Windows install. I have a domain setup, nameservers setup, and physical hosting setup. When I go to the domain in the browser I can see I am hitting my server (No site error from plesk).

    1. I can also connect via FTP. WHen I do I do not see anything. Am I supposed to ?

    2. WHen I try to upload a file or create a directory I get the '550 Access Denied Error Message"

    .... and yes I am using passive FTP.

    I'll look in the manual again but I gone over it several times. I set up the user, the domain, and physical hosting for the user. I am using the same userid and password that I filled in the Frontpage.FTP fields. And still no dice.

    ANy help is appreciated.
     
  2. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    this has happened to me once when making a subdomain, the directory was empty..

    it seems like plesk has not setup your domain right. You should see lots of directories when logging in with ftp

    what you can do:

    1. delete the domain and recreate it

    if that doesn't work:

    look in the file structure, is your vhost directory created alright with the correct subfolder structure like: httpdocs, subdomains, errorpages, cgi-bin etc...

    if they are, do they have the right permissions set for your user

    If yes, is the ftp directory (under vhost/servers) created for your domain

    If yes, does that have the right permissions

    check the IIS, is the ftp site setup there.. if not, plesk reconfigurator might help, maybe your IPs aren't setup right...
     
  3. patrick24601

    patrick24601 Guest

    0
     
    Thanks for the info.

    In IIS and in Windows all directories exists. I am not sure what permissions I should be checking.

    What is this reconfigurator your are talking about - I don't see it in Windows.
     
  4. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    your ftp user should have full control over the directory.

    the reconfigurator, if not available from the menu, resides in plesk/admin/bin and is called reconfigurator.exe
     
  5. patrick24601

    patrick24601 Guest

    0
     
    It looks like the reconfigurator only allows you to control IP addresses and virtual hosts directory. That all looked good.

    I also looked on the permissions of the directory with the domain in it. ( c:\inetpub\vhosts\domainname ). It looks like the userid I create in Plesk has full control of that directory.
     
  6. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    it doesnt really show what it does, but when it repairs an ip it sets the replication between the www site and the ftp site. these are two different directories.

    if you have both the directories all correct and all permisions set, then I really don't know whats wrong. you could try to create a directory that is there and see what it says (I did this in the subdomain case and suddenly all the directories appeared)

    also what ftp client are you using? have you tried other clients? try connecting with the commando prompt so that you see all output, try also explorer and ws_ftp..
     
Loading...