1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Cannot add tony to Mail

Discussion in 'Plesk for Linux - 8.x and Older' started by Gorgon@, May 20, 2005.

  1. Gorgon@

    Gorgon@ Guest

    0
     
    Hi folks,

    Here is a very strange problem and I'm wondering if anyone else has encountered it. We're running v7.5.3.

    A user was trying to add a mailbox called 'tony'. He kept getting an error about the password, even though it was a good password. We then tried about 10 different passwords and it didn't like any of them. We then tried adding the mailbox 'tony' to 3 other domains with the same tests it had the same problem. I have another user who already has a mailbox named tony, but I know it's not a 'duplicate' problem because we have several users with the mailbox called 'mike', for example.

    For whatever reason, plesk doesn't like 'tony'. Has anyone seen similar behavior for this or other mailbox names?

    Thanks,
    mikeS
     
  2. Gorgon@

    Gorgon@ Guest

    0
     
    Hmmm, having the same problem with 'info' too. We have dozens of domains using that as an email box. I cannot find this being logged anywhere either, but I didn't expect it to log really since the error seems to be javascript. Any ideas on where to look next are appreciated.

    Thanks,
    mikeS
     
  3. editor

    editor Guest

    0
     
    the plesk-mailsystem works by this "strategy":

    [dom_ID]-[mailalias]@domainname.tld
    or
    [dom_ID]-[pop3name]@domainname.tld

    So, f.e., if the domainname.tld has the domain-ID number 18,
    then it is:

    18-[mailalias]@domainname18.tld
    or
    18-[pop3name]@domainname18.tld

    dom_id cooperates with mn_id and this is why it should not
    be a problem to have many "info"-mailaliases or
    "info"-pop3mailboxes for each own domainname, f.e.

    info@domainname01.tld
    info@domainname02.tld
    info@domainname03.tld
    etc.

    Before you will be able to setup a pop3mailbox, the
    "intelligent" Plesk-System will also try to check out the
    name of the mailalias/pop3mailbox with the password.
    It is not allowed to have the same word/name of a pop3mailbox
    within the password, because the name of the pop3mailbox
    is also the username to login by SMPT/POP3.

    To specify your problem, I think, the word "tony" was also used
    anywhere as a password and this is why you got the error.
    Just try another password. The word "tony" should not exist
    within the password, if you have anywhere a "tony" as
    pop3mailbox-name.

    And if you have

    tony@domainname01.tld
    tony@domainname02.tld
    tony@domainname03.tld

    you should better use 1 pop3mailbox and 3 mailaliases which
    will forward the mail to the correct one pop3mailbox.

    If you still have any problems, then you should let us know the
    complete error-message.
     
  4. Gorgon@

    Gorgon@ Guest

    0
     
    Hi Editor,

    I'm not sure if I completely understand the plesk 'strategy' you describe. But, I don't think that's the problem either.

    I have tried many different passwords, most of them randomly generated and none work. The exact error message I get is thus:

    ---------------------------------------------------
    [JavaScript Application]

    Unable to update the mail name properties:

    The password is incorrect, use at least 5 characters. The password should not contain mail name as its part.

    Only Latin characters, no dictionary words (optional).
    ---------------------------------------------------

    Now in this particular run, I used this randomly generated password:

    priaspo3

    Now there is 1 other 'tony' on the system (for a different domain). As an experiment, I tried adding a mailbox for 'mike'. There are currently 6 other mikes on the system in 6 different domains. I am able to successfully add mike with no problem.

    It looks to me like plesk is getting confused somehow. Could this be a corrupted or bad entry in the plesk database as the cause?

    Again, thanks for your response.

    M
     
  5. ron685

    ron685 Guest

    0
     
    I had the same problem. I remember changing IP address on the interface eth0 to share from exclusive.
     
  6. Gorgon@

    Gorgon@ Guest

    0
     
    Hmm, thanks for the reply ron685, but I don't think that's it. The sites are already using the main shared IP.

    I have plesk support looking at this situation. This could be a configuration issue, a corruption issue or a bug (IMHO). Hopefully sw-soft will be able to figure it out.

    thanks,
    mikeS
     
  7. Gorgon@

    Gorgon@ Guest

    0
     
    FYI, this problem was solved by changing from 'short' POP/IMAP names to 'long' POP/IMAP names.

    I guess this 'feature' will be fixed in the next release as this used to work okay before the latest rev.

    Apparently the problem was introduced in how Plesk checks to see if a password is being used. Since plesk cannot check the password of an existing user, the check fails so you cannot add the user.

    M
     
  8. editor

    editor Guest

    0
     
    Thank you very much for your report.

    btw: where exaclty did you change from 'short' POP/IMAP names to 'long' POP/IMAP ?
     
  9. Gorgon@

    Gorgon@ Guest

    0
     
    From the Server view, click on the Mail icon. Down at the bottom is the section:

    Names for POP3/IMAP mail accounts

    Check the appropriate radio button. :)

    M
     
  10. Laurence@

    Laurence@ Basic Pleskian

    26
     
    Joined:
    Nov 25, 2001
    Messages:
    73
    Likes Received:
    0
    We just ran into a similar problem. We couldn't add a name with a . in it (name.surname). We solved it by switching the domain to an exclusive IP but that isn't a very good solution on a normal shared server and luckily this instance was on a dedicated servfer (our own).
     
  11. ryanjbonnell

    ryanjbonnell Guest

    0
     
    Cannot change password for mailbox

    We're having the same problems with the user "connie".
     
  12. Mirco@

    Mirco@ Basic Pleskian

    24
    53%
    Joined:
    Aug 1, 2001
    Messages:
    43
    Likes Received:
    0
    Have you guys possibly migrated to Plesk from another control panel?
     
  13. PaulusMagnus

    PaulusMagnus Guest

    0
     
    Just had a similar problem trying to create mail names 'paul.lastname' and can't do it. It's because my first name is too short it seems, even though I could do this prior to v7.5.4.

    However, I can create a mail account as long as I don't put in a password. Haven't found a fix yet but will check out the radio button mentioned above to see if that helps.

    *EDIT*

    Yup, that radio button worked. I can create my own 'firstname.lastname' accounts again. :)
     
Loading...