1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Cannot install Plesk 7.5.3 on Debian

Discussion in 'Plesk for Linux - 8.x and Older' started by Peter2, May 9, 2005.

  1. Peter2

    Peter2 New Pleskian

    22
    73%
    Joined:
    May 9, 2005
    Messages:
    21
    Likes Received:
    0
    Hi,
    I test the brand new 7.5.3 and I cannot install it on 3 Debian-Servers.

    On one of the 3 servers I get always the same error:
    Installation type
    ===============================================================================

    Here you can select additional optional components:

    1. [*] Plesk Professional Web Site Editor
    2. [*] Apache mod_python module
    3. [*] Backup utilities
    4. [*] Plesk Counter-Strike game server module
    5. [*] Frontpage 2002 support
    6. [*] Plesk Firewall module
    7. [*] Dr. Web antivirus
    8. [*] Plesk migration manager
    9. [*] Plesk API [former Plesk Agent]
    10. [*] Plesk VPN module
    11. [*] SPAM blocker for QMail daemon
    12. [*] Plesk Fileserver module and SMB file server package
    13. [*] Additional Horde (webmail) components for Plesk
    14. [*] Application vault packages
    15. [*] SSHTerm - SSH Terminal java applet
    16. [=] Mailman mailing list manager support (already installed)
    17. [*] Additional Plesk manuals
    18. [=] PosgreSQL server support (already installed)
    19. [*] ASP support
    20. [*] SpamAssassin support
    21. [*] Tomcat Java Servlets support
    22. [*] ColdFusion support for Plesk

    1) Next page; 2) Previous page; 0) Cancel installing
    3) Toggle component; 4) Select all; 5) Unselect all;
    Select action [1]:
    Hit http://security.debian.org testing/updates/main Packages
    Hit http://security.debian.org testing/updates/main Release
    Get:1 http://autoinstall.plesk.com PSA_7.5.3/ Packages [9878B]
    Ign http://autoinstall.plesk.com PSA_7.5.3/ Release
    Hit ftp://munin.net.web4.hm unstable/main Packages
    Hit ftp://munin.net.web4.hm unstable/main Release
    Hit ftp://munin.net.web4.hm unstable/non-free Packages
    Hit ftp://munin.net.web4.hm unstable/non-free Release
    Hit ftp://munin.net.web4.hm unstable/contrib Packages
    Hit ftp://munin.net.web4.hm unstable/contrib Release
    Hit ftp://munin.net.web4.hm unstable/main Sources
    Hit ftp://munin.net.web4.hm unstable/main Release
    Hit ftp://munin.net.web4.hm unstable/non-free Sources
    Hit ftp://munin.net.web4.hm unstable/non-free Release
    Hit ftp://munin.net.web4.hm unstable/contrib Sources
    Hit ftp://munin.net.web4.hm unstable/contrib Release
    Hit ftp://munin.net.web4.hm unstable/non-US/main Packages
    Hit ftp://munin.net.web4.hm unstable/non-US/main Release
    Hit ftp://munin.net.web4.hm unstable/non-US/contrib Packages
    Hit ftp://munin.net.web4.hm unstable/non-US/contrib Release
    Hit ftp://munin.net.web4.hm unstable/non-US/non-free Packages
    Hit ftp://munin.net.web4.hm unstable/non-US/non-free Release
    Hit ftp://munin.net.web4.hm unstable/non-US/main Sources
    Hit ftp://munin.net.web4.hm unstable/non-US/main Release
    Hit ftp://munin.net.web4.hm unstable/non-US/contrib Sources
    Hit ftp://munin.net.web4.hm unstable/non-US/contrib Release
    Hit ftp://munin.net.web4.hm unstable/non-US/non-free Sources
    Hit ftp://munin.net.web4.hm unstable/non-US/non-free Release
    Fetched 9878B in 3s (2578B/s)
    Reading Package Lists...
    Reading Package Lists...
    Building Dependency Tree...
    j2sdk1.4 is already the newest version.
    j2re1.4 is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    psa-api-rpc: Depends: psa-api-common (=
    7.5.3-debian3.1.build75050509.09) but 7.5.3-debian3.1.build75050506.13
    is to be installed
    E: Broken packages
    Hit ftp://munin.net.web4.hm unstable/main Packages
    Hit http://security.debian.org testing/updates/main Packages
    Hit http://security.debian.org testing/updates/main Release
    Hit ftp://munin.net.web4.hm unstable/main Release
    Hit ftp://munin.net.web4.hm unstable/non-free Packages
    Hit ftp://munin.net.web4.hm unstable/non-free Release
    Hit ftp://munin.net.web4.hm unstable/contrib Packages
    Hit ftp://munin.net.web4.hm unstable/contrib Release
    Hit ftp://munin.net.web4.hm unstable/main Sources
    Hit ftp://munin.net.web4.hm unstable/main Release
    Hit ftp://munin.net.web4.hm unstable/non-free Sources
    Hit ftp://munin.net.web4.hm unstable/non-free Release
    Hit ftp://munin.net.web4.hm unstable/contrib Sources
    Hit ftp://munin.net.web4.hm unstable/contrib Release
    Hit ftp://munin.net.web4.hm unstable/non-US/main Packages
    Hit ftp://munin.net.web4.hm unstable/non-US/main Release
    Hit ftp://munin.net.web4.hm unstable/non-US/contrib Packages
    Hit ftp://munin.net.web4.hm unstable/non-US/contrib Release
    Hit ftp://munin.net.web4.hm unstable/non-US/non-free Packages
    Hit ftp://munin.net.web4.hm unstable/non-US/non-free Release
    Hit ftp://munin.net.web4.hm unstable/non-US/main Sources
    Hit ftp://munin.net.web4.hm unstable/non-US/main Release
    Hit ftp://munin.net.web4.hm unstable/non-US/contrib Sources
    Hit ftp://munin.net.web4.hm unstable/non-US/contrib Release
    Hit ftp://munin.net.web4.hm unstable/non-US/non-free Sources
    Hit ftp://munin.net.web4.hm unstable/non-US/non-free Release
    Reading Package Lists...

    Autoinstaller work completed.

    You can refer to file
    /tmp/psa_installer_v2.0.0_build75050509.20_os_Debian_3.1_i686.log
    where autoinstaller has logged its actions.

    Can anybody help me?

    Viele Gruesse,
    Peter
     
  2. blueice

    blueice Guest

    0
     
    I have the same problem.
    I hope it is needed a fix in the installer.
     
  3. robca

    robca Guest

    0
     
    /tmp/psa_installer_v2.0.0_build75050509.20_os_Debian_3.1_i686.log

    what is in there?

    and it says it has dependencies problems....

    The following packages have unmet dependencies:
    psa-api-rpc: Depends: psa-api-common (=
    7.5.3-debian3.1.build75050509.09) but 7.5.3-debian3.1.build75050506.13
    is to be installed
    E: Broken packages

    on the other hand weird it says autoinstaller completed...
     
  4. Peter2

    Peter2 New Pleskian

    22
    73%
    Joined:
    May 9, 2005
    Messages:
    21
    Likes Received:
    0
    And what shell we do now?

    Plesk 7.5.3 is not install-able on Debian.

    Does any sw-soft technical really test it before?
    I cannot believe it?

    Why can nobody install it?
    Or does we do all something wrong?

    I do not know....
    :confused:
     
  5. tijn

    tijn Guest

    0
     
    API

    Just do not install the Plesk API and the install will go fine. I hope they do fix this within the updater, so the API will work later. You don't need the API if you don't use expand or another plesk product i forgot.

    :(
     
  6. Peter2

    Peter2 New Pleskian

    22
    73%
    Joined:
    May 9, 2005
    Messages:
    21
    Likes Received:
    0
    Re: API

    Hmmm, why I think that SW-Soft use all clients as BETA-testers?

    We only take a debian and click on install and the autoinstaller doesnt work.

    On x Servers on x diffrent clients?

    What game plays Sw-Soft?

    I love Plesk,
    but I think really that the Releases should be better tested.....
     
  7. Peter2

    Peter2 New Pleskian

    22
    73%
    Joined:
    May 9, 2005
    Messages:
    21
    Likes Received:
    0
    I test it,
    but it stops now here:

    Code:
    cat /tmp/psa_7.5.3_Debian_3.1_build75050506.13_installing.log
     Trying to define super-server internet daemon type...
    ERROR while trying to define super-server internet daemon type
    
    Aborting...
    
     Trying to define super-server internet daemon type...
    ERROR while trying to define super-server internet daemon type
    
    Aborting...
    
     Trying to define super-server internet daemon type...
    ERROR while trying to define super-server internet daemon type
    
    Aborting...
    
     Trying to set up default qmail permissions... done
    
    ===> Installing Qmail server
     Trying to set maillog file to /opt/psa/var/log/maillog... done
     Configuring Qmail...
     Trying to define super-server internet daemon type...
    ERROR while trying to define super-server internet daemon type
    
    Aborting...
    
     Checking that /bin/false registered as login shell...
    /bin/false
     /bin/false is already registered as login shell
    
     Checking for ftp home directory for 'clients' group...
     Trying to add '@psacln' to /etc/ftpchroot... done
    
     Trying to set up default qmail permissions... done
    
    ===> Installing Qmail server
     Trying to set maillog file to /opt/psa/var/log/maillog... done
     Configuring Qmail...
     Trying to define super-server internet daemon type...
    ERROR while trying to define super-server internet daemon type
    
    Aborting...
    
     Trying to set up default qmail permissions... done
    
    ===> Installing Qmail server
     Trying to set maillog file to /opt/psa/var/log/maillog... done
     Configuring Qmail...
     Trying to define super-server internet daemon type...
    ERROR while trying to define super-server internet daemon type
    
    Aborting...
    
     Trying to set up default qmail permissions... done
    
    ===> Installing Qmail server
     Trying to set maillog file to /opt/psa/var/log/maillog... done
     Configuring Qmail...
     Trying to define super-server internet daemon type...
    ERROR while trying to define super-server internet daemon type
    
    Aborting...
    
     Trying to set up default qmail permissions... done
    
    ===> Installing Qmail server
     Trying to set maillog file to /opt/psa/var/log/maillog... done
     Configuring Qmail...
     Trying to define super-server internet daemon type...
    ERROR while trying to define super-server internet daemon type
    
    Aborting...
    ;(

    Why I think that no one have really test it before on Debian?
     
  8. jinxedworld

    jinxedworld Guest

    0
     
    Hi,

    I just installed PSA 7.5.3 on Debian Sarge without much trouble. I did the following:

    1. Download the first ISO of the full CD-set from cdimage.debian.org (take it from the testing-branche)
    2. Install it as default
    3. I used the protocol FTP and source ftp.debian.org for APT.
    4. When you have to select what you want to use your server for, don't select anything (not even "Select Packages Manually")
    5. Configure the base system as usual
    6. Login as root, and execute "apt-get install libcurl3"
    7. Download the psa autoinstaller with wget, chmod it to +x, and execute.

    That gave me a nicely working PSA 7.5.3 with Debian Sarge.

    There are a few functions that are not working, though they are supported by my license key
    * SpamAssassin
    * PostgreSQL
    * Migration Manager
    * Mailman

    They're all greyed out in the server settings screen, even though they are installed. I'd like to see some suggestions from SW-Soft for that.

    *** Edit ***
    Ok, i found some more issues. Bind9 doesn't seem to be doing anything. That's what I call a major issue. I'll see what I can do, and i'll report this to the techs. When i have more info i'll post it here.
     
  9. blueice

    blueice Guest

    0
     
    today i have receive a email from the plesk support team and inform me that the installer is fixed.
    I have begin the install but i have problems with tomcat. i have remove this option and the install is completed.
    I checkit in the next days and i post my comments.
    It is good that the release team have fix within a day the installer.
    Regards,
    Christos Pelekis
     
  10. jinxedworld

    jinxedworld Guest

    0
     
    Could you check if bind9 is running on your Debian system? I'm having a bunch of problems with the DNS setup... :confused:
     
  11. blueice

    blueice Guest

    0
     
    srv1:~# ps aux | grep bind
    bind 2500 0.0 0.2 29384 2520 ? Ss 15:58 0:00 /usr/sbin/named -t /var/named/run-root -c /etc/named.conf -u bind
    bind 3052 0.0 0.2 29320 2532 ? Ss 16:01 0:00 /usr/sbin/named -t /var/named/run-root -c /etc/named.conf -u bind
    root 3599 0.0 0.0 1832 544 pts/0 D+ 16:10 0:00 grep bind
    srv1:~#
     
  12. blueice

    blueice Guest

    0
     
    i have make a apt-get install webmin and together with webmin it is finished the install of spamassassin postgresql and many other debs.
    So try this and may resolve your problem.
    Regards,
    Christos
     
  13. Peter2

    Peter2 New Pleskian

    22
    73%
    Joined:
    May 9, 2005
    Messages:
    21
    Likes Received:
    0
    Dito.
    bind works at me, too.

    I install a debian from scratch too and deselected psa-api-common.

    But anyway, why I think that SW-Soft uses us as Crashtestdummys?
     
  14. hardweb

    hardweb Guest

    0
     
    Install directly the packages and everything would be much easier :) You do not need the installer.
     
  15. death

    death Guest

    0
     
    I managed to install Plesk 7.5.3 on Debian sarge yesterday. Notice that i ran into some troubles. If I did a dpkg -i *.deb in the base directory, it didnt install correctly. There where some failed depencies on ntpdate. As a further step I had to remove mailx and at as they somehow conflicted with psa-qmail.

    Furthermore it is a little bit tricky to uninstall the Plesk Package psa-imp once the installation of psa failed upon depencies problems. Because the post rm Script of psa-imp searches for an admin passwort in /etc/psa/psa.conf and tries to connect to the psa database (neither file or db exist at the moment of the failed installation), the package psa-imp isn't removeable with dpkg -r psa-imp.

    I had to modify /var/lib/dpkg/info/psa-imp.postrm to fix that problem (just deletet all the code checking for password and db).

    But finally I managed to install Plesk on Debian. I just love Debian (and Plesk o'course) :)
     
  16. jinxedworld

    jinxedworld Guest

    0
     
    You know what's funny? I've got spamassassin and psa-spamassassin running on my system, but in Plesk -> Service Management it says "Not Installed". Same goes for PostgreSQL and Dr. Web. My key supports all of them though.
     
  17. death

    death Guest

    0
     
    Same here

    Tomcat
    PostgreSQL
    SpamAssassin
    Dr.Web antivirus

    Doesnt seem to work under Debian.

    @jinxedworld: Did you manage to fix this yet?

    Kind Regards from the Alps ;)
     
  18. jinxedworld

    jinxedworld Guest

    0
     
    @Death

    Nopes, haven't been able to fix this yet...
    I created a supportticket so that SW-soft can give us some assistance :) Any resolution they find, I will post here.
     
  19. death

    death Guest

    0
     
    @jinxedworld: Fixed it ;) I guess you want to know how ;) Well it was not tricky:

    Just login the Control Panel, then go to Server -> Component Info

    There you should press "Refresh". Now all the Services should be available.
     
  20. jinxedworld

    jinxedworld Guest

    0
     
    Ehmm, that was just too easy?? Thx death!
    Guess i won't need SW-soft for this i guess... :)
     
Loading...