1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't remove joomla(application) after manually deleting httpdocs contents

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by mr_panels, May 11, 2012.

  1. mr_panels

    mr_panels Guest

    0
     
    Hi,

    I wanted to remove joomla and reinstall and so manually deleted the contents of httpdocs, forgetting of course that plesk has a feature to remove installed applications.

    Now when I try and remove the application using plesk it says its successful but the entry under managed installed applications is still there.

    I tried to reinstall joomla in the same location but plesk doesn't allow me to either saying that there is overlap because there is already an installed application at the same location.

    How can I remove joomla successfully? I have also tried removing the database but plesk won't let me do that either.
     
  2. OurAce.com

    OurAce.com New Pleskian

    10
     
    Joined:
    Jun 11, 2012
    Messages:
    2
    Likes Received:
    0
    First log in to Plesk then check which domain the application is installed under.
    Go to "Websites & Domains" and hover over the domain.
    You should see something like https://localhost:8443/smb/web/settings/id/555
    We want the Last number: 555

    now you will need to login to the psa database:
    cmd cd "path to your admin mysql\bin directory"
    mysql --port=8306 -uroot -pThepassword

    mysql> use psa;
    mysql> select id from apsresources where pleskID=555;
    +------+
    | id |
    +------+
    | 101 |
    | 102 |
    +------+

    mysql> delete from apsresourcesparameters where apsResourceId = 101;
    Query OK, 2 rows affected (0.02 sec)

    mysql> delete from apsresourcesparameters where apsResourceId = 102;
    Query OK, 10 rows affected (0.00 sec)


    mysql> delete from apsresources where pleskID=555;
    Query OK, 2 rows affected (0.02 sec)

    You should be good to go
     
Loading...