1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

CDOSYS and CDONTS simply don't work ?! (Very strange behavior)

Discussion in 'Plesk for Windows - 8.x and Older' started by Coolplay, Oct 4, 2008.

  1. Coolplay

    Coolplay Guest

    0
     
    Configuration:
    ==============
    1 Virtuozzo Hardware node running under W2K3 Datacenter x86 64bit Edition
    1 Container running W2K3 Datacenter x86 64bit Edition and of course running inside the above Virtuozzo node.
    1 Plesk 8.6 running into the above container.

    For info, Mail Enable is running into that Container for notification needs, and Plesk notification are going out normaly via Mail Enable SMTP server on the Container.

    What we need in extra to be operative before going into production with tha container:
    =================================================================
    The native CDOSYS component, AND ALSO the old CDONTS component and this because we don't want our clients to
    rewrite the pages who are using CDOSYS/CDONTS (on our old server) and so the migration will be transparent for them without script changes.

    Note: CDONTS was installed by following the Parallels KB: http://kb.odin.com/en/560


    Issue encountered:
    ==============
    We never managed to have the native CDOSYS component working and this for an unknow reason ??!! and even before installing the CDONTS on that container.
    AND THE SAME GOES for CDONTS component, not working either ??!!


    Of course, we took care to change the SMTP default Port 25 on IIS and changed it to 8025 in order to avoid conflict with defautl Mail Enable. We did alos tried (for test purpose) to stop Mail Enalble, restored port 25 on IIS SMTP ... no sucess either.

    For the CDOSYS/CDONTS test on that container, we have used 2 basic scripts (one for CDOSYS and one for CDONTS)
    Those scripts are used for test purpose on regular W2K3 servers (with no Virtuozzo nor Plesk installed on it) and they are working JUST FINE on such server.
    And so, a bad test script on our side is not the issue.

    Additional info:
    ===========
    When trying our CDOSYS Test script, we obtain the following error message:

    CDO.Message.1 error '80040220'
    The "SendUsing" configuration value is invalid.
    /cdosystest.asp, line 15

    Line 15 is equal to: myMail.Send

    When trying our CDONTS Test script, we obtain the following error message:

    Server object error 'ASP 0178 : 80070005'
    Server.CreateObject Access Error
    /cdontstest.asp, line 11
    The call to Server.CreateObject failed while checking permissions. Access is denied to this object.

    Line 11 is equal to: Set MAILCDO = Server.CreateObject("CDONTS.NewMail")

    Note: all the following folders are empty also after our test:
    C:\Inetpub\mailroot\Badmail
    C:\Inetpub\mailroot\Drop
    C:\Inetpub\mailroot\Mailbox
    C:\Inetpub\mailroot\Pickup
    C:\Inetpub\mailroot\Queue

    Resume:
    We crawled the web about this issue and problem seems apparently to be related to permissions,etc..
    In the mean time we tried to give some rights (read + Exec) to the .DLL's files without too much success.
    And as Plesk does is own config,etc.. we simply don't want to play around with permissions here and there but would like to make sure that the permissions are exactly the one needed to have CDO and CDONTS work.

    Maybe: We are asking ourselves if this could be maybe due to the OS Template used to create the container who is maybe missing that specific settings (especialy regarding the native CDOSYS Component)

    If somene did allready face the same issue, your recommendation or help would be greatly appreciated.
     
Loading...