1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

cgi-bin broken (debian)

Discussion in 'Plesk for Linux - 8.x and Older' started by DiLDoG, May 31, 2007.

  1. DiLDoG

    DiLDoG Guest

    0
     
    Hi, except for test.cgi my scripts wont run. I tried copying suexec but it didn't help. This is my log:

    error.log:
    Code:
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Failed loading /usr/lib/php5/ioncube/ioncube_loader_lin_5.2.so:  /usr/lib/php5/ioncube/ioncube_loader_lin_5.2.so: cannot open shared object file: No such file or directory
    suexec.log
    Code:
    [2007-06-01 01:40:27]: target uid/gid (10028/10001) mismatch with directory (10028/2523) or program (10028/10001)
    [2007-06-01 02:01:38]: uid: (10028/beachpirates) gid: (10001/10001) cmd: test.cgi
    [2007-06-01 02:01:41]: uid: (10028/beachpirates) gid: (10001/10001) cmd: progress.cgi
    [2007-06-01 02:01:41]: target uid/gid (10028/10001) mismatch with directory (10028/2523) or program (10028/10001)
    [2007-06-01 02:01:42]: uid: (10028/beachpirates) gid: (10001/10001) cmd: test.cgi

    Code:
    /var/www/vhosts/domain.tld/cgi-bin/test$ ls -al
    total 28
    drwxr-xr-x 2 fptuser psacln  4096 Jun  1 02:05 .
    drwxr-x--x 3 fptuser psaserv 4096 Jun  1 02:05 ..
    -rwxr-xr-x 1 fptuser psacln  1255 Jun  1 01:09 header.cgi
    -rwxr-xr-x 1 fptuser psacln   661 Jun  1 00:31 progress.cgi
    -rwxr-xr-x 1 fptuser psacln   662 Mar 30 00:45 test.cgi
    -rwxr-xr-x 1 fptuser psacln  4551 Jun  1 01:09 upload.cgi
    
    Code:
    /usr/lib/apache2$ ls -al
    total 68
    drwxr-xr-x  3 root root      4096 Jun  1 02:01 .
    drwxr-xr-x 51 root root     16384 May 29 22:47 ..
    drwxr-xr-x  2 root root      4096 May 30 10:21 modules
    -rwxr-xr-x  1 root www-data 10244 Mar 27 15:21 suexec
    -rwxr-xr-x  1 root www-data 18720 Jun  1 01:35 suexec2
    -rwsr-x---  1 root www-data 10596 Jul 28  2006 suexec2.saved_by_psa
    Does anyone know what I am doing wrong?
    Any help would be appreciated.

    Kind regards,
    Joris
     
  2. michaelst0ne

    michaelst0ne Guest

    0
     
    Hi,

    Please try the following steps,

    disable the line ,
    SuexecUserGroup <user> psacln
    in your http include file.
    Then,
    touch /usr/sbin/suexec

    Now restart apache and see if that helps also make sure the path of perl in the cgi script is /usr/bin/perl

    best of luck !
    Michael Stone
     
  3. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    For the error log part
    That means that the file you are trying to load into php does not exist. make sure that its in the right place, or change the php.ini file (if you have your loader specified somewhere else, then edit that file) to fix that.

    You can verify by typing php -V at the CLI

    for suexec log
    I believe that means that the user and group ownership is not set properly on the cgi files from what suExec expected to find.



    for
    it looks like you have unloaded (or never had) mod_suexec in apache. Look in your httpd.conf file and make sure you have it enabled. it should look similar to this (although it may not be exact)

    Code:
    LoadModule suexec_module modules/mod_suexec.so
    
    Good luck.
     
Loading...