1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

CGI-BIN not working

Discussion in 'Plesk for Linux - 8.x and Older' started by diness, Apr 10, 2005.

  1. diness

    diness Guest

    0
     
    I have a problem with my cgi-bin.
    I have uploaded several different cgi script to the cgi-bin, all has the right premissions set, but they all turn out with a server error.

    500 Internal Server Error.


    I uploaded some files to the web server and I can't seem to view them in a web browser. The files I uploaded have the following paths:

    /cgi-bin/listman/hello.cgi
    /cgi-bin/listman/hello.pl

    Try to reach them though here :

    http://mydomain/cgi-bin/listman/hello.cgi

    If I put a html file instead, there is no problems.
    What am I doing wrong?
     
  2. Matt.D

    Matt.D Guest

    0
     
  3. diness

    diness Guest

    0
     
    I can not access the log from my plesk controlpanel, it says domain id invailid.

    However, I find it odd that cgi is not working at alle - have tried several scripts. Something much be wrong with the apache server.

    what does plesk support says?
     
  4. Matt.D

    Matt.D Guest

    0
     
    Can I??

    According to the text of SW-soft web site, I am only entitled free support during the first 30 days after purchasing the plesk lisense.

    I have been using PLESK for over a year now. Hence my desperate crys for hep over the last few weeks after the upgrade to 7.5 version.

    Use of the PLESK platform is not our core business. We provide customer web applications (95% of our business), hosting is an additional service we provide. Its a mix between MS platforms and dedicated Linux boxes.

    The PLESK box is an extra to a couple of our customers, and currently it is causing us more grief that it is worh.......

    How can I go about solving this issue?
    Please help
     
  5. dirty@

    dirty@ Guest

    0
     
    search for "Internal Server Error" at faq.sw-soft.com and you'll find articles how to trace possible cgi script problem reasons..

    there may be independent 5-6 reasons as far as i remember, from broken suexec to ^M windows characters in scripts
     
  6. Matt.D

    Matt.D Guest

    0
     
    Thanks that helped allow:-

    >> http://faq.sw-soft.com/index.php?ToDo=view&questId=467&catId=90


    However, now its doing something new....

    If I run the script in shell, everything is fine, it rints the output. If I run the script through the browser, I still get the error page and the following entry in the error log:-

    Code:
    [2005-04-13 18:16:22]: uid: (10004/eaglenet) gid: (10001/10001) cmd: t2.pl
    [2005-04-13 18:16:22]: target uid/gid (10004/10001 or $ld) mismatch with directory (2523/10004) or program (2523/0)
    
    How come there is the id miss-match?
     
  7. diness

    diness Guest

    0
     
    My cgi-script is working after I changed the ftpusername to : ftpuser.
     
  8. Matt.D

    Matt.D Guest

    0
     
    where? in proftpd.conf?
     
  9. diness

    diness Guest

    0
     
    I just changed the ftp login in Plesk - in the setup hosting.

    username : ftpuser

    Then it was working, pretty odd.
     
  10. pwgen

    pwgen Guest

    0
     
    Hi there!

    please check that you have correct permissions to the cgi-bin directory and all its subdirectories:

    FTPUSER:psacln

    where FTPUSER is one that has been defined from the control panel: Domains -> DOMAIN.COM -> Setup -> Ftp user.

    or:

    #grep DOMAIN.COM /etc/passwd

    Further you may use the following command to fix recursive:

    #chown -R FTPUSER:psacln cgi-bin
     
  11. panaman

    panaman Guest

    0
     

    I am getting the same error..

    strange how one domain works fine
     
Loading...